Ubuntu

Totem BBC plugin cannot connect

Reported by Alan Pope ㋛ on 2010-02-26
94
This bug affects 16 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: totem

Open Totem, choose BBC from the panel on the left. Get an error "Could not connect to server.". It worked in the past.

See screenshot.

ProblemType: Bug
Architecture: i386
Date: Fri Feb 26 22:12:53 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
Package: totem 2.29.91-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: totem
Uname: Linux 2.6.32-14-generic i686

Alan Pope ㋛ (popey) wrote :
Dave Morley (davmor2) on 2010-02-26
Changed in totem (Ubuntu):
status: New → Confirmed
Dave Jones (dgjones) wrote :

I've just test this & can confirm the bug, same "could not connect to server" message after about a minute of attempting to connect.

Craig H. (craig-87) wrote :

I have just tested this and mine will not connect at all, it doesn't even attempt to.

scottuss (scottuss) wrote :

I have just tried this, and I get the Could not connect to server error

Matthew Paul Thomas (mpt) wrote :

I have experienced this problem since Wednesday 24th.

The Totem BBC plugin tries to retrieve <http://open.bbc.co.uk/rad/uriplay/availablecontent>. On Wednesday, loading this in a browser returned a 500 Internal Server Error. Today, I have tried it twice. The first time it took over a minute to respond, but eventually returned the desired programming data. The second time it returned a 500 Internal Server Error. ("Apache/2.2.3 (Red Hat) Server at uriplay.rad0.net Port 80".)

So, I think it's nothing to do with iPlayer registration, and everything to do with the uriplay.rad0.net server being overloaded or misconfigured.

Matthew Paul Thomas (mpt) wrote :

(And now I look at the downloaded file more closely, I see it's truncated, so Totem probably wouldn't be able to parse it anyway.)

Sitsofe Wheeler (sitsofe) wrote :

The plugin appears to be somewhat working for me (although the items under Science & Technology seem to span more than the title suggests (e.g. Hotel California: LA from the Byrds to the Eagles).

scottuss (scottuss) wrote :

In addition to what Bruce Cowan said, Ars Technica report that this could be down to the BBC SWF verification: http://arstechnica.com/open-source/news/2010/02/bbc-blocks-open-source-software-from-iplayer-video-service.ars?utm_source=rss&utm_medium=rss&utm_campaign=rss

Sebastien Bacher (seb128) wrote :

note that the iplayer and the bbc code are diffferent ones and using different bbc servers and ressources, the iplayer one will likely be broken by the recent changes but the bbc one shouldn't

Changed in totem (Ubuntu):
importance: Undecided → Low
George Wright (george-dexy) wrote :

Hi there

This plugin comes out of my team (R&D Prototyping), built alongside Collabora/ Canonical.

We have some downstream (from this service) connectivity problems which are hampering our ability to diagnose what looks like a probable server misconfiguration. I can connect intermittently to the service (stock Karmic) from my home box but it's very flaky.

We are working to fix this and will update when we have. Please note this is unrelated to any other change that the BBC may have made to other services.

Regards

George

ChrisDesjardins (cddesjardins) wrote :

Thanks George. Is there an update on this? I'm still experiencing this as of 27 March 2010 and it would be great to see this fixed prior to Lucid's release as it's a great service.

Sebastien Bacher (seb128) wrote :

George thanks for the comment, the server is still not working though, do you know if there is any chance that will change before lucid or should we change totem to stop listing the option?

Alex Cockell (alcockell) wrote :

Still not connecting...

Sent mail to the BBC asking for status of the server

Sebastien Bacher (seb128) wrote :

the server seems to be back; closing the bug

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
Changed in totem (Ubuntu):
status: Fix Released → New
Sebastien Bacher (seb128) wrote :

the server seems to reply now but some users have been having parsing issue with the list, it works fine for me on lucid right now, I will check on that later and update the bug

Robert Ancell (robert-ancell) wrote :

Checked today and this url just returns an empty page

Changed in totem (Ubuntu):
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

Can someone update about this bug ?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in totem (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for totem (Ubuntu) because there has been no activity for 60 days.]

Changed in totem (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers