Volume of totem browser plugin on minimum

Bug #527432 reported by Alexander Hunziker on 2010-02-24
90
This bug affects 19 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: totem

When I use Firefox to listen to Swiss DRS3 radio (www.drs3.ch, then click on "Radio Ein"), the popup window opens and radio starts playing using the totem plugin, but I can't hear anything, because in pulseaudio's mixer, the channel for the totem plugin is on the minimum position. after increasing that slider in the volume control, i can hear the radio.

ProblemType: Bug
Architecture: i386
Date: Wed Feb 24 23:35:24 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100128) (Final release affected too).
Package: totem-mozilla 2.29.4-0ubuntu2 (Totem Browser Plugin 2.30.0 & GStreamer 0.10.28)
ProcEnviron:
 LANG=en_DK.utf8 (en_US.utf8)
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: totem
Uname: Linux 2.6.32-14-generic i686

To clarify: When reloading the page with the embedded player, the volume will be reset to zero again.

tags: added: amd64
Changed in totem (Ubuntu):
status: New → Confirmed

I can also recreate this bug by getting the following webpage with firefox, which has streamed video:
http://www.suono.jp/ondemand/?id=1790

Lucid 10.04 RC,
totem - 2.30.0git20100413-0ubuntu1
totem-mozilla - 2.30.0git20100413-0ubuntu1
firefox - 3.6.3+nobinonly-0ubuntu3

Chris Beswick (doobry) wrote :

I also have this bug with all the video's I tried using firefox at:

http://trailers.apple.com/

Video's play fine if you manually set the volume every time you start one, and the stand alone totem application remembers its volume settings.

Lucid 10.04 RC
totem - 2.30.0git20100413-0ubuntu1
totem-mozilla - 2.30.0git20100413-0ubuntu1
firefox - 3.6.3+nobinonly-0ubuntu4

bgruber (bgruber) wrote :

The default volume setting for the plugin seems to be the gconf key /apps/totem/volume. If the key isn't present I get a default volume of 0. Totem (the app, not the plugin) seems to remember its volume somewhere else (not sure where).

Thanks bgruber :) Yes adding a /apps/totem/volume key with gconf fixes it.

$ gconftool --type int --set /apps/totem/volume 100

Juan J. Martínez (jjmartinez) wrote :

I confirm that the tip of Richard Croy works with Lucid UNE. Thank you!

Yep, workaround as described in 6 works.

Cross (strokemeister) wrote :

Okay, I can confirm this bug in Lucid (Final release) 10.04 fully updated.

Any final fix?

description: updated
description: updated
Bob Huber (bobhuber) wrote :

I have the same bug in trying to play an embedded MP3 file in Firefox. The fix listed above did NOT work for me.
AMD64 Lucid Final (all updates installed) Firefox 3.6.3

Bob Huber (bobhuber) wrote :

Correction- The above fix worked when logged in as a normal user without root privileges.

I have the same bug on my 32-bit notebook using the final version of ubuntu 10.04 . I can observe it when trying to listen to pronunciation of words on www.m-w.com . I do not complain that just clicking on the amplifier icon does not work. What I mean is that if I then open the sound sample with default audio player (totem), the player starts with volume level set to zero.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers