Totem don't auto load .txt subtitles

Bug #448900 reported by Przemysław Kochański on 2009-10-11
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Totem
Won't Fix
Medium
totem (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

.txt subs are not being loaded automatically loaded even with auto-load subs option enabled. .srt and other subs work fine. Selecting subtitle file from menu works for all subs, including .txt. Checked on multiple movies and subtitles.

ProblemType: Bug
Architecture: i386
Date: Sun Oct 11 19:54:38 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/totem
Package: totem 2.28.1-0ubuntu1
ProcEnviron:
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.43-generic
SourcePackage: totem
Uname: Linux 2.6.31-13-generic i686

Kåre Birger Lapstuen (lapstue) wrote :

I'm having the same problem.

Changed in totem (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in totem (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

upstream says that's not a bug but to use filenames for subtitles

Changed in totem (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Invalid

file names of movie and subs are the same. only extension differs. and auto-load is enabled.

Changed in totem (Ubuntu):
status: Invalid → Confirmed

Bugfix: just add
 "txt",
to 264 line in /src/totem-uri.c

autoload works, but I'm now experiencing bug #441396

Sebastien Bacher (seb128) wrote :

upstream said they will not use txt because there is no way to know if those are subtitle or not, rename your subtitle to use a correct naming

Changed in totem (Ubuntu):
status: Confirmed → Invalid
Vish (vish) wrote :

As per comment #8

Changed in hundredpapercuts:
status: New → Invalid
fsx@o2.co.uk (fsx) wrote :

There is no such file "/src/totem-uri.c" in Ubuntu 9.10 and Totem 2.28.2

Igor Wojnicki (wojnicki) wrote :

Sebastien, Could you ask upstream if there is any other reason for not loading subtitles for a file ending with .txt, please ?
This very behavior, loading .txt as well as .srt subtiltes, is implemented by some other players such as mplayer and xine (and as far as I know a couple of standalone DVD/DivX players also).

I'm a little bit confused by the upstream statement that they will not use .txt since it's hard to tell if it is a subtitle file or not. There are a couple of subtitle standards anyway, so one way or the other upon upening a subtitle file there has to be an algorithm implemented which detects the subtitle standard and read it. So what's wrong with trying both .srt and .txt files then? I can't see any explanation.

Pedro Villavicencio (pedro) wrote :

Igor, why not doing that yourself? anybody can comment on the upstream bug tracker : https://bugzilla.gnome.org/show_bug.cgi?id=598156 ; Thanks.

Changed in totem:
importance: Unknown → Medium
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.