totem crashed with SIGABRT in __kernel_vsyscall()

Bug #421318 reported by Felipe Besoain on 2009-08-30
282
This bug affects 44 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Critical
totem (Ubuntu)
High
Ubuntu Desktop Bugs
Karmic
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

I was watching a video, in format .rmbv and when I close the app, this crashed it!

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/totem
Package: totem 2.27.2-0ubuntu4
ProcCmdline: totem /home/username/Desktop/p-Fightng178/p-Fightng178.rmvb
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-8.28-generic
Signal: 6
SourcePackage: totem
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 Py_FatalError () from /usr/lib/libpython2.6.so.1.0
 PyEval_SaveThread () from /usr/lib/libpython2.6.so.1.0
Title: totem crashed with SIGABRT in __kernel_vsyscall()
Uname: Linux 2.6.31-8-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Felipe Besoain (fbesoain) wrote :
Changed in totem (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in totem (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
sierdzio (sierdzio) wrote :

crashes every time I attempt closing Totem with a video still playing.

Tharakan (tharakan) wrote :

1. Easily reproducible (In my case it was a simple MP3 file which was playing perfectly in 9.04 (I have just upgraded to 9.10))

2. Just play an mp3 song, in my case the two times it crashed, the Visualizations were on fullscreen. I did a third time without the fullscreen, and it exited properly

jonathan (jcwhiteford) wrote :

This also happens for me, however now that it has crashed say 5 times, all the videos i try to play will either:

1)not play
2)play, but without sound
3)play but very jumpy all the way through
4)play at superfast speed.

Pedro Villavicencio (pedro) wrote :

we got a few duplicates about this, it's pretty easy to reproduce; Open totem and close it , make sure there's at least one plugin enabled like the BBC one; on the terminal it says:

Fatal Python error: PyEval_SaveThread: NULL tstate
Aborted (core dumped)

and the backtrace is the same as the one in this report. Marking this as confirmed. Thanks for reporting.

Changed in totem (Ubuntu):
status: Incomplete → Confirmed
Changed in totem (Ubuntu):
milestone: none → ubuntu-9.10-beta
Changed in totem (Ubuntu):
status: Confirmed → Triaged
Changed in totem:
status: Unknown → New
Martin Pitt (pitti) wrote :

To the reporters: This is an useful bug report, so thanks for sending it.

However, I'm a bit puzzled since Apport (the crash detector/reporting user interface) is not actually supposed to send these bugs (for the technically inclined: it is an assert failure, but Apport could not extract the assertion message).

When you filed this, did you see this text anywhere?

  'The program crashed on an assertion failure, but the message could not be retrieved. Apport does not support reporting these crashes.'

How did you send the crash report, through the "totem has crashed" window which pops up automatically, or with "ubuntu-bug"?

Matthew Woerly (nattgew) wrote :

Apport told me it was an assertion failure...

Nizar Kerkeni (nizarus) wrote :

@Martin : When I try to report the bug with apport I have the message you cite.
I reported the same bug with ubuntu-bug : bug 431107

Martin Pitt (pitti) wrote :

@Nizar, @Nattgew: So apport told you that it can't send the crash report, but sent it anyway?

Nizar Kerkeni (nizarus) wrote :

In my case apport don't send it after totem crash and I created my bug report manually with ubuntu-bug.

oli z (oliver-z) wrote :

assertion failures are not send automaticaly to launchpad
never!
i have the same problem and this sucks

Changed in totem (Ubuntu Karmic):
importance: Medium → High
Matthew Woerly (nattgew) wrote :

I reported mine manually, too.

Dmitry Tantsur (divius) wrote :
Download full text (4.3 KiB)

Totem 2.28

Starting program: /usr/bin/totem
[Thread debugging using libthread_db enabled]
[New Thread 0xb7577b70 (LWP 3589)]
[New Thread 0xb6d76b70 (LWP 3590)]
[New Thread 0xb62b3b70 (LWP 3591)]
Fatal Python error: PyEval_SaveThread: NULL tstate

Program received signal SIGABRT, Aborted.
0x00f59422 in __kernel_vsyscall ()
(gdb) back
#0 0x00f59422 in __kernel_vsyscall ()
#1 0x023b34d1 in *__GI_raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2 0x023b6932 in *__GI_abort () at abort.c:92
#3 0x008a547f in Py_FatalError (msg=0x91b4b8 "PyEval_SaveThread: NULL tstate")
    at ../Python/pythonrun.c:1657
#4 0x00881db6 in PyEval_SaveThread () at ../Python/ceval.c:318
#5 0x016c7f8d in ?? ()
   from /usr/lib/pymodules/python2.6/gtk-2.0/gobject/_gobject.so
#6 0x008264f4 in dict_dealloc (mp=0x8b8602c) at ../Objects/dictobject.c:911
#7 0x016c7f32 in ?? ()
   from /usr/lib/pymodules/python2.6/gtk-2.0/gobject/_gobject.so
#8 0x008435fd in subtype_dealloc (self=0x87e1cac)
    at ../Objects/typeobject.c:1024
#9 0x0809c942 in totem_python_object_finalize (object=0x85141c8)
    at totem-python-plugin.c:217
#10 0x003433e3 in IA__g_object_unref (_object=0x85141c8)
    at /build/buildd/glib2.0-2.21.6/gobject/gobject.c:2421
#11 0x080998e0 in totem_plugin_info_free (info=0x853ec88)
    at totem-plugins-engine.c:415
#12 0x00e3e4b8 in g_hash_table_remove_all_nodes (
    hash_table=<value optimized out>, notify=<value optimized out>)
    at /build/buildd/glib2.0-2.21.6/glib/ghash.c:374
---Type <return> to continue, or q <return> to quit---
#13 0x00e3edea in IA__g_hash_table_remove_all (hash_table=0x850a350)
    at /build/buildd/glib2.0-2.21.6/glib/ghash.c:1052
#14 0x00e3efdd in IA__g_hash_table_destroy (hash_table=0x850a350)
    at /build/buildd/glib2.0-2.21.6/glib/ghash.c:759
#15 0x08099799 in totem_plugins_engine_shutdown ()
    at totem-plugins-engine.c:445
#16 0x08068ad7 in totem_object_plugins_shutdown () at totem-object.c:353
#17 0x0806974f in totem_action_exit (totem=0x8203808) at totem-object.c:896
#18 0x0806a28d in main_window_destroy_cb (widget=0x8273bb8, event=0x82bb560,
    totem=0x8203808) at totem-object.c:954
#19 0x010fe6c8 in _gtk_marshal_BOOLEAN__BOXED (closure=0x82285a0,
    return_value=0xbffff014, n_param_values=2, param_values=0x8bcc9b8,
    invocation_hint=0xbffff000, marshal_data=0x806a270)
    at /build/buildd/gtk+2.0-2.17.11/gtk/gtkmarshalers.c:84
#20 0x003410f2 in IA__g_closure_invoke (closure=0x82285a0,
    return_value=0xbffff014, n_param_values=2, param_values=0x8bcc9b8,
    invocation_hint=0xbffff000)
    at /build/buildd/glib2.0-2.21.6/gobject/gclosure.c:767
#21 0x00357af8 in signal_emit_unlocked_R (node=<value optimized out>,
    detail=<value optimized out>, instance=0x8273bb8,
    emission_return=0xbffff15c, instance_and_params=0x8bcc9b8)
    at /build/buildd/glib2.0-2.21.6/gobject/gsignal.c:3247
#22 0x00358d98 in IA__g_signal_emit_valist (instance=0x8273bb8, signal_id=60,
---Type <return> to continue, or q <return> to quit---
    detail=0,
    var_args=0xbffff1c0 "\354\361\377\277\070\357\037\b\210\207", <incomplete sequence \355>) at /build/buildd/glib2.0-2.21.6/gobject/gsignal.c:2990
#23 0x00359396 ...

Read more...

Paolo Stivanin (polslinux) wrote :

me too!

Sebastien Bacher (seb128) wrote :

there is a feature to confirm you get the issue, click on the text between the bug table saying that the bug affects you too rather than adding comments

Martin Pitt (pitti) wrote :

This is not serious enough to block the beta release IMHO.

Changed in totem (Ubuntu Karmic):
importance: High → Medium
Martin Pitt (pitti) on 2009-09-25
Changed in totem (Ubuntu Karmic):
milestone: ubuntu-9.10-beta → ubuntu-9.10
importance: Medium → High

Steve,

You had mentioned that the Foundations Team can offer help on tough crashers. We're have a bit of a time debugging this one. Would it be possible to get some assistance tracking down the cause of this crasher? Thanks.

Changed in totem (Ubuntu Karmic):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Steve Langasek (vorlon)
Steve Langasek (vorlon) wrote :

Rick, I don't believe I'm going to have any time to work on this bug this week personally; perhaps it's best to ask another member of the foundations team to look at it?

Martin Pitt (pitti) wrote :

Reassigning back to desktop team for now. Robert, do you have some time to look at this? If not, please reassign back to me.

Anyone else is of course welcome to help out as well.

Changed in totem (Ubuntu Karmic):
assignee: Steve Langasek (vorlon) → Robert Ancell (robert-ancell)

Lars - robbiew suggested that you might be able to crack this but

Changed in totem (Ubuntu Karmic):
assignee: Robert Ancell (robert-ancell) → Lars Wirzenius (liw)

uh, for "but", read "nut"

to be removed (liw) wrote :

I can reproduce this using Pedro's instructions. Originally I had two plugins enabled (which surprised me), one for BBC, one for Youtube. With just Youtube, I don't get the bug. With just BBC I do, so I assume the plugin is in the BBC plugin.

Chris Coulson (chrisccoulson) wrote :

I've only ever seen this with the BBC plugin too

Chris Coulson (chrisccoulson) wrote :

Lars - the Youtube plugin is not a Python plugin though, so I wouldn't expect to see the same issue there.

to be removed (liw) wrote :

I can reproduce this, using Pedro's instructions, on jaunty.

to be removed (liw) wrote :

This patch fixes the problem for me on karmic. It is from Alessandro Decina, of Collabora, I just packaged into into debian/patches and tested it.

Sebastien Bacher (seb128) wrote :

Thanks Lars, the change will be in the next upload

Changed in totem (Ubuntu Karmic):
status: Triaged → Fix Committed
assignee: Lars Wirzenius (liw) → Ubuntu Desktop Bugs (desktop-bugs)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.28.0-0ubuntu2

---------------
totem (2.28.0-0ubuntu2) karmic; urgency=low

  * debian/patches/71_totem_python_gil.patch: Handle the Python global
    interpreter lock correctly when closing totem. (Closes: LP: #421318)

 -- Lars Wirzenius <email address hidden> Thu, 01 Oct 2009 15:06:27 +0300

Changed in totem (Ubuntu Karmic):
status: Fix Committed → Fix Released
WalterCool (waltercool) wrote :

IDK if is the same problem:

waltercool@miniCompu:~$ gdb -exec totem
GNU gdb (GDB) 7.0-ubuntu
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
(gdb) run
Starting program: /usr/bin/totem
[Thread debugging using libthread_db enabled]
[New Thread 0xb7a15b70 (LWP 24420)]
[New Thread 0xb7214b70 (LWP 24421)]

(totem:24416): GLib-GObject-WARNING **: IA__g_object_set_valist: object class `GstPlayBin2' has no property named `queue-size'
[New Thread 0xb67f3b70 (LWP 24422)]
[New Thread 0xb5ff2b70 (LWP 24423)]
[New Thread 0xb57f1b70 (LWP 24424)]
[New Thread 0xb4cfeb70 (LWP 24425)]
[New Thread 0xb03f7b70 (LWP 24426)]
[Thread 0xb03f7b70 (LWP 24426) exited]

Program received signal SIGABRT, Aborted.
[Switching to Thread 0xb57f1b70 (LWP 24424)]
0x00361422 in __kernel_vsyscall ()
(gdb) back
#0 0x00361422 in __kernel_vsyscall ()
#1 0x0736a4d1 in raise () from /lib/tls/i686/cmov/libc.so.6
#2 0x0736d932 in abort () from /lib/tls/i686/cmov/libc.so.6
#3 0x03889217 in MPV_frame_start () from /usr/lib/i686/cmov/libavcodec.so.52
#4 0x06b2bff4 in ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Tim Müller (t-i-m-zen) wrote :

WalterCool: this looks like a completely different problem (looks like a totem version / gstreamer0.10-plugins-base version mismatch)

Changed in totem:
importance: Unknown → Critical
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.