Online media streams that use WMA2 WMAS audio codec do not play

Bug #418984 reported by rusivi2 on 2009-08-26
62
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Wishlist
Baltix
Undecided
Unassigned
ffmpeg (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by rusivi2
Nominated for Karmic by rusivi2
gstreamer0.10-ffmpeg (Ubuntu)
Low
Unassigned
Nominated for Jaunty by rusivi2
Nominated for Karmic by rusivi2
totem (Ubuntu)
Low
Unassigned
Nominated for Jaunty by rusivi2
Nominated for Karmic by rusivi2
vlc (Ubuntu)
Low
Unassigned
Nominated for Jaunty by rusivi2
Nominated for Karmic by rusivi2

Bug Description

Binary package hint: totem

1) lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

2) apt-cache policy totem
totem:
  Installed: 2.26.1-0ubuntu5
  Candidate: 2.26.1-0ubuntu5
  Version table:
 *** 2.26.1-0ubuntu5 0
        500 http://us.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

3) I expected the separate window of Bloomberg TV via "Launch Video Player" at website:

http://www.bloomberg.com/tvradio/tv/index.html

would play both audio and video in sync, with no delay.

4) Instead, I see the video play flawlessly but hear no audio. Audio is not muted or turned down low, and plays perfectly fine if using hulu.com videos for example.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/totem/gstreamer/totem-plugin-viewer
NonfreeKernelModules: fglrx
Package: totem-gstreamer 2.26.1-0ubuntu5
ProcAttrCurrent: unconfined
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux 2.6.28-11-generic i686

komputes (komputes) wrote :

There are a few issues reported against bloomberg.com :
Crash when playing video - Bug #419000
Content Encoding Error caused by ad in video (I think) - Bug #375784

The link you sent seems to play a flash video and not a totem video. The video is an ad and plays fine (with sound). Can you please include more detail on how to reproduce this issue.

-Are you always able to reproduce this?
-Actions to reproduce the bug.
-Expected result of actions.
-Actual result of actions.

Changed in totem (Ubuntu):
status: New → Incomplete
komputes (komputes) wrote :

Also, just to make sure we are talking about the same pop-up window which plays muted video, please include a screenshot if possible, thank you.

Thank you for addressing this bug.

Regarding your questions:

-Are you always able to reproduce this?

Yes. Everytime the video pop-up launches it's video plays great, no sound.

A fellow Ubuntu user I know personally tried the recommendations at the following link:

http://ubuntuforums.org/showthread.php?t=1024820

and the video worked, but the sound was choppy, and lagged a couple seconds behind.

 I have tried other Synaptic Package Manager permutations from a fresh install of Ubuntu 9.04, full updating via Update Manager, and with/without Medibuntu repository packages (all packages listed were clicked, and all default recommendations to uninstall/install packages were accepted as presented):

1) Fresh install, full updates only.

No video, no sound.

2) Fresh install, full updates.

mozilla-plugin-vlc

Plays video but no sound.

3) fresh install, full updates, Medibuntu repository addition, Medibuntu updates.

mozilla-mplayer
w32codecs
non-free-codecs

Plays video but no sound.

4) fresh install, full updates, Medibuntu repository addition, Medibuntu updates.

gstreamer0.10-fluendo-mp3
non-free-codecs
ubuntu-restricted-extras

Plays video but no sound.

Attached is a screenshot of the same setup I bugged about.

komputes (komputes) wrote :

I am marking this bug as confirmed as I have tested this myself. The issue gets worse in karmic which simply crashes instead of proposing plugins.

The link to test is:
http://bloomberg.com/avp/avp.htm?clipSRC=LiveBTV

This uses the totem plugin, and requires a package that can decode proprietary microsoft protocols. On a base install, going to this page will make totem pop up, proposing to search for packages that can read this stream. It is not able to find any packages to fit this need.

gstreamer0.10-plugins-ffmpeg - black screen, no proposal of plugins presented, totem plugin shows "Playing 0:00 (Streaming)"

gstreamer0.10-plugins-bad - proposes to search for plugins, which recommends gstreamer0.10-plugins-ugly

gstreamer0.10-plugins-ugly - once all three installed, I got a second of video then I was proposed more plugins, which failed because there was no package found for Windows Media Speech decoder.

w32codecs/w64codecs (medibuntu) - saw video for a second, makes no difference Windows Media Speech decoder is still needed.

Looking for bugs of people who have experienced the same thing, I found Bug #298189 and Bug #301120 which also explain the same issue. Looking at the ubuntuforums link you provided. I got the idea to try it in VLC. From the totem plugin window menu, I select "Copy" which copies the source of the video, which in this case was:

mms://a627.l2479952251.c24799.g.lm.akamaistream.net/D/627/24799/v0001/reflector:52251

I pasted this into vlc's Open > Network Stream bar, which gave me the video, but no audio. I also got the error:

No suitable decoder module: VLC does not support the audio or video format "wmas". Unfortunately there is no way for you to fix this.

So in fact totem is not failing, the plugins in ubuntu repositories are enough for the video, but since it can't decode the audio the totem plugin stops there. Whats missing is libdmo_plugin.so which is the WMA2/WMAS decoder module.

So in conclusion, this bug is a request to include the WMA2/WMAS audio codecs to the gstreamer plugin packs and to vlc. If there are any issues with doing this please comment on this bug.

Changed in totem (Ubuntu):
status: Incomplete → Confirmed
komputes (komputes) wrote :

As The request is to add WMA2/WMAS audio codec support to one of the flowing packages, I tried reporting it against them, but only -ffmpeg is available in Launchpad.

gstreamer0.10-plugins-ffmpeg
gstreamer0.10-plugins-bad
gstreamer0.10-plugins-ugly

komputes (komputes) wrote :

The libdmo_plugin.so codec module can be found here:
 http://ubuntuforums.org/attachment.php?attachmentid=97969&d=1230581757

komputes (komputes) on 2009-08-28
summary: - Bloomberg TV Does Not Play Sound
+ Online media streams that use WMA2 WMAS audio codec do not play
Changed in vlc (Ubuntu):
status: New → Confirmed
Changed in totem (Ubuntu):
importance: Undecided → Low
Changed in vlc (Ubuntu):
importance: Undecided → Low
Changed in gstreamer0.10-ffmpeg (Ubuntu):
importance: Undecided → Low
WolphFang (mjoyner-vbservices) wrote :

a) Where does the libdmo_plugin.so supposed to be put?
b) Is it i386 only?, x64 only?, both?

WolphFang:

a) I followed the links I posted above word for word regarding where to copy libdmo_plugin.so

b) I only tried the above mentioned tests in a 32-bit environment.

Changed in totem:
status: Unknown → Confirmed
Reinhard Tartler (siretart) wrote :

ffmpeg itself can playback wmav2 material for years (modulo various kind of broken encoders). See http://wiki.multimedia.cx/index.php?title=WMA2 for more information on that codec.

btw, it would really help if you would attach a proper sample file that we can test. surfing to a javascript and advertisment overloaded website is not appropriate for a bug with the current bugtitle.

Changed in ffmpeg (Ubuntu):
status: New → Invalid
Reinhard Tartler (siretart) wrote :

vlc plays back http://samples.mplayerhq.hu/A-codecs/WMA2/nintendothemesacappellax.wmv for me just fine.
So nothing to fix in vlc.

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
Changed in totem:
status: Confirmed → Fix Released
komputes (komputes) wrote :

Upstream bug report corrected. Reported upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=603284

Changed in totem:
status: Fix Released → Unknown
tags: added: codec
komputes (komputes) wrote :

@ Reinhard Tartler

Unfortunately, the file you tested is not the same as the one comming in off the stream. As the upstream bug says, you need to take the actual stream and play it in VLC to objectively veryfy this bug.

The stream address looks like this:
mms://a1149.l1305038288.c13050.g.lm.akamaistream.net/D/1149/13050/v0001/reflector:38288

I think it changes from time to time, so if you do not want to fuss with the javascript on the site, just ping me on IRC and I will give you a valid stream address to analyses for that time.

Also, please make sure you test this on Ubuntu 9.10 with vlc 1.0.2-1ubuntu2 from the ubuntu universe repository.

Changed in vlc (Ubuntu):
status: Fix Released → New

Updated to Ubuntu 9.10, installed mediaconnectivity 0.9.2, and installed packages:

w32codecs (20071007-0medibuntu5)
gstreamer0.10-ffmpeg (0.10.9-1)
gstreamer0.10-fluendo-mp3 (0.10.7.debian-1ubuntu1)
gstreamer0.10-plugins-ugly (0.10.12-1)
liba52-0.7.4 (0.7.4-11ubuntu1)
libdvdnav4 (4.1.3-3)
libdvdread4 (4.1.3-5ubuntu2)
libid3tag0 (0.15.1b-10build1)
libmpeg2-4 (0.4.1-3)
libsidplay1 (1.36.59-5)
libtwolame0 (0.3.12-1)

and all video media streams work as desired.

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
Changed in vlc (Ubuntu):
status: New → Fix Released
Changed in gstreamer0.10-ffmpeg (Ubuntu):
status: New → Fix Released
shivam (shivam-alang) on 2010-02-04
Changed in vlc (Ubuntu):
status: Fix Released → Fix Committed
komputes (komputes) wrote :

I have tested this recently and I can confirm that the example media given in the bug description (Bloomberg LiveBTV) is viewable with both totem and vlc.

Benjamin Drung (bdrung) on 2010-04-15
Changed in vlc (Ubuntu):
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Wishlist
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.