Screensaver not inhibited while playing movies in browser

Bug #381116 reported by Nicolò Chieffo on 2009-05-27
98
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem (Ubuntu)
Low
Robert Ancell
Karmic
Low
Robert Ancell

Bug Description

Binary package hint: totem

Using gnome-power-manager 2.26.1-0ubuntu3.
Totem is not capable to stop the screen blanking: after the timeout set in the gconf keys to control gnome-power-manager, the screen is blanked even if totem is playing a video.
This is a karmic problem.

the problem is not in gnome-screensaver, because I've disabled it and set the time as 2 ours.

ProblemType: Bug
Architecture: amd64
Date: Thu May 28 01:04:23 2009
DistroRelease: Ubuntu 9.10
Package: totem 2.26.2-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-6.7-generic
SourcePackage: totem
Uname: Linux 2.6.30-6-generic x86_64

Nicolò Chieffo (yelo3) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Do you use totem-gstreamer or totem-xine? Is there anything in the --debug log?

 This will help us to find and resolve the problem.

Changed in totem (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete

Ok let's answer:
- always reproducible (current version is totem-2.27.1-1ubuntu3)
- steps:
   * run gnome-power-preferences
   * set the display to sleep time to 1 minute (so you don't have to
wait for a long time)
   * play a video with totem
   * wait 2 minutes (don't know why but it's one minute more than the
one you've chosen)
   * you'll get your screen blanked
- The xine backend is no more available, only gstreamer
- the --debug shows lots of times during the startup this message:
   (totem:12842): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display:
assertion `atom != GDK_NONE' failed

The issue is an upstream one and the bug should be sent to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME) by somebody having it

Changed in totem (Ubuntu):
status: Incomplete → New
Changed in totem:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in totem (Ubuntu):
status: New → Triaged
Nicolò Chieffo (yelo3) wrote :

As you can see the DPMS is called, as if totem was not running.

Scott Howard (showard314) wrote :

I believe I can help this one a bit:

From Richard Hughes' blog:
http://blogs.gnome.org/hughsie/2009/01/28/inhibits-and-the-new-world-order/

inhibit is now a method of:
org.gnome.SessionManager

The API and documentation is now in gnome session manager, and the GPM inhibit
is no longer in GPM 2.27+.

Most likely totem has to switch to using gnome-session-manager's inhibit, and not GPM's inhibit.

http://bugzilla.gnome.org/show_bug.cgi?id=472812

Scott Howard (showard314) wrote :

More information from the author of GPM (Richard Hughes), this was sent to the gnome-power-manager developer mailing list:

Okay, after having F11 g-p-m blank the screen on me (not using
nouveau, that's a separate issue) whilst watching some short videos in
totem yesterday, I got really angry.

I've audited all the IDLETIME code in gnome-power-manager, and when
I've run it in a console and watched the output, it all seems to work
100% okay. It only seems to fall over gnome-session is involved with
handling inhibits.

So, we have working:

GPMIDLEDEBUG=1 gnome-power-manager

...wait 10 seconds...

IDLETIME fires the idle alarm expired (and g-p-m dims the screen)

...move the mouse...

IDLETIME fires the reset alarm expired

then I issue an inhibit request to org.gnome.SessionManager with
parameters ('moo',0,'testing',8) using d-feet and get back a cookie
like normal. Session becomes inhibited.

...wait 10 seconds...

IDLETIME fires the idle alarm expired (but g-p-m doesn't dim the
screen, as the session is inhibited from totem)

...move the mouse...

NOTHING. No event from X.

...close d-feet...

the inhibit gets auto-revoked, session becomes non-inhibited, and
g-p-m assumes that x has been idle for a long time, and also the
session is not inhibited, and so switches off the screen. You can see
this using GPMIDLEDEBUG as the second icon is a box, not a computer
icon.

Now g-p-m is confused, and has to be restarted before it will reset
the new idletime counter. You can't reproduce with the original
idlecounter-demo program when using XNextEvent, but you can as soon as
you hook into gdk with gdk_window_add_filter. It really looks like
something is doing GDK_FILTER_REMOVE on the reset alarm at some point.

As an aside, it appears totem is inhibiting using gnome-screensaver as
a proxy, although I don't this this is the problem as it also can be
done using d-feet.

After looking in the forums, this problem looks like it's triggered
lots, and by many different users. I would appreciate any help here.

Richard.

Scott Howard (showard314) wrote :

Richard Hughes, the author of gnome-power-manager, has written a bodge in the most recent version of Karmic gnome-power-manager (2.27.5) [1] to prevent screen blanking when using inhibit in gnome-session or xsync. Could you test it to see if it is now working properly (a daily liveCD of karmic should do [2])? Thanks in advanced.

He wrote:
"There's no bug in gnome-power-manager, and I suspect gnome-session somehow triggers this bug. There's a full writeup in http://blogs.gnome.org/hughsie/2009/07/30/accidental-blanking-and-gnome-power-manager/ but I've got next-to-no help in debugging gnome-session or the XSync alarms stuff. "

[1] http://git.gnome.org/cgit/gnome-power-manager/commit/?id=b5cf34d4b9861ab916a3ff74a2a08093ccb75b9f
[2] http://cdimage.ubuntu.com/daily-live/current/

tags: added: regression-potential
Changed in totem (Ubuntu):
milestone: none → ubuntu-9.10
summary: - totem does not inhibit screen blanking
+ Screensaver not inhibited while playing movies

The screen just blanked on me while playing a video, so I'd say the bug is still present. totem is at 2.28.1-0ubuntu1.

Scott Howard (showard314) wrote :

There seems to be several related upstream bugs. It has something to do with totem and gnome screensaver:
https://bugzilla.gnome.org/show_bug.cgi?id=554750 (***This seems the most like this bug)

https://bugzilla.gnome.org/show_bug.cgi?id=567908
https://bugzilla.gnome.org/show_bug.cgi?id=598173
https://bugzilla.gnome.org/show_bug.cgi?id=580562

and somewhat related, bug #448438

Changed in totem:
status: New → Unknown
Sebastien Bacher (seb128) wrote :

The bug is fixed in git and will be fixed in karmic too

Changed in totem (Ubuntu):
status: Triaged → Fix Committed
enedene (enedene) wrote :

The same problem for VLC after upgrade to karmic. Does this fix apply for VLC too?

Sebastien Bacher (seb128) wrote :

The issue fixed in git is in the webbrowser player though, I still can't confirm the issue using the standalone totem player on karmic

Martin Pitt (pitti) on 2009-10-29
Changed in totem (Ubuntu Karmic):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Ancell (robert-ancell)
Martin Pitt (pitti) wrote :

Accepted totem into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I get screen blanking regardless of the program running and regardless of the power management and screensaver settings. For instance, when the screensaver is disabled and all screen blanking settings in power management are set to at least 1 hour, the screen blanks anyway after 10 minutes or so. This happens while watching full screen flash (megavideo), web browsing, etc.

Ubuntu 9.10 Karmic
Intel 945GM video chipset

FrenchNux (christophe-pauc) wrote :

same issue after testing totem 2.28.2 in ubuntu-proposed

black screen after 10 minutes.
Screensaver not inhibited while playing movies with totem or VLC

Changed in totem (Ubuntu):
status: Fix Committed → New
Sennaista (sennaista) wrote :

Same problem with VLC. Even though I have asked for screensaver to be inhibited it sitll comes up regardless of settings in VLC.

Sebastien Bacher (seb128) wrote :

there is several bugs described there in comments that's not really working, the issue fixed is specific to the firefox mode not the software player there

Martin Pitt (pitti) wrote :

The general "broken screensaver inhibition" issue is bug 428884 (for standalone players). So let's use this for the browser plugin. Can you please test this one? Thanks!

Changed in totem (Ubuntu):
milestone: ubuntu-9.10 → none
summary: - Screensaver not inhibited while playing movies
+ Screensaver not inhibited while playing movies in browser
Changed in totem (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.28.2-0ubuntu1

---------------
totem (2.28.2-0ubuntu1) karmic-proposed; urgency=low

  * New upstream release: (LP: #463102)
    - Movie Player:
      - Fix possible crash on exit when using Python plugins
      - Fix warning when displaying file tooltip in the playlist
      - Fix help links not showing up in error messages (LP: #452510)
      - Fix "disabling screensaver when audio is playing" checkbox
        never turning off (or on)
      - Fix play order when removing currently playing song
    - Web browser plugin:
      - Fix screensaver not being stopped when playing movies (LP: #358297)
        (LP: #381116)
      - Fix parsing of playlist files when using WebKit
      - Add support for midi files
    - GStreamer backend:
      - Fix possible hang on startup
      - Fix DVB channels file not being detected properly
      - Fix warning when creating a screenshot
      - Use cubic volumes when PulseAudio is used
      - Fix intermittent pixel-aspect-ratio warnings
  * debian/patches/03_screensaver_preferences.patch:
  * debian/patches/71_totem_python_gil.patch:
  * debian/patches/91_git_change_fix_dvb_issue.patch:
    - Applied upstream

 -- Robert Ancell <email address hidden> Thu, 29 Oct 2009 16:30:01 +1100

Changed in totem (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied karmic-proposed to lucid.

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Changed in totem (Ubuntu Karmic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.28.2-0ubuntu2

---------------
totem (2.28.2-0ubuntu2) karmic-proposed; urgency=low

  * debian/patches/05_youtube_regex.patch:
    - Fix YouTube plugin (LP: #459423)
  * debian/patches/06_playlist.patch:
    - Start from beginning when switching to next video in playlist
      (LP: #466620)

totem (2.28.2-0ubuntu1) karmic-proposed; urgency=low

  * New upstream release: (LP: #463102)
    - Movie Player:
      - Fix possible crash on exit when using Python plugins
      - Fix warning when displaying file tooltip in the playlist
      - Fix help links not showing up in error messages (LP: #452510)
      - Fix "disabling screensaver when audio is playing" checkbox
        never turning off (or on)
      - Fix play order when removing currently playing song
    - Web browser plugin:
      - Fix screensaver not being stopped when playing movies (LP: #358297)
        (LP: #381116)
      - Fix parsing of playlist files when using WebKit
      - Add support for midi files
    - GStreamer backend:
      - Fix possible hang on startup
      - Fix DVB channels file not being detected properly
      - Fix warning when creating a screenshot
      - Use cubic volumes when PulseAudio is used
      - Fix intermittent pixel-aspect-ratio warnings
  * debian/patches/03_screensaver_preferences.patch:
  * debian/patches/71_totem_python_gil.patch:
  * debian/patches/91_git_change_fix_dvb_issue.patch:
    - Applied upstream

 -- Robert Ancell <email address hidden> Wed, 04 Nov 2009 09:28:04 +1100

Changed in totem (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to lucid.

Changed in totem (Ubuntu Karmic):
status: Fix Released → Fix Committed
Steve Langasek (vorlon) on 2009-11-10
Changed in totem (Ubuntu Karmic):
milestone: ubuntu-9.10 → karmic-updates
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.28.2-0ubuntu3

---------------
totem (2.28.2-0ubuntu3) karmic-proposed; urgency=low

  * debian/patches/07_disable_web_browser_midi.patch:
    - Disable MIDI support in totem web browser plugin as Karmic's gstreamer
      doesn't support streaming MIDI files over HTTP (LP: #463102)

totem (2.28.2-0ubuntu2) karmic-proposed; urgency=low

  * debian/patches/05_youtube_regex.patch:
    - Fix YouTube plugin (LP: #459423)
  * debian/patches/06_playlist.patch:
    - Start from beginning when switching to next video in playlist
      (LP: #466620)

totem (2.28.2-0ubuntu1) karmic-proposed; urgency=low

  * New upstream release: (LP: #463102)
    - Movie Player:
      - Fix possible crash on exit when using Python plugins
      - Fix warning when displaying file tooltip in the playlist
      - Fix help links not showing up in error messages (LP: #452510)
      - Fix "disabling screensaver when audio is playing" checkbox
        never turning off (or on)
      - Fix play order when removing currently playing song
    - Web browser plugin:
      - Fix screensaver not being stopped when playing movies (LP: #358297)
        (LP: #381116)
      - Fix parsing of playlist files when using WebKit
      - Add support for midi files
    - GStreamer backend:
      - Fix possible hang on startup
      - Fix DVB channels file not being detected properly
      - Fix warning when creating a screenshot
      - Use cubic volumes when PulseAudio is used
      - Fix intermittent pixel-aspect-ratio warnings
  * debian/patches/03_screensaver_preferences.patch:
  * debian/patches/71_totem_python_gil.patch:
  * debian/patches/91_git_change_fix_dvb_issue.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden> Wed, 11 Nov 2009 09:47:30 +0100

Changed in totem (Ubuntu Karmic):
status: Fix Committed → Fix Released
Pieter (diepes) wrote :

I found this bug looking for a reason gmplayer does not inhibit the screensaver.
$ uname -a
Linux pumba 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

Changed in totem:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.