Totem firefox plugin can't launch apple HD trailers

Bug #368252 reported by Jason Erbskorn on 2009-04-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Jaunty by Robert Ancell

Bug Description

Binary package hint: totem-mozilla

Description: Ubuntu 9.04
Release: 9.04

Installed x86_64 variant

totem-mozilla:
  Installed: 2.26.1-0ubuntu5
  Candidate: 2.26.1-0ubuntu5
  Version table:
 *** 2.26.1-0ubuntu5 0
        500 http://us.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Totem-mozilla package fails to create a new window when selecting (left click) HD trailers from www.apple.com/trailers, using Firefox. This bug can be worked around by opening the movie in a new tab or window using right click. Adding www.apple.com to the pop-up unblock list does not solve the situation. This is a regression from Ubuntu 8.10, where this functioned perfectly.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * What error do you get?

 This will help us to find and resolve the problem.

Changed in totem (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Jason Erbskorn (mrguy) wrote :

Setup: This bug is reproducible using a stock Ubuntu 9.04 x64 desktop installation. I have ubuntu-restricted-extras installed.

Reproducibility Steps: Go to any HD trailer on www.apple.com/trailers (http://www.apple.com/trailers/paramount/startrek/hd/ for example). Try to watch a trailer by clicking on one of the HD options (720p for example).

Error: HD trailer will not launch, nothing happens

Sebastien Bacher (seb128) wrote :

the issue is an upstream GNOME one

Changed in totem (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Robert could you have a look to that bug?

Changed in totem (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

stdout from firefox when left-clicking on the movie link

Robert Ancell (robert-ancell) wrote :

stdout from firefox when middle-clicking (i.e. open in new tab) on the movie link

Robert Ancell (robert-ancell) wrote :

stdout from firefox when manually loading movie link. This causes the movie to be displayed.

Robert Ancell (robert-ancell) wrote :

I built and installed the old Ubuntu 8.10 totem (2.24.2) on 9.04 and it didn't fix the problem. Looking at the source for http://www.apple.com/trailers/paramount/startrek/hd/ it appears that something in the javascript may be causing the plugin to be called with the wrong arguments. If you hand-write a simple page with an equivalent link it works.

Possibly a firefox bug?

Robert Ancell (robert-ancell) wrote :

Using the firefox DOM inspector shows clicking on this element calls the following:
function anonymous(e) {
    s_objectID = "http://movies.apple.com/movies/paramount/star_trek/startrek-clip_480p.mov_1";
    return this.s_oc ? this.s_oc(e) : true;
}

Robert Ancell (robert-ancell) wrote :

I have tried this with the 8.10 live CD and the behaviour appears to be the same. It may be that Apple has changed the HTML/JS in their website since then. I've forwarded this upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=580973

Changed in totem (Ubuntu):
status: New → Triaged
assignee: Robert Ancell (robert-ancell) → Ubuntu Desktop Bugs (desktop-bugs)
Changed in totem:
status: Unknown → New
Robert Ancell (robert-ancell) wrote :

Upstream has confirmed this is a change in the Apple site code and fixed Totem to handle the missing plugin parameter "autohref"

Changed in totem (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.26.2-0ubuntu1

---------------
totem (2.26.2-0ubuntu1) karmic; urgency=low

  * New upstream version:
   - Add support for autohref, makes trailers on the Apple website work again
     (LP: #368252)
   - Add the cache subtitles directory to the subtitle file selection dialogue's
     shortcuts (LP: #366647)
   - Fix resolve_uri returning an empty URI when trying to resolve
     with a base at the root of a webserver (LP: #362820)

 -- Robert Ancell <email address hidden> Wed, 06 May 2009 12:03:08 +0200

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Changed in totem:
status: New → Fix Released
Patricio (patricio-stwing) wrote :

How do I install this fix in Ubuntu 9.04?
My Totem is 2.26.1 and shows as up to date.
I tried http://launchpadlibrarian.net/26388371/totem-plugins_2.26.2-0ubuntu1_i386.deb but it gave me some dependency problems.
Same problem if I use: http://packages.ubunut.com/ko/karmic/i386/totem/download
I guess this is what you call backport? Is there a backport for Jaunty.
I hope I am using the right language.

Patricio (patricio-stwing) wrote :

This is the error: Error: Dependency is not satisfiable: libgstreamer-plugins-base0.10-0 (>= 0.10.23)

Changed in totem:
importance: Unknown → Medium
zzecool (zzecool) wrote :

Bug is still here in Ubuntu 10.10

Totem Movie Player 2.32.0
Movie Player using GStreamer 0.10.30
vlc mozilla plugin (with totem support)

HD and left click = no

Right click open in new tab or new window works great though

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.