Unnecessary depends

Bug #349325 reported by Bruce Cowan on 2009-03-27
2
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Undecided
Unassigned
muine (Ubuntu)
Wishlist
David Futcher
totem (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

It would appear that GStreamer is opening files with the GnomeVFS plugin. AFAIK Totem doesn't actually need this package any more, so it should no longer depend on it.

Related branches

thank you for reporting this problem, it helps make Ubuntu better. Confirmed.

Changed in totem:
status: New → Confirmed
Changed in totem (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist

In other words, Banshee, Muine and Totem should no longer depend on
gstreamer0.10-gnomevfs?
--
Chow Loong Jin

Yes, AFAIK they should use giosrc instead.

Chow Loong Jin (hyperair) wrote :

On Fri, 2009-03-27 at 18:36 +0000, Bruce Cowan wrote:
> Yes, AFAIK they should use giosrc instead.
>
I see. So basically, if gstreamer0.10-gnomevfs is dropped, it'll
automatically use giosrc?
--
Chow Loong Jin

Playbin(2) should handle it.

Chow Loong Jin (hyperair) wrote :

On Fri, 2009-03-27 at 21:09 +0000, Bruce Cowan wrote:
> Playbin(2) should handle it.
>
Fixed in Banshee packaging for Debian, but not uploaded, because it's a
very minor change.

  affects ubuntu/banshee
  status fixcommitted
--
Chow Loong Jin

Changed in banshee:
status: New → Fix Committed
David Futcher (bobbo) on 2009-04-01
Changed in muine (Ubuntu):
assignee: nobody → bobbo
importance: Undecided → Low
status: New → In Progress
importance: Low → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muine - 0.8.10-1ubuntu2

---------------
muine (0.8.10-1ubuntu2) jaunty; urgency=low

  * debian/control: Remove un-needed dependency on gstreamer0.10-gnomevfs (LP: #349325)
  * src/{Metadata.cs, SongDatabase.cs}: Apply patch (inline) to fix crashing when
    song metadata changed by an external application (LP: #62408)

 -- David Futcher <email address hidden> Wed, 01 Apr 2009 16:03:58 +0100

Changed in muine:
status: In Progress → Fix Released
Chow Loong Jin (hyperair) wrote :

Fixed in 1.4.3-4

Changed in banshee (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

totem (2.27.1-1ubuntu5) karmic; urgency=low

  * debian/control.in:
    - remove gstreamer0.10-gnomevfs from Depends; dependency was removed in
      version 2.23.4. (LP: #361151)

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers