GStreamer encountered a general supporting library error.

Bug #336597 reported by aashee on 2009-03-02
62
This bug affects 13 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: totem

hi
when i wanna see any video from youtube and other websites, they all are running in firefox browser,but when i save them in my personal files or i download them for next use many of them are not running in totem player and ther is a messege ,,,,,,,,,,,,,,,,,GStreamer encountered a general supporting library error. what is this when a video was running in mozilla browser then why not in totem again ,pls help (<email address hidden>.)
thanks muhammad arshad .pk

ProblemType: Bug
Architecture: i386
Date: Mon Mar 2 14:51:15 2009
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/totem-gstreamer
Package: totem-gstreamer 2.22.1-0ubuntu3
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux 2.6.24-23-generic i686

aashee (alpha-19-20-yahoo) wrote :
Pedro Villavicencio (pedro) wrote :

could you run totem from the command line as totem &> totem.txt perform the operation to try to watch the videos ? do you have installed the gstreamer ffmpeg codecs?

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!

Changed in totem (Ubuntu):
status: Incomplete → Invalid
Poltiser (poltiser) wrote :

for some reason after upgrade to 9.1 totem does not play youtube - gstreamer general library error

Changed in totem (Ubuntu):
status: Invalid → New
Saivann Carignan (oxmosys) wrote :

I confirm this bug, and it also happens with totem in jaunty now, therefore make me thinking that this is due to some changes in the youtube website or video formats, not in ubuntu itself.

Changed in totem (Ubuntu):
status: New → Confirmed
cronocopio (firefoxbt) wrote :

leo@ubuntu:~$ totem
/var/lib/python-support/python2.6/gdata/tlslite/utils/cryptomath.py:9: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
** Message: Error: GStreamer encountered a general supporting library error.
gstffmpegdemux.c(1209): gst_ffmpegdemux_open (): /GstPlayBin:play/GstDecodeBin:decodebin0/ffdemux_swf:ffdemux_swf0:
Input/output error

To reproduce this error

1 open Totem
2 activate Sidebar
3 from drop-down menu select "youtube"
4 type "preslava"
5 click Find
6 play any video

I confirm this bug, and it also happens with totem in Ubuntu 9.10 (Karmik Koala) RC. I tried to watch a lot of videos but the problem persist.

misiu_mp (misiu-mp) wrote :

This must be an upstream bug as I have it on Fedora 11 too (using totem 2.26.3 and gstreamer 0.10.25).

Kai Jauch (kaijauch) wrote :

I ran totem with --gst-debug-level=2, ffmpeg complains:
   "Compressed SWF format not supported".

I downloaded the file it tried to play back, "file" states: "Macromedia Flash data (compressed), version 8"
Apparently ffmpeg can deal with those files if they are decompressed with cws2fws first (I did not try it).

FFmpeg version SVN-r19352-4:0.5+svn20090706-2ubuntu2
totem 2.28.1

Jan Nekvasil (jan-nekvasil) wrote :

I suggest to set importance of this bug to High - ubuntu boasts about this feature directly on http://www.ubuntu.com/products/whatisubuntu/910features/, so it would be really embarrassing for all to see new users trying this feature in 9.10 with current state of things.

Sebastien Bacher (seb128) wrote :

Don't reopen closed bugs because you have what you think is the same issue often they are different issues, bug #459423 is the currently used bug on karmic versions you can subscribe to this one

Changed in totem (Ubuntu):
status: Confirmed → Invalid
status: Invalid → New
status: New → Invalid

Confirm in Karmic

PCZahra (pczahra06) wrote :

videos do not play in Totem due to "GStreamer encountered a general supporting library error."

Changed in totem (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers