intrepid: BBC plugin: "Could not connect to server"

Bug #290537 reported by Ian Mackenzie on 2008-10-29
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: totem

Using Intrepid rc, updated this morning,

I read about the plugin at http://www.chiark.greenend.org.uk/ucgi/~cjwatson/blosxom/2008/10/27#2008-10-27-totem-bbc-plugin and tried it. ie, started "Movie player" from Applications | Sound and Video , and then clicked the dropdown saying "playlist", and clicked on "BBC".

Instant response "Could not connect to server" on both EeePC 901 talking wireless & desktop talking ethernet to my DSL connection.

I'm in NZ, so I wondered if this was a "feature" of the BBC server, but the other bugs I looked at suggest that there is plenty of international content available.

lsb_release -rd:
Description Ubuntu 8.10
Release 8.10

apt-cache policy totem:
totem:
 Installed: 2.24.2-0ubuntu4
 Candidate: 2.24.2-0ubuntu4
 Version table:
***2.24.4-0ubuntu4 0
          500 http://nz.archive.ubuntu.com intrepid/main Packages
          100 /var/lib/dpkg/status

George Wright (george-dexy) wrote :

Hi

I run the team at the BBC working with Canonical/ Collabra on this.

We're moving this to our live infra and servers now (to coincide with the release tomorrow)

It'll be temporarily unavailable during this time. Don't worry about you not being in the UK - lots of content is available outside the UK - although some is only cleared for UK.

George

Colin Watson (cjwatson) wrote :

I've just confirmed that the BBC feed is back up and that totem can connect to it fine.

Changed in totem:
status: New → Fix Released
Max Randor (max-randor) wrote :

I am still experiencing this problem, I have experienced this problem since I first upgraded to the intrepid beta.
As it only says that it Could not connect to server, I cannot diagnose where the problem more accurately, it is not in the firewall, and everything should work fine if it is using http/https though I am behind a proxy so it could be some kind of network issue but I just can't tell. Running totem from the terminal provides no additional information.
totem --debug
** (totem:10365): DEBUG: Init of Python module
** (totem:10365): DEBUG: Registering Python plugin instance: BBCViewer+TotemPythonPlugin
** (totem:10365): DEBUG: Creating object of type BBCViewer+TotemPythonPlugin
** (totem:10365): DEBUG: Creating Python plugin instance
** (totem:10365): DEBUG: Init of Python module
** (totem:10365): DEBUG: Registering Python plugin instance: YouTube+TotemPythonPlugin
** (totem:10365): DEBUG: Creating object of type YouTube+TotemPythonPlugin
** (totem:10365): DEBUG: Creating Python plugin instance
** (totem:10365): DEBUG: Finalizing Python plugin instance
** (totem:10365): DEBUG: Finalizing Python plugin instance

Is Ian Mackenzie? still experiencing this problem?

George Wright (george-dexy) wrote :

Hi

Confirmed that the feed works from our end.

BUT - I have had previous problems with proxies - despite proxies being set correctly in the gnome session, if I was being corporate firewall, there would be issues.

Perhaps this is something where totem isn't picking up proxies correctly? I only suggest this as when it connects via open internet, there are no problems

George

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers