MythTV support is missing

Bug #278748 reported by Björn Torkelsson
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: totem

The latest version of totem available in Intrepid is missing MythTV support, which is a regression from hardy.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: openafs
Package: totem-plugins-extra 2.24.1-0ubuntu1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
 LC_NUMERIC=en_US.UTF-8
SourcePackage: totem
Uname: Linux 2.6.27-4-generic x86_64

Related branches

Revision history for this message
Björn Torkelsson (torkel) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

the mythtv version in intrepid is not recent enough to enable the option in the current version

Changed in totem:
importance: Undecided → Wishlist
Revision history for this message
Björn Torkelsson (torkel) wrote :

Sure it is:

torkel@skruttibangbang:/scratch/totem-2.24.2$ grep gmyth configure.in
   PKG_CHECK_MODULES(GMYTH, gmyth >= 0.7.1 gmyth-upnp >= 0.7.1,

torkel@skruttibangbang:/scratch/totem-2.24.2$ pkg-config --modversion gmyth gmyth-upnp
0.7.1
0.7.1

It needs to build depends on both libgmyth-dev and libgmythupnp-dev though. Depending on only libgmyth-dev is not enough.

Revision history for this message
Sebastien Bacher (seb128) wrote :

the required version were not available when the update has been done and some are in universe so they can't be used right now, it would require to have somebody interested in the option to get those promoted before changing the option

Revision history for this message
Björn Torkelsson (torkel) wrote :

So you can't Build-Depend on universe stuff for packages that end up in universe (totem-plugins-extra)? Didn't know that. Sorry for the noise then.

Revision history for this message
Didier Roche (didrocks) wrote :

The new version have some support for this and will make it for jaunty

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.25.3-0ubuntu1

---------------
totem (2.25.3-0ubuntu1) jaunty; urgency=low

  * New upstream version:
   Interface changes: (LP: #303045)
    - Make the left-click seek directly to the destination
    - Hide colour balance sliders that aren't available (LP: #282073)
    - Make modifiers work as expected when drag'n'dropping files
    - Use "Movie Player" everywhere in the interface
    - Add an arrow to the sidebar button (LP: #260534)
    - Convert British English messages to American English
    - Show the fullscreen popups when seeking with the keyboard (LP: #48751)
    - Better behaviour when changing the type of playlist to be saved
    - Fix playlist problems when removing an file that was deleted
      from the filesystem
   Subtitle handling:
    - Add plugin to download text subtitles from OpenSubtitles.org
    - Allow selecting a text subtitle from the View menu, or by dropping
      the file onto the video widget (LP: #160518)
    - Add the subtitle and languages menus to the fullscreen popup
   Browser plugin:
    - Remove the "basic" web browser plugin, we now use the same
      API as VideoLAN for our default plugin
    - Fix relativbzre paths not resolving in some cases
    - Fix repeat=true only playing files twice
   Plugins:
    - Add Jamendo plugin
    - Add support for streaming TV from MythTV (LP: #278748)
    - Fix YouTube movie playback following website changes
    - Make the local search and YouTube search sidebars look more alike
    - Add proper mute support for remote controls
    - Fix the metadata-updated signal to be useful
   Build:
    - Remove libgnome dependency
    - Remove NVTV support
    - Use g_timeout_add_seconds() when possible
   GStreamer backend:
    - Require the rsndvdbin plugin for DVD playback
    - Add zoom support
    - Fix some files not giving us metadata with the video indexer
    - Fix the video window getting bigger than the screen (LP: #221795)
    - When streaming, the pause button stops
   Other:
    - Add ability to create a gallery image using the video thumbnailer
      (LP: #282435)
  * Update debian/watch to take unstable GNOME version
  * debian/control.in:
    - add Vcs-Bzr tag
    - remove libgnome2-dev, libgnomeui-dev and libgnome-keyring-dev as b-d
      as upstream does not depend anymore from libgnome
  * Adapt patches to new configure.in:
    - debian/patches/02_lpi.patch
    - debian/patches/65_bbc-plugin.patch
  * Re-regenate debian/patches/70_autotools.patch and debian/control

 -- Didier Roche <email address hidden> Wed, 07 Jan 2009 19:20:37 +0100

Changed in totem:
status: New → Fix Released
Revision history for this message
Richard Ayotte (rich-ayotte) wrote :

I'm running Jaunty now and Totem does not have the MythTV plugin installed. I have the totem-plugins and totem-plugins-extra packages installed.

Here's what I have in my /usr/lib/totem/plugins

drwxr-xr-x 2 root root 4096 2009-04-18 10:07 bbc
drwxr-xr-x 2 root root 26 2009-04-18 10:02 bemused
drwxr-xr-x 2 root root 81 2009-04-18 10:02 brasero-disc-recorder
drwxr-xr-x 2 root root 64 2009-04-20 19:58 coherence_upnp
drwxr-xr-x 2 root root 51 2009-04-20 19:58 gromit
drwxr-xr-x 2 root root 67 2009-04-18 10:02 jamendo
drwxr-xr-x 2 root root 72 2009-04-18 10:02 lirc
drwxr-xr-x 2 root root 73 2009-04-18 10:02 media-player-keys
drwxr-xr-x 2 root root 49 2009-04-18 10:02 ontop
drwxr-xr-x 2 root root 99 2009-04-18 10:02 opensubtitles
drwxr-xr-x 2 root root 71 2009-04-18 10:02 properties
drwxr-xr-x 2 root root 121 2009-04-18 10:07 pythonconsole
drwxr-xr-x 2 root root 61 2009-04-18 10:02 screensaver
drwxr-xr-x 2 root root 76 2009-04-18 10:02 screenshot
drwxr-xr-x 2 root root 67 2009-04-18 10:02 skipto
drwxr-xr-x 2 root root 57 2009-04-18 10:02 thumbnail
drwxr-xr-x 2 root root 43 2009-04-18 10:07 totem
drwxr-xr-x 2 root root 53 2009-04-18 10:02 tracker
drwxr-xr-x 2 root root 85 2009-04-18 10:07 youtube

Revision history for this message
Pobice (robert-pobice) wrote :

No MythTV plugin on my system either (upto date Jaunty system)

Revision history for this message
Pobice (robert-pobice) wrote :

Theres a couple of missing dependencies from the control file (libgmyth-dev and libgmythupnp-dev) however it would appear the plugin doesn't work anyway as even when I got it to compile with the plugin I get an error when totem fires up with this plugin enabled and it makes no attempt to contact my mythtv box.

Revision history for this message
Pobice (robert-pobice) wrote :

It does work, my mistake - screw up on mythtv setup...

Anyway I've upload a working package with the pluggin to my ppa
https://launchpad.net/~robert-pobice/+archive/ppa

And raised a new bug #365750

Revision history for this message
axelsvag (darinsson) wrote :

I do not consider it working i jaunty. Because you can not not do any settings as you could in apps menu before. Even if the plugin is there in totem.

Revision history for this message
Nixus Maximus (srenaud) wrote :

Mythtv-Plugin again not implemented in Karmic

Changed in totem (Ubuntu):
status: Fix Released → New
Revision history for this message
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs because you have a similar issue

Changed in totem (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers