Totem crashed when i open a new file

Bug #27297 reported by Johan Van Hellemont on 2005-12-18
22
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Medium
Sebastien Bacher

Created an attachment (id=5390)
backtrace from totem

(In reply to comment #1)
> Created an attachment (id=5390) [edit]
> backtrace from totem
>
This's on a Dapper Flight 2 with updates
Sorry forget this,its my first time here on bugzilla

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Does it happen when you open any file or on a particular
one (is it somewhere on the web to download?)?

(In reply to comment #3)
> Thanks for your bug. Does it happen when you open any file or on a particular
> one (is it somewhere on the web to download?)?

It happens with any file (avi,wmv...)
It happens also when i open the sidebar,the first movie add normaly,when i add
the second movie totem-xine crashed.
From a terminal i het this :

johan@dapper:~$ totem

(totem:8665): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion
`gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

(totem:8665): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion
`gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

Onkar Shinde (onkarshinde) wrote :

I confirm this bug. I have some more information to add. I am using totem-xine
from Breezy-Backports (which essentially means that it is frrom dapper).

totem-xine : 1.2.1-0ubuntu1~breezy1
totem : 1.2.1-0ubuntu1~breezy1

More info: Totem crashes when I try to add new songs to playlist in sidebar
while there are already songs in playlist and some song already playing or
paused. Also this is true only about mp3 files. If there are ogg files in
playlist then it won't crash.

I will add backtrace generated by bug-buddy

Onkar Shinde (onkarshinde) wrote :

Created an attachment (id=5396)
Backtrace created by bug-buddy after totem crash

(In reply to comment #4)
> It happens also when i open the sidebar,the first movie add normaly,when i add
> the second movie totem-xine crashed.

I have this problem too (totem-xine and up to date Dapper) :

1) open Totem
2) open playlist/sidebar
3) click the "plus " button to add one song : the song starts playing automatically
4) click the "plus" button again, and add another song : totem crashes.

I attached a valgrind trace if that helps (took 10 minutes to produce ! ;-)

Created an attachment (id=5483)
valgrind trace

Sebastien Bacher (seb128) wrote :

Thanks for the comments, the backtrace matches
http://bugzilla.gnome.org/show_bug.cgi?id=324240 which is fixed upstream

Sebastien Bacher (seb128) wrote :

*** Bug 27818 has been marked as a duplicate of this bug. ***

Sebastien Bacher (seb128) wrote :

Should be fixed with dapper. Feel free to reopen if you have the issue again

Changed in totem:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.