[Dapper] Totem hangs once started

Bug #27231 reported by Trouilliez vincent on 2005-12-17
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Medium
Sebastien Bacher

Bug Description

That's on a Dapper Flight-2 plus updates : when I start totem (gstreamer), the
GUI pops up fine, but it hangs there. The GUI is completely un-responsive,
whatever I click on, it doesn't react.

When started from a terminal, I get this:

$ totem
(totem:5227): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion
`gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
(totem:5227): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion
`gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
*** glibc detected *** free(): invalid pointer: 0x082a1360 ***

I tried totem-xine, and it works fine. It gives the same Gtk errors, but not the
glibc / invalid pointer one.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Could you start it from gdb and get a backtrace?
- gdb totem
(gdb) handle SIG33 pass nostop noprint
(gdb) run
... hang
(gdb) thread apply all bt

Do you try to open a video or just to run the application?

(In reply to comment #1)
>Could you start it from gdb and get a backtrace?
> - gdb totem
> (gdb) handle SIG33 pass nostop noprint
> (gdb) run
> ... hang
> (gdb) thread apply all bt

Thanks for the instructions (first time I use gdb...)
I attached the result. However it's filled with "(no debugging symbols found)"
messages :-/
Is there a way to get more info from totem ? Maybe recompile it with some
special flag or something ??

> Do you try to open a video or just to run the application?

I tried both, and the result is exactly the same.

Created an attachment (id=5374)
gdb backtrace

same here.

Sebastien Bacher (seb128) wrote :

Does it still happen with totem 1.3.0? Could any of you get a debug backtrace
(https://wiki.ubuntu.com/DebuggingProgramCrash) or get a valgrind log of the issue?

Sebastien Bacher (seb128) wrote :

Cc-ing the other submitter so he gets comments too. Could you get a backtrace of
a valgrind log for it?

(In reply to comment #5)
> Does it still happen with totem 1.3.0?

Yes, nothing has changed.

> Could any of you get a debug backtrace
> (https://wiki.ubuntu.com/DebuggingProgramCrash)

I still get the same error at the command line, but I attached a new gdb
backtrace anyway, see attached...

> or get a valgrind log of the issue?

Would love to, as soon as you tell me what a "valgrind" log is, and how to get
one...

Created an attachment (id=5451)
gdb backtrace with totem 1.3.0-0ubuntu2

Sebastien Bacher (seb128) wrote :

Thanks for the backtrace, it's not easy to figure what is the issue from it
though. For the valgrind log that's easy, install the valgrind package, run
"valgrind totem" and copy the text to a comment. valgrind makes things quite
slow though you just have to be patient (can take like 1 min to display the
totem window)

> For the valgrind log that's easy, install the valgrind package, run
> "valgrind totem" and copy the text to a comment. valgrind makes things quite
> slow though you just have to be patient (can take like 1 min to display the
> totem window)

Thanks, it was easy, and produced lots of info for a change ;-)
Too much (300 lines) to put in a comment, so I attached it instead.

There is something new : when run via valgrind, totem behaves differently.
Instead of just loading the GUI and hanging, it loads the GUI, then the GUI
disappears a second later, then it pops up an error dialog that says:

------------------------
Totem could not start up

The video output is in use by another application.
Please close other video applications,
or select another video output in the Multimedia Systems Selector.
-----------------------

That's strange, as I had no other applications using video when I ran valgrind.
And even then, normally I can watch XawTV and play a video simultaneously with
Totem, and it all works fine.

Created an attachment (id=5455)
valgrind log

Sebastien Bacher (seb128) wrote :

What videosink is configured with gstreamer-properties? Does changing it fix
your issue? What xorg driver (/etc/X11/xorg.conf) do you use?

(In reply to comment #12)
> What videosink is configured with gstreamer-properties?

I don't know anything about all this multimedia stuff, so I just left the
default Dapper setting, in this case: "XWindows (X11/XShm/Xv)"

> Does changing it fix your issue?

Oh ! Yes ! :o)
I tried the two other available settings ("XWindows (No Xv)" and "SDL Simple
DirectMedia Layer") and both work fine (and I can still watch TV at the same
time :-)

> What xorg driver (/etc/X11/xorg.conf) do you use?

I use the "mga" driver, it's for my old 2D PCI Matrox Millennium II (2MB) card.
It's a bit slow, but I use it because the picture quality is significantly
better (sharper/neater) than the on-board Geforce2 MX that's on the motherboard
(nForce).

Sebastien Bacher (seb128) wrote :

Thank for your comment and following on the bug.

It seems that the mga driver doesn't do xv, Daniel is that right?

Works for me now.

Sebastien Bacher (seb128) wrote :

marking as fixed then

Changed in totem:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.