Ubuntu

Real Player stream is garbled on BBC radio

Reported by Michael Doube on 2008-04-14
16
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Medium
gst-plugins-ugly0.10 (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned
totem (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

When I try to listen to the Real Player stream or old shows on BBC Radio 1, I get totally garbled output in my headphones.

The Real Player stream is affected:

http://www.bbc.co.uk/radio/aod/networks/radio1/live.shtml

But the Windows media stream is fine:

http://www.bbc.co.uk/radio/aod/networks/radio1/wmp.shtml?9all

I'm using Hardy Beta, 64-bit, all updates applied as of today.

TEST CASE
make sure you have gstreamer0.10-plugins-ugly installed, and dont have realplayer installed (or anything else that may try to play realplayer streams)
visit http://www.bbc.co.uk/radio/aod/networks/radio1/live.shtml or http://www.bbc.co.uk/radio/aod/radio4.shtml
observe how the audio stream sounds horribly jumbled (no that not just what modern music sounds like)

now with the patched version, go to the same page, and the audio will be clear.

Michael Doube (michael-doube) wrote :

And if I try to open the stream directly in Totem:

http://www.bbc.co.uk/radio1/realaudio/media/r1live.ram

The same thing happens.

Michael Doube (michael-doube) wrote :

If I remove gstreamer0.10-plugins-ugly, I get no sound whatsoever, then when I reinstall it I get the same garbled output so I guess the bug is in the codec.

Roderic Jones (rodericj) wrote :

I have had this problem but have found a work around. BBC Radio Player produced garbled sound in Hardy Beta, Release Candidate and in the final release version. I installed Firefox 2 and uninstalled and reinstalled the gstreamer plugins and the BBC radioplayer works perfectly in Firefox 2. Firefox 3 still produces garbled sound. I think the problem is with Firefox.

Michael Doube (michael-doube) wrote :

Roderic

I just installed a bunch of plugins and media handlers as well as following your suggestions and now have un-garbled BBC Radio 1 in Firefox 2

What plugin is handling the Real Audio stream for you in Firefox 2? Can you please attach the output from typing

about:plugins

in the address bar.

Mike

Michael Doube (michael-doube) wrote :

OK, I have the same problem with FF3: mplayer plugin is installed and handling Real Audio streams but the output is garbled still.

Michael Doube (michael-doube) wrote :

Actually, running firefox-3.0 at the command line revealed that totem was handling the stream and failing dismally. Removing totem and helix player and making sure that mplayer was installed fixed it for me. This is not a bug in FF3, it is in totem or its codecs.

Diagnosis: totem is broken. helix is broken. mplayer works.
Workaround: install mozilla-mplayer. remove totem. remove helix.

Mplayer - I have atached the file

Rod Jones

2008/4/28 Michael Doube <email address hidden>:
> Roderic
>
> I just installed a bunch of plugins and media handlers as well as
> following your suggestions and now have un-garbled BBC Radio 1 in
> Firefox 2
>
> What plugin is handling the Real Audio stream for you in Firefox 2? Can
> you please attach the output from typing
>
> about:plugins
>
> in the address bar.
>
> Mike
>
> ** Attachment added: "about_plugins_ff2.txt"
> http://launchpadlibrarian.net/13982298/about_plugins_ff2.txt
>
>
>
> --
> Real Player stream is garbled on BBC radio
> https://bugs.launchpad.net/bugs/217301
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Roderic Jones

Trout Cottage
Llanvihangel Crucorney
Abergavenny
Monmouthshire
NP7 7NB

Telephone 01873 890050

Roderic Jones (rodericj) wrote :

Many thanks for your suggestion this works. Removing Totem and
reinstalling mplayer produces perfect sound.

Rod Jones

2008/4/28 Michael Doube <email address hidden>:
> Actually, running firefox-3.0 at the command line revealed that totem
> was handling the stream and failing dismally. Removing totem and helix
> player and making sure that mplayer was installed fixed it for me. This
> is not a bug in FF3, it is in totem or its codecs.
>
> Diagnosis: totem is broken. helix is broken. mplayer works.
> Workaround: install mozilla-mplayer. remove totem. remove helix.
>
> ** Attachment added: "ff3_debug.log"
> http://launchpadlibrarian.net/13982666/ff3_debug.log
>
>
>
> --
> Real Player stream is garbled on BBC radio
> https://bugs.launchpad.net/bugs/217301
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Roderic Jones

Trout Cottage
Llanvihangel Crucorney
Abergavenny
Monmouthshire
NP7 7NB

Telephone 01873 890050

Changed in gstreamer0.10:
importance: Undecided → Medium
status: New → Triaged
Changed in gstreamer:
status: Unknown → Confirmed
Changed in gstreamer:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

it's a gstreamer task rejecting totem.

Changed in totem:
status: New → Invalid
Pedro Villavicencio (pedro) wrote :

also fixed upstream, thanks.

Changed in gstreamer0.10:
status: Triaged → Fix Committed
sam tygier (samtygier) wrote :

the upstream change fixes it for me. what are the odds of a SRU?

sam tygier (samtygier) wrote :

to build a fixed package

mkdir fix-realplayer
apt-get source gstreamer0.10-plugins-ugly
sudo apt-get install build-essential fakeroot devscripts
sudo apt-get build-dep gstreamer0.10-plugins-ugly
wget http://launchpadlibrarian.net/14422919/fix-realplayer-patch.diff
cd gst-plugins-ugly0.10-0.10.7
patch -p1 < ../fix-realplayer-patch.diff
dpkg-buildpackage -rfakeroot
cd ..
sudo dpkg -i gstreamer0.10-plugins-ugly_0.10.7-3_*.deb

Sebastien Bacher (seb128) wrote :

the change seems simple enough and worth a stable update, do you want to work on that sru?

sam tygier (samtygier) wrote :

oops i noticed that the patch i uploaded has some cruft. the "diff -ruNp gst-plugins-ugly0.10-0.10.7.old/gst/realmedia/rtspreal.c.orig gst-plugins-ugly0.10-0.10.7/gst/realmedia/rtspreal.c.orig" chunk.

i dont have load rights, or really understand how the patch fixes the issue, so i dont think i am the best person to drive the SRU.

sam tygier (samtygier) wrote :

The fix has hit intrepid

0.10.7.4-1
Published in intrepid-release on 2008-05-22

gst-plugins-ugly0.10 (0.10.7.4-1) unstable; urgency=low

  * New upstream pre-release:
    + Fixes some bugs with the Real demuxer (Closes: #479996).

 -- Ubuntu Archive Auto-Sync < <email address hidden>> Thu, 22 May 2008 08:19:22 +010

the resulting packages work in hardy
http://launchpadlibrarian.net/14654991/gstreamer0.10-plugins-ugly_0.10.7.4-1_i386.deb
http://launchpadlibrarian.net/14656337/gstreamer0.10-plugins-ugly_0.10.7.4-1_amd64.deb
http://launchpadlibrarian.net/14657508/gstreamer0.10-plugins-ugly_0.10.7.4-1_powerpc.deb

Changed in gst-plugins-ugly0.10:
status: Fix Committed → Fix Released
sam tygier (samtygier) wrote :

debdiff for SRU.
i am a noob, please review carefully. thanks

sam tygier (samtygier) on 2008-06-04
description: updated
Changed in totem:
status: New → Invalid
sam tygier (samtygier) wrote :

DktrKranz gave the following comments:
a couple of notes regarding bug 217301, your debdiff require some adjustments, first of all target must be hardy-proposed (as per policy), you should also adjust maintainer field as per wiki.ubuntu.com/DebianMaintainerField. Last one: patch should be managed with simple-patchsys.

here is my new attempt

sam tygier (samtygier) wrote :

hmmm. that surely should not have jumped in size so much. i'll have another go

sam tygier (samtygier) wrote :

i used the wrong patch from this page which has rtspreal.c.orig cruft.

sam tygier (samtygier) wrote :

this one should be good

Luca Falavigna (dktrkranz) wrote :

ACK from motu-sru.
gst-plugins-ugly0.10 version 0.10.7-3ubuntu1 uploaded in hardy-proposed.

Changed in gst-plugins-ugly0.10:
importance: Undecided → Medium
status: New → Confirmed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in gst-plugins-ugly0.10:
status: Confirmed → Fix Committed
Michael Doube (michael-doube) wrote :

The new codec (amd64 version) is working fine for me using Totem independently and the Mozilla plugin. Thanks everyone!

sam tygier (samtygier) wrote :

just too note that i have been testing this with the BBC streaming on amd64 and i386. fixes it on both.

there is occasionally still some garbbledness, but reloading the page gives me good sound. either there is still some rare case where this does not work, or its just a network issue. before the fix, no amount of refreshing would help.

The i386 version is good, but not perfect for me.

I get garbling (sounds like 2 streams simultaneously playing about .5 seconds out of sync) if I press the pause button and the play button in quick succession (say < 1 second). The terminal then says:

(totem-plugin-viewer:15927): GStreamer-CRITICAL **: gst_clock_set_calibration: assertion `internal <= gst_clock_get_internal_time (clock)' failed

Also (and correct me if this isn't the right place to mention this), the other buttons (fast forward and volume) don't work, and nor does the popup asking if I want to go to where I was last listening. These buttons return the following errors in terminal:

WARNING: Site uses unimplemented function 'totemIComplexPlayer::GetLength'
WARNING: Site uses unimplemented function 'totemIComplexPlayer::GetPosition'
WARNING: Site uses unimplemented function 'totemIComplexPlayer::GetBandwidthAverage'
WARNING: Site uses unimplemented function 'totemIComplexPlayer::CanStop'

Steve Beattie (sbeattie) wrote :

Nick: you should report the button breakage in a separate bug. Is it only with the version in -proposed that you see this, or are the buttons broken in the Hardy released version as well. If it's only in -proposed, then that's an introduced regression that needs to be addressed before the -proposed package gets pushed into updates. If it's also broken in the original version, then it should not block this update.

I was also able to reproduce the original package's garbled output and can confirm significantly improved output in the bbc real player audio stream by using the version in -proposed. The output is not perfect -- I detected the occasional loss of packets -- but is such a significant improvement over the released version that unless there's an introduced regression, I would consider the proposed package sufficient for release.

Steve: Thanks for the advice - have reported the button problems to a new bug, #242148.

I couldn't say if it the pause garbling was a regression, as I haven't used this plugin before Hardy.

Regardless, though, the -proposed version substantially improves the playback, therefore to my inexperienced eyes it looks like it should be released.

Markus Korn (thekorn) wrote :

In can confirm this bug with the version of gst0.10-plugins-ugly in hardy (0.10.7-3), tthe version in hardy-proposed (0.10.7-3ubuntu1) fixes this issue for me.

Markus

Michael Doube (michael-doube) wrote :

Yep, the version in hardy-proposed gives good sound quality while listening to the cricket here:

http://www.bbc.co.uk/fivelive/live/surestream_sportsextra.ram

Michael Doube (michael-doube) wrote :

But trying to listen again to the new Verve world exclusive on Radio 1 died with silent patches followed by total silence.

Luca Falavigna (dktrkranz) wrote :

Version in -proposed fixed issue for me, now streams are processed correctly.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gst-plugins-ugly0.10:
status: Fix Committed → Fix Released
Changed in gstreamer:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.