totem-xine mozilla plugin make firefox crash

Bug #21110 reported by Hervé Cauwelier (bug tracking) on 2005-09-07
70
This bug affects 2 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Medium
Sebastien Bacher

Bug Description

I try watching trailers from quicktime.com with Firefox and Totem-Xine on Breezy.

Here is the output on console:

herve@bouba:~ $ firefox
NP_Initialize
totem_plugin_new_instance
Init scriptable instance
mode 1
argv[0] src http://images.apple.com/quicktime/home/images/btn_launchguide.gif
argv[1] type video/quicktime
argv[2] pluginspage http://www.apple.com/quicktime/download/
argv[3] controller false
argv[4] loop true
argv[5] autoplay true
argv[6] href http://qtpix.apple.com/qtpix/qtpix.mov
argv[7] target QuickTimePlayer
argv[8] height 42
argv[9] width 151
plugin_get_value 14
plugin_set_window
about to fork
Launching: /usr/lib/totem/totem-mozilla-viewer --xid 62919586 --width 151
--height 42 --url
http://images.apple.com/quicktime/home/images/btn_launchguide.gif --href
http://qtpix.apple.com/qtpix/qtpix.mov --nocontrols fd://0
waiting for signal org.totem_13726.MozillaPluginService
Received notification for :1.7
Received notification for :1.7
Received notification for org.totem_13726.MozillaPluginService
Received notification for org.totem_13726.MozillaPluginService
Done forking, new proxy=0x87aa7b8
leaving plugin_set_window
plugin_set_window
existing window
resize
leaving plugin_set_window
plugin_set_window
existing window
resize
leaving plugin_set_window
CMD line: /usr/lib/totem/totem-mozilla-viewer --xid 62919586 --width 151
--height 42 --url
http://images.apple.com/quicktime/home/images/btn_launchguide.gif --href
http://qtpix.apple.com/qtpix/qtpix.mov --nocontrols fd://0
plugin_new_stream
plugin_write_ready
plugin_write
plugin_destroy_stream
** Message: totem_embedded_open 'fd://0'
** Message: error: There is no plugin to handle this movie.
plugin_destroy
** Message: stop
Die scriptable instance
Erreur de segmentation

I'll post a strace output in a moment.

Created an attachment (id=3585)
Gzipped strace output

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What page do you use to get the crash? Could you get a
backtrace (the bug-buddy dialog to send the bug has it)?

(In reply to comment #2)
> Thanks for your bug. What page do you use to get the crash?

I got to http://www.apple.com/trailers/ then try to watch a trailer.

> Could you get a
> backtrace (the bug-buddy dialog to send the bug has it)?

Unfortunately, bug-buddy won't wake up, this is a Firefox crash. Maybe I can
provide some options to strace, or recompile totem-xine with -g?

Sebastien Bacher (seb128) wrote :

Does it happen all the time for you? It works fine here. You can get a backtrace
by doing this after starting firefox:
- gdb -p `pidof firefox-bin`
(gdb) continue
... crash
(gdb) thread apply all bt

Does it happen as soon as you start playing a file? Does it happen on all the
files on this website?

Sebastien Bacher (seb128) wrote :

what architecture are you using?

Sebastien Bacher (seb128) wrote :

do it happen while playing the file or when changing the page after that?

Sorry I won't have time to test in the short term. Could Firefox be weaker
without libxp6 or it's just an urban legend?

Sebastien Bacher (seb128) wrote :

what about libxp6? what architecture do you use, amd64?

(In reply to comment #8)
> what about libxp6? what architecture do you use, amd64?

No, i386. I refer to a thread on ubuntu-devel where people report they solved
Firefox instability by installing libxp6.

Sylvain Defresne (sdefresne) wrote :

I think i have encountered the same bug. It happens when changing the page
containing an embeded movie.
I'll post a backtrace soon.

Sylvain Defresne (sdefresne) wrote :

Created an attachment (id=4059)
backtrace of firefox-bin after the segmentation fault

Here comes the backtrace. Unfortunately, there are lots of unresolved symbols.

Sebastien Bacher (seb128) wrote :

Thanks for the comment. What architecture do you use? amd64?

Sylvain Defresne (sdefresne) wrote :

I'm using i386, firefox version 1.0.7-0ubuntu15 and totem-xine
version 1.2.0-0ubuntu3 (both are current version of breezy).

Scott Robinson (scott-ubuntu) wrote :

I too am having issues with the totem thumnailer. Could it be separated from the
main totem package so it doesn't take down my browser every time I inadvertantly
load a video?

Example link:

http://hem.spray.se/sammorling/clips/6step-maniacs1.mov

Sebastien Bacher (seb128) wrote :

(In reply to comment #14)
> I too am having issues with the totem thumnailer. Could it be separated from the
> main totem package so it doesn't take down my browser every time I inadvertantly
> load a video?

Ccing you, so you get the comments on what you say. I'm not going to split the
packages, that's not required for several reasons:
- if there is an issue open a bug, it'll be fixed
- you can change the gconf /desktop/gnome/thumbnailers/video@quicktime settings
for that

> Example link:
>
> http://hem.spray.se/sammorling/clips/6step-maniacs1.mov

This file works fine for me. What version of totem do you use? What
architecture? Could you put that to a new bug, this one is about something else

Scott Robinson (scott-ubuntu) wrote :

Created an attachment (id=4228)
Black screen of death.

I apologize - I am tired. I meant the totem mozilla-plugin.

When I click on the link in my previous post, the video appears in the browser
using the plugin. It plays for a few seconds, and then stops and displays only
black. I cannot play it again. If I press "back" or try closing the tab the
browser immediately crashes.

The attached pic is the browser when it is displaying black. Pressing back or
closing the tab at this point will crash it.

(In reply to comment #16)
> The attached pic is the browser when it is displaying black. Pressing back or
> closing the tab at this point will crash it.

I've just noticed this too. I installed the mplayer plugin in favor of the the
totem one, but an upgrade overwrote it. I've closed the window and Firefox is
still alive.

Sebastien Bacher (seb128) wrote :

(In reply to comment #16)

> When I click on the link in my previous post, the video appears in the browser
> using the plugin. It plays for a few seconds, and then stops and displays only
> black. I cannot play it again. If I press "back" or try closing the tab the
> browser immediately crashes.

do you use an amd64 installation?

Scott Robinson (scott-ubuntu) wrote :

Linux geneva 2.6.12-9-686 #1 Mon Sep 26 23:57:13 BST 2005 i686 GNU/Linux

George Wood (gbwood) wrote :

There seem to be a lot of bugs on this, so I didn't know which to post to. The
Totem plugin for Firefox seems to be crashing whenever I play a file. If I am
at Amazon.com I can listen to a windows audio stream (I am using Totem-Xine and
have the w32codecs, I know that isn't supported, but I thought I would post
anyway). Afterward, if I close the pop-up that it played in it will crash all
Firefox related windows. It will also crash all Firefox windows if I attempt to
play another file without closing the pop-up first. I am new to Bugzilla, and
as such am unaware of how to do traces or bug tracking. But if you tell me what
you need (if anything), I'll work it out and post it.

Yup same thing as everyone else.

It seems to be any video files as well. I'm not sure whether its totem or
whether its firefox thats causing the crash.

marc@ubuntu:~$ totem --version
Gnome totem 1.2.0
marc@ubuntu:~$

I tried using gdb -p (pid of firefox) and it froze firefox?
gdb spat out a lot of information though. Is that a separate issue?

Created an attachment (id=4583)
firefox gdb

I'm hoping I've done it correctly I rang gdb -p pid after it had run the movie
and it recorded a lot of stuff.

Sebastien Bacher (seb128) wrote :

Do you use an amd64? What file format is used for the backtrace file?

Daniel Holbach (dholbach) wrote :

It's a .tar.gz. Marc: could you please retry and use the information on
https://wiki.ubuntu.com/DebuggingProgramCrash (from step 3 on)

Created an attachment (id=4641)
backtrace after sigsegv

(From update of attachment 4641)
Same problem for me. I attched a backtrace. I hope that thi is what you need.
Cheers.

Sebastien Bacher (seb128) wrote :

*** Bug 27135 has been marked as a duplicate of this bug. ***

Sebastien Bacher (seb128) wrote :

*** Bug 21131 has been marked as a duplicate of this bug. ***

Sebastien Bacher (seb128) wrote :

This upload is supposed to fix the crasher:

 totem (1.3.0-0ubuntu4) dapper; urgency=low
 .
   * debian/patches/08_firefox-plugin-fix.dpatch:
     - upstream patch to fix the firefox plugin crasher (Ubuntu: #14882)

Could people having the issue and using dapper have a try with it and comment on
the bug on how it works for them?

Julien Olivier (julo) wrote :

This version works perfectly for me. No more crash. With only one thing: when a
video is launched, the volume appears as muted, but sound is actually played.
But it's not realted to this bug.

Julien Olivier (julo) wrote :

Today, I noticed a new bug: after successfully playing an embedded video, if I hit "back", and then play another video, firefox crashes. However, if I open the new video in another tab, it works.

Julien Olivier (julo) wrote :

I also noticed that I can reproduce this bug on http://www.davesdaily.com/mediaclips.htm, but not on http://www.apple.com/trailers/.

Sebastien Bacher (seb128) wrote :

Closing that bug as fixed, Julien please use new bugs for new issues you note, that's easier to manager with a bug tracker than abusing an another topic!

Changed in totem:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.