Ubuntu

bemused plugin in totem-plugins not working

Reported by Hasse Hagen Johansen on 2008-03-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Low
totem (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: totem-plugins

I cannot get the bemused plugin to work..I have tried recompiling from the source package, but no success. The plugin doesn't appear in totem (Edit->Plugins). I don't get any relevant debugging output when running totem --debug from a terminal

This is the Ubuntu version:
Description: Ubuntu hardy (development branch)
Release: 8.0

totem-plugins:
  Installed: 2.22.0-0ubuntu3
  Candidate: 2.22.0-0ubuntu3
  Version table:
 *** 2.22.0-0ubuntu3 0
        500 http://dk.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Sebastien Bacher (seb128) wrote :

you need to install totem-plugins-extra, not a bug

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid

As far as I see it is part of totem-plugins and not totem-plugins-extra

hhj@lisa:~$ dpkg -L totem-plugins|grep 'totem/plugins'
/usr/lib/totem/plugins
/usr/lib/totem/plugins/media-player-keys
/usr/lib/totem/plugins/media-player-keys/media-player-keys.totem-plugin
/usr/lib/totem/plugins/media-player-keys/libmedia_player_keys.so
/usr/lib/totem/plugins/tracker
/usr/lib/totem/plugins/tracker/tracker.totem-plugin
/usr/lib/totem/plugins/tracker/libtracker.so
/usr/lib/totem/plugins/thumbnail
/usr/lib/totem/plugins/thumbnail/libthumbnail.so
/usr/lib/totem/plugins/thumbnail/thumbnail.totem-plugin
/usr/lib/totem/plugins/skipto
/usr/lib/totem/plugins/skipto/skipto.totem-plugin
/usr/lib/totem/plugins/skipto/skipto.ui
/usr/lib/totem/plugins/skipto/libskipto.so
/usr/lib/totem/plugins/ontop
/usr/lib/totem/plugins/ontop/libontop.so
/usr/lib/totem/plugins/ontop/ontop.totem-plugin
/usr/lib/totem/plugins/screensaver
/usr/lib/totem/plugins/screensaver/libscreensaver.so
/usr/lib/totem/plugins/screensaver/screensaver.totem-plugin
/usr/lib/totem/plugins/lirc
/usr/lib/totem/plugins/lirc/lirc.totem-plugin
/usr/lib/totem/plugins/lirc/liblirc.so
/usr/lib/totem/plugins/bemused
/usr/lib/totem/plugins/bemused/libbemused.so
/usr/lib/totem/plugins/properties
/usr/lib/totem/plugins/properties/movie-properties.totem-plugin
/usr/lib/totem/plugins/properties/libmovie-properties.so
/usr/lib/totem/plugins/youtube
/usr/lib/totem/plugins/youtube/youtube.ui
/usr/lib/totem/plugins/youtube/youtube.totem-plugin
/usr/lib/totem/plugins/youtube/youtube.py
/usr/lib/totem/plugins/totem
/usr/lib/totem/plugins/totem/__init__.py

hhj@lisa:~$ dpkg -L totem-plugins-extra |grep 'totem/plugins'
/usr/lib/totem/plugins
/usr/lib/totem/plugins/gromit
/usr/lib/totem/plugins/gromit/gromit.totem-plugin
/usr/lib/totem/plugins/gromit/libgromit.so
/usr/lib/totem/plugins/mythtv
/usr/lib/totem/plugins/mythtv/mythtv.totem-plugin
/usr/lib/totem/plugins/mythtv/libtotem_mythtv.so

I should say that I run the 64bit hardy

By the way the mythtv plugins is not working because gstreamer is missing af mythtv source, but that is for another bugreport i guess

Changed in totem:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

That seems to be an upstream issue, they don't distribute the totem-plugin, somebody who knows what the option is supposed to do and care about it should send that on bugzilla

Changed in totem:
importance: Low → Wishlist

It is not an upstream issue. I think it is a problem with the debian/rules file in the source package which doesn't copy the totem plugin description file named bemused.totem-plugin. The .so file i distributed in the ubuntu package so it _is_ a bug that the bemused.totem-plugin file isn't in the binary ubuntu package.

I have just got it working by manually running make in the src/plugins/bemused directory, and then copying the bemused.totem-plugin, and it is working quite fine

It is a plugin for remote controlling totem by any java enabled bluetooth phone.

Bug confirmed in Hardy. I think "importance" should be "Low" or "Medium", but not "Wishlist" because bluetooth remote control is a announced feature in package description (and it is not working).
Please, change "importance" flag or package control file.

Changed in totem:
status: New → Confirmed

We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in totem:
status: Confirmed → Incomplete

Hi. It is still a problem. Long time I looked at it, but as I remember I got it working. I think it is a missing file which is not copied when the debian/rules file is run.

All the other plugins have <plugin-name>.totem-plugin file which I believe describes the plugin to totem, and that is why it doesn't turn op in the plugin list

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in jaunty and describe how to trigger it?

Yes. The bug is stille present. As far as I remember it was quite an easy fix last time. The <plugin-name>.totem-plugin file is missing from totem-plugins. Only the libbemused.so file i distirbuted. The .totem-plugin fil eis needed for Totem to use the .so file - as far as I remember it is a bug in debian/rules file or what builded the .deb file...it did not copy the <plugin-name>.totem-plugin for bemused(probably called something like bemused.totem-plugin or libbemused.totem-plugin)

Changed in totem (Ubuntu):
status: Incomplete → New
Thomas Hotz (thotz) on 2012-11-11
Changed in totem (Ubuntu):
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in totem (Ubuntu):
status: Confirmed → Incomplete
Changed in totem:
importance: Unknown → Low
status: Unknown → Fix Released
Thomas Hotz (thotz) on 2013-05-02
Changed in totem (Ubuntu):
status: Incomplete → Confirmed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.