totem-gsteamer freezes when pausing, advancing, or reversing playback

Bug #20308 reported by John Meuser on 2005-08-24
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Totem
Expired
Medium
totem (Ubuntu)
Medium
Sebastien Bacher

Bug Description

The version of totem gstreamer in breezy freezes when you pause, advance, or
reverse playback. It does NOT happen when using the xine backend. This happens
regardless of the file format.. any movie or audio file does this. The program
doesn't segfault or crash, the movie/audio just freezes. The program appears to
respond.. menues and buttons work.. they just don't affect the playback. If I
have more than one media file on the playlist, I can procede to the next one or
go back to the previous, but as soon as I attempt to advance, pause, or reverse
the playback, the media freezes. I will attach the output of 'totem
--gst-debug-level=5 --gst-debug-no-color mediafile.avi' (I didn't paste it
inline because it is >400,000 lines.

http://bugzilla.gnome.org/show_bug.cgi?id=315898: http://bugzilla.gnome.org/show_bug.cgi?id=315898

John Meuser (meuserj) wrote :

Created an attachment (id=3358)
output of 'totem --gst-debug-level=3 --gst-debug-no-color'

debug level 4 and 5 created huge files, so I'm sending debug level 3

Matt MacLeod (mmacleod) wrote :

I have seen this for the past several versions as well, on i386. Confirming.
Hardware should be changed to all, but I don't have access to change that.

John Meuser (meuserj) wrote :

The latest update seems to fix this bug... this report can probably be closed.

John Meuser (meuserj) wrote :

nevermind.. I'm stupid, forgot that I was running with the xine backend...

Matt MacLeod (mmacleod) wrote :

The severity of this should probably be upped, as not being able to pause and
resume makes the default video player pretty much unusable.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. I've forwarded the issue upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=315898. The severity is not changed
because it doesn't happen to everybody. Do you have all the current version of
the packages?

Mantas Kriaučiūnas (mantas) wrote :

Please set severity of this but to "Major", as not being able to pause, resume
or rewind forward/backward makes the default video player pretty much unusable.

Matt MacLeod (mmacleod) wrote :

See the upstream bug for how changing the sink settings makes it work for me.
Perhaps one of these alternate options should be the default.

Sebastien Bacher (seb128) wrote :

Fixed with the new gst0.10 code and dapper according to upstream

Changed in totem:
status: Unconfirmed → Fix Released
status: Unconfirmed → Fix Released
Changed in totem:
status: Unconfirmed → Rejected
Changed in totem:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.