Ubuntu

Totem loses sound when seeking or when switching language

Reported by Kimiko Koopman on 2008-03-14
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: totem

Totem Player (using gstreamer) loses sound when changing audio track.

* .mkv movies (which Nautilus reports as 'Matroska' something or other I think).
* commercial DVD

DESCRIPTION:
------------------

When starting Totem (the gstreamer variant that is) with the video, it will play it okay, but with some default language selected. When I change the language, sound stops, even though the video keeps playing.

The same thing happens when seeking in the movie (.mkv, not confirmed on DVD), whether it is using the keyboard or the scroll wheel or dragging the position slider (BTW, isn't there supposed to be a "Seek To: hh:mm:ss" dialog available somewhere? I can't find it).
Since Totem often (but strangely, not always) picks the wrong language for audio and I like to skip back or forth now and then, this makes it rather useless in playing .mkv or DVD movies.

PACKAGE VERSIONS:
---------------------------

totem: 2.22.0-0ubuntu1
gstreamer0.10-ffmpeg: 0.10.3-6
gstreamer0.8-ffmpeg: 0.8.7-10ubuntu1 (I'm not sure this package is still needed, but the v0.10 packages never actually _replaced_ the v0.8 ones in Apt)

HOW TO REPRODUCE:
----------------------------
Play a DVD movie, go to Sound -> Languages and change track. You'll then notice there's no more sound while movie keeps playing.

Stéphane Graber (stgraber) wrote :

Reproduced on hardy (without -proposed) with a multi-language DVD when switching to another language.
Switching back to the main language (english in my case) doesn't revert it.

Looking at pavumeter (pulseaudio) the sound feed is correctly sent but contains nothing.

Changed in totem:
importance: Undecided → Medium
status: New → Confirmed
Antoine Pairet (b-ly) wrote :

I confirm the bug too.

This may be related to this bug which also give links to upstream bugs:
https://bugs.launchpad.net/bugs/41335

How can we help this to be solved?

Antoine Pairet (b-ly) wrote :

Here are the steps to reproduce the bug while reading a DVD:

1. Start playing a movier using totem and totem-gstreamer
2. Click on Sound ->Languages -> Track XXX and select another than the default one
3. Sound doesn't work anymore

Is there any test I should make? Running totem from shell? What debug info can I give?
Thanks!

Antoine Pairet (b-ly) on 2008-08-05
description: updated

Repoduces this bug in intrepid with any multitrack video.

Ryan Thompson (rct86) wrote :

I suspect that the mkv seeking problem and the sound track switching problem might not be the same problem. Then again, they might be.

Maxim Levitsky (maximlevitsky) wrote :

I confirm this

Maxim Levitsky (maximlevitsky) wrote :

Added me as CC

Jacob Popov (j-a-popov) wrote :

I confirm this bug on Karmic with Totem playing DVDs.

There is a workaround though: if I press "seek to the next chapter" button and then "seek to the previous chapter", everything starts working again.

The problem seems to be in GStreamer though, not in Totem: when it was possible to use XINE as Totem's backend, the trouble never occured.

Jan Girke (jangirke) wrote :

Same problem with sound tracks confirmed here.
Ubuntu Jaunty Jackalope 9.04 Nov. 09th 2009
Totem 2.26.1 Gstreamer 0.10.22

madbiologist (me-again) wrote :

It looks as if Ryan Thompson is correct.

The mkv seeking problem should be fixed in GStreamer Good Plug-ins 0.10.24. From the release notes:

# 620358 : [matroskademux] Sorenson Squish WebM output seeking issues
# 620743 : matroskademux: refactor delta unit handling
# 619485 : matroskademux: skip buffers before a late keyframe (QoS)

Those are GNOME bug numbers. The corresponding bug reports are at:

https://bugzilla.gnome.org/show_bug.cgi?id=620358
https://bugzilla.gnome.org/show_bug.cgi?id=620743
https://bugzilla.gnome.org/show_bug.cgi?id=619485
Please test with the Ubuntu 10.10 "Maverick Meerkat" alpha 3 CD. After booting, and before testing, please use Synaptic Package Manager to upgrade Totem and the gstreamer packages, in particular the update of gstreamer0.10-plugins-good to 0.10.24.3-1ubuntu1

madbiologist (me-again) wrote :

Sorry, I meant Live CD.

madbiologist (me-again) wrote :

There is another fix in GStreamer Good Plug-ins 0.10.25. From the release notes:

Features of this release:

# seeking in matroska and webm files that don't have an index
# matroskademux: support seeking in local files even if they don't have an index
# 617368 : [matroska] Implement push-mode seeking and non-cue seeking

That last one has a GNOME bug number - the corresponding bug report is at:

https://bugzilla.gnome.org/show_bug.cgi?id=617368

They don't seem to have included the bug reference (if there was one) for the local file case.

Please test with the Ubuntu 10.10 "Maverick Meerkat" beta CD. After booting, and before testing, please use Synaptic Package Manager to upgrade Totem and the gstreamer packages, in particular the update of gstreamer0.10-plugins-good to 0.10.25-4ubuntu1

Changed in totem (Ubuntu):
status: Confirmed → Incomplete
Omer Akram (om26er) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Kimiko Koopman (kimiko) wrote :

Wow, it's been almost three years since I reported that bug. I switched to MPlayer shortly afterwards, and haven't really looked back at Totem.
Anyways, I just did a quick check, and I can't reproduce the bug at the moment. Unless one of the others who confirmed it still experience this problem, I think you can close the bug report.

I haven't seen this in a while either.

On Wed, Jan 26, 2011 at 11:07 AM, Kimiko Koopman <email address hidden> wrote:
> Wow, it's been almost three years since I reported that bug. I switched to MPlayer shortly afterwards, and haven't really looked back at Totem.
> Anyways, I just did a quick check, and I can't reproduce the bug at the moment. Unless one of the others who confirmed it still experience this problem, I think you can close the bug report.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/202288
>
> Title:
>  Totem loses sound when seeking or when switching language
>

Omer Akram (om26er) wrote :

closing then, thanks for the confirmations

Changed in totem (Ubuntu):
status: Incomplete → Invalid
Ivan Akulov (gxoptg) wrote :

Opening it. I see it very often.

Changed in totem (Ubuntu):
status: Invalid → New
Ivan Akulov (gxoptg) wrote :

(with mkv files)

madbiologist (me-again) wrote :

Ivan - which version of Ubuntu are you using? Can you attach one of the mkv files which show the problem?

Ivan Akulov (gxoptg) wrote :

Ubuntu version: 11.10
sorry, I can't attach a file (it's about 10 Gb). but it happens with any long (a hour and longer) mkv file (i haven't tested it for short files)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed

Sorry for this bug not having been attended for a while. Ivan or anybody else affected by this bug. Please open a new bug with "ubuntu-bug totem" and your system information if you are still seeing the bug of this report, since it is too old to have any useful debugging information. Otherwise please kindly ignore this message.

Changed in totem (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.