Automatic DVD playback now defaults to totem-gstreamer even when totem-xine is installed

Bug #200537 reported by Matt Zimmerman on 2008-03-10
4
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem (Debian)
Fix Released
Unknown
totem (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: totem

In the past, installing totem-xine (which removed totem-gstreamer) was sufficient to get (unencrypted) DVD playback working properly. I would insert the DVD, and it would begin playing immediately with totem-xine.

Now, totem-gstreamer and totem-xine can both be installed at the same time. This is mostly a good thing, but when a DVD is inserted, it is played with totem-gstreamer, rather than totem-xine, which means there is no support for menus etc. (bug 41335). I think it would be appropriate to prefer totem-xine for DVD playback when it is installed, if that is possible.

Matt Zimmerman (mdz) wrote :

This may also affect other media formats if totem-xine can play them, but totem-gstreamer can't. I don't know whether much content (other than DVD) still falls into this category.

Caroline Ford (secretlondon) wrote :

Bug #209303 is the dependency issue.

Changed in totem:
status: Unknown → New
Daniel T Chen (crimsun) wrote :

The situation has improved somewhat (although I admit I only recently noticed): I can now choose to Open With> Movie Player (xine)

Changed in totem:
importance: Undecided → Wishlist
status: New → Confirmed

Linking the gnome bug from the debian bug here. Accordingly setting the status to "triaged".

Changed in totem (Ubuntu):
status: Confirmed → Triaged
Changed in totem:
status: Unknown → Fix Released

Closing as won't fix due to upstream comment https://bugzilla.gnome.org/show_bug.cgi?id=168510#c23
>>>
The xine-lib backend was removed from Totem master. Please test whether the
problem(s) you were encountering still occur with the GStreamer backend (in
which case you should file a new bug).

If you are unwilling or unable to use the GStreamer backend, feel free to use
alternative xine-lib based players, such as gxine.

Totem 2.26.x will still have the xine-lib backend available.
<<<

Changed in totem (Ubuntu):
status: Triaged → Won't Fix
Changed in totem:
importance: Unknown → Medium
Changed in totem (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.