[Hardy A3] libgnome-desktop-2.so.2 is missing

Bug #182231 reported by Linard Verstraete on 2008-01-12
16
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

*** Platform ***
Xubuntu Hardy Alpha 3 - Running LiveCD

*** Problem ***
totem doesn't load from the dropdown menu - nor by double clicking to open an associated file - nor by terminal-commands 'totem' or 'totem-xine'

*** Cause ***
-Transcript from terminal-
'error while loading shared libraries: libgnome-desktop-2.so.2: cannot open shared object file: No such file or directory'

*** Solved by ***
Installing package libgnome-desktop-2 by Synaptic or Terminal command sudo apt-get install libgnome-desktop-2

I assume that there is just a simple mistake in the dependencies...

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

I tried recreating this using the daily build of the Ubuntu desktop CD and was unable to so this seems specific to Xubuntu.

I couldn't reproduce this on my Xubuntu Hardy virtual machine, are you sure your system is fully up to date ?

Changed in totem:
status: New → Incomplete
L Jones (isharra) wrote :

I can confirm this on an install from the 20070119 live-cd and a single update using update manager. Unfortunately I was reporting to a duplicate bug (and took long enough that I missed the message that it was a duplicate report).
see bug #182787 for more information.

L Jones (isharra) wrote :

I'm having trouble typing on this keyboard (cursor randomly jumps around), the live cd image was from 2007-01-09. (not 20070119 as i wrote above)

Linard Verstraete (linardv) wrote :

I downloaded the .iso 12 hours after the release of Xubuntu Hardy Alpha 3.
I checked the update manager, but no updates seems to be related to totem, however I shall try to get a recent .iso tomorrow.

P.S.: I'm quite new to the testing of .iso, should I follow these guidelines (https://help.ubuntu.com/community/RsyncCdImage) for getting a newer version without re-downloading a complete .iso?

Linard Verstraete (linardv) wrote :

Oké, so it seems that this bug only applies on the Hardy release of 2007-01-09 (Hardy A3) and it's solved in the daily builds.

Changed in totem:
status: Incomplete → Fix Committed
Pedro Villavicencio (pedro) wrote :

It's fixed then, thanks you.

Changed in totem:
status: Fix Committed → Fix Released
L Jones (isharra) wrote :

The problem is NOT fixed in the daily build. Downloaded and booted less than 15 minutes ago.

http://cdimage.ubuntu.com/xubuntu/daily-live/20080119/hardy-desktop-amd64.iso

ubuntu@ubuntu:~$ totem
totem: error while loading shared libraries: libgnome-desktop-2.so.2: cannot open shared object file: No such file or directory
ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.24-4-generic #1 SMP Mon Jan 14 18:19:11 UTC 2008 x86_64 GNU/Linux

Linard Verstraete (linardv) wrote :

So, now it isn't? O boy ...
I can't confirm right now because I'm almost through my download-limit. So I have to wait till the 1st February before I can download a new daily-build.
And by the way, I have an i386 architecture.

Changed in totem:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

that was a totem issue and has been fixed in hardy

Changed in gnome-desktop:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers