totem assert failure: totem: totem: gen9_mfd.c:649: gen9_hcpd_get_reference_picture_frame_id: Assertion `0' failed.

Bug #1821525 reported by El jinete sin cabeza on 2019-03-24
46
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Libva
Unknown
Unknown
Mesa
Unknown
Unknown
Totem
Fix Released
Unknown
intel-vaapi-driver (Ubuntu)
Medium
Unassigned
totem (Ubuntu)
Medium
Unassigned

Bug Description

https://errors.ubuntu.com/problem/f36d74be6ec6814d0d81897848945dfb17739b84
https://errors.ubuntu.com/problem/21e6ce32534f56195547dcde1e33d883f2a01957
https://errors.ubuntu.com/problem/a0da0313b3f76e479f1052b60522e4c2ec2f1de6

https://github.com/intel/intel-vaapi-driver/issues/448 (or 451)
https://bugzilla.freedesktop.org/show_bug.cgi?id=110232 (No Mesa)
https://gitlab.gnome.org/GNOME/totem/issues/315 (No totem)

---

Watching movie 4k, forward and back.

ProblemType: Crash
DistroRelease: Ubuntu 19.04
Package: totem 3.32.0-1ubuntu1
Uname: Linux 5.0.4-050004-generic x86_64
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
AssertionMessage: totem: gen9_mfd.c:649: gen9_hcpd_get_reference_picture_frame_id: La declaración `0' no se cumple.
CurrentDesktop: ubuntu:GNOME
Date: Sun Mar 24 11:18:37 2019
ExecutablePath: /usr/bin/totem
InstallationDate: Installed on 2018-12-02 (111 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
ProcCmdline: /usr/bin/totem --gapplication-service
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
 LANGUAGE=es_CL:es
 PATH=(custom, no user)
 LANG=es_CL.UTF-8
Signal: 6
SourcePackage: totem
StacktraceTop:
 __assert_fail_base (fmt=0x7f06f2ac2d6a <error: No se puede acceder a la memoria en la dirección 0x7f06f2ac2d6a>, assertion=0x7f06b2cbcba4 "0", file=0x7f06b29b1cd0 "gen9_mfd.c", line=649, function=<optimized out>) at assert.c:92
 __GI___assert_fail (assertion=0x7f06b2cbcba4 "0", file=0x7f06b29b1cd0 "gen9_mfd.c", line=649, function=0x7f06b29b23e0 "gen9_hcpd_get_reference_picture_frame_id") at assert.c:101
 ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
 ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
 vaEndPicture () from /usr/lib/x86_64-linux-gnu/libva.so.2
Title: totem assert failure: totem: gen9_mfd.c:649: gen9_hcpd_get_reference_picture_frame_id: La declaración `0' no se cumple.
UpgradeStatus: Upgraded to disco on 2018-12-02 (111 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
separator:

El jinete sin cabeza (ejsc) wrote :

StacktraceTop:
 __assert_fail_base (fmt=0x7f06f2ac2d6a <error: Cannot access memory at address 0x7f06f2ac2d6a>, assertion=0x7f06b2cbcba4 "0", file=0x7f06b29b1cd0 "gen9_mfd.c", line=649, function=<optimized out>) at assert.c:92
 __GI___assert_fail (assertion=assertion@entry=0x7f06b2cbcba4 "0", file=file@entry=0x7f06b29b1cd0 "gen9_mfd.c", line=line@entry=649, function=function@entry=0x7f06b29b23e0 <__PRETTY_FUNCTION__.14793> "gen9_hcpd_get_reference_picture_frame_id") at assert.c:101
 gen9_hcpd_get_reference_picture_frame_id (frame_store=frame_store@entry=0x7f06a0079a70, ref_pic=<optimized out>, ref_pic=<optimized out>) at gen9_mfd.c:649
 gen9_hcpd_get_collocated_ref_idx (ctx=0x7f06a80b8cf0, gen9_hcpd_context=0x7f06a0079a40, slice_param=0x7f06a0013a30, pic_param=0x7f06a00a08f0) at gen9_mfd.c:806
 gen9_hcpd_slice_state (ctx=0x7f06a80b8cf0, gen9_hcpd_context=0x7f06a0079a40, next_slice_param=0x7f06a00080e0, slice_param=0x7f06a0013a30, pic_param=0x7f06a00a08f0) at gen9_mfd.c:878

Changed in totem (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
description: updated
Changed in totem:
status: Unknown → New
summary: - totem assert failure: totem: gen9_mfd.c:649:
- gen9_hcpd_get_reference_picture_frame_id: La declaración `0' no se
- cumple.
+ totem assert failure: totem: totem: gen9_mfd.c:649:
+ gen9_hcpd_get_reference_picture_frame_id: Assertion `0' failed.
description: updated
Changed in totem (Ubuntu):
status: New → Invalid
description: updated
description: updated
description: updated
Changed in mesa (Ubuntu):
status: New → Invalid
description: updated
no longer affects: totem
no longer affects: mesa
El jinete sin cabeza (ejsc) wrote :

See LP: #1818862

Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1818862, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in intel-vaapi-driver (Ubuntu):
status: New → Confirmed
Changed in totem (Ubuntu):
status: Invalid → Confirmed
description: updated
Changed in intel-vaapi-driver (Ubuntu):
importance: Undecided → Medium
description: updated
tags: added: bionic eoan
no longer affects: mesa (Ubuntu)
Changed in totem:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.