totem silently fails to create screenshot gallery

Bug #1798399 reported by George on 2018-10-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Low
Sebastien Bacher
Bionic
Low
Sebastien Bacher
Cosmic
Low
Sebastien Bacher

Bug Description

*Impact

The gallery plugin/menu option doesn't work

* Test case

- open a video
- open the menu and click on the gallery option
- validate making a gallery with the default options

-> the picked filename should exist and be a gallery if pictures from the video

* Regression potential

The changes are restricted to the screenshot plugin, so make sure that one works

------------------

https://gitlab.gnome.org/GNOME/totem/issues/268

---

https://gitlab.gnome.org/GNOME/totem/merge_requests/18/

---

Package totem 3.26.0-0ubuntu6

totem 3.26.0 running on Ubuntu 18.04 silently fails to create screenshot gallery. I'm assuming that this has something to do with totem-video-thumbnailer.

Steps to reproduce:

totem-video-thumbnailer -g 20 inputvideo outputpng

I can reproduce this result with both HEVC and AVC encoded videos. I haven't been able to test other codecs, but the error indicates the codec isn't the problem.

totem 3.18.1 under Ubuntu 16.04 does not have this problem.

Any further information required I will be happy to produce within my abilities.
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2018-09-19 (27 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
Package: totem 3.26.0-0ubuntu6
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.15.0-36.39-generic 4.15.18
Tags: bionic wayland-session
Uname: Linux 4.15.0-36-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XorgLog: Error: [Errno 2] No such file or directory: '/var/log/Xorg.0.log'
_MarkForUpload: True

Hello George,

Execute the following command in the terminal:

$ apport-collect 1798399

Best regards,
--
Cristian Aravena Romero (caravena)

Changed in totem (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected bionic wayland-session
description: updated

apport information

apport information

apport information

apport information

Thank you for your bug report. What is the "screenshot gallery" and how to access it and get content? Does "totem-video-thumbnailer -g" is called by some software/in your log and what made you try that command?

Hello,

I confirm this error.

16.04
http://manpages.ubuntu.com/manpages/xenial/man1/totem-video-thumbnailer.1.html
"totem-video-thumbnailer [-j|--jpeg] [-l|--no-limit] [-g num|--gallery num] [-s size] input
       output [backend options]"

18.10
http://manpages.ubuntu.com/manpages/cosmic/man1/totem-video-thumbnailer.1.html
"totem-video-thumbnailer [-j|--jpeg] [-l|--no-limit] [-g num|--gallery num] [-s size] input
       output [backend options]"

Does not accept the option '-g'.

Best regards,
--
Cristian Aravena Romero (caravena)

Changed in totem (Ubuntu):
status: Incomplete → Confirmed
summary: - totem-video-thumbnailer unknown option -g
+ It is necessary to update the documentation of totem-video-thumbnailer
description: updated

The gallery code has been split in a different binary with https://gitlab.gnome.org/GNOME/totem/commit/a642fd971

Changed in totem (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

The manpage fix doesn't resolve the gallery option not working though

> The gallery code has been split in a different binary with
> https://gitlab.gnome.org/GNOME/totem/commit/a642fd971

This is interesting...
--
Cristian

Sebastien Bacher (seb128) wrote :
Changed in totem (Ubuntu):
status: Triaged → In Progress
description: updated
Changed in totem (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
summary: - It is necessary to update the documentation of totem-video-thumbnailer
+ totem silently fails to create screenshot gallery
Changed in totem (Ubuntu):
status: In Progress → Fix Committed
description: updated

Hello George, or anyone else affected,

Accepted totem into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/totem/3.26.2-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-cosmic
George (3grciii) wrote :

I tested totem 3.26.2-1ubuntu2 under Cosmic and the Create screenshot gallery... option works as advertised. Note that the Take screenshot option does not work for me (I suspect that should be a different bug report. The screenshot works as expected under totem 3.18.1-1ubuntu4 under 16.04)

Sebastien Bacher (seb128) wrote :

Thanks for testing, and yes the "take screenshot" not working is another bug, can you open a new report?

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.26.2-1ubuntu2

---------------
totem (3.26.2-1ubuntu2) cosmic; urgency=medium

  * d/p/gallery-don-t-use-command-line-options-that-got-removed-f.patch,
    d/p/screenshot-fix-invalid-free-created-by-the-previous-chang.patch:
    - backport fixes to make the gallery plugin work again (lp: #1798399)

 -- Sebastien Bacher <email address hidden> Thu, 25 Oct 2018 17:26:01 +0200

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
George (3grciii) wrote :

It would be nice to see this fix backported to Bionic (18.04) which is the version the bug was originally reported for.

Daniel van Vugt (vanvugt) wrote :

Bionic has now been nominated for a fix.

Unfortunately we are required to release fixes into disco and cosmic before bionic. Lots of releases to support right now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.26.2-1ubuntu2

---------------
totem (3.26.2-1ubuntu2) cosmic; urgency=medium

  * d/p/gallery-don-t-use-command-line-options-that-got-removed-f.patch,
    d/p/screenshot-fix-invalid-free-created-by-the-previous-chang.patch:
    - backport fixes to make the gallery plugin work again (lp: #1798399)

 -- Sebastien Bacher <email address hidden> Thu, 25 Oct 2018 17:26:01 +0200

Changed in totem (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for totem has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

George (3grciii) wrote :

Daniel That's interesting. I wasn't aware that it was required to fix a bug reported on an LTS release on development release first. I find this curious. It begs the question required by whom? And perhaps more interesting, why?

Daniel van Vugt (vanvugt) wrote :

I don't know where it's written, but it does make sense. Although I think I overstated the requirement because really I can only see a justification to get all fixes into the _next_ release before backporting.

You don't want to declare a bug fixed in the latest LTS only to find months or years later that the fix is missing in newer releases. So we must ensure every fix exists in the _next_ release before it is put into any previous release.

Changed in totem (Ubuntu Bionic):
importance: Undecided → Critical
importance: Critical → Low
status: New → Triaged
assignee: nobody → Sebastien Bacher (seb128)
Brian Murray (brian-murray) wrote :
Changed in totem (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-done

Hello George, or anyone else affected,

Accepted totem into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/totem/3.26.0-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

George (3grciii) wrote :

Hello Brian,

I tested totem 3.26.0-0ubuntu6.1 on amd64 arch. The create gallery works just fine. I'm not fully conversant on how to add a tag, so if I've done it wrong, feel free to bring me up to speed.

Tags: verification-done-bionic

Sebastien Bacher (seb128) wrote :

Thanks George for testing, the existing tags verification-needed are the ones to edit & change in verification-done, I'm doing that now

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.26.0-0ubuntu6.1

---------------
totem (3.26.0-0ubuntu6.1) bionic; urgency=medium

  * debian/patches/git_properties_segfault.patch:
    - backport fix for nautilus sometime crashing when closing the
      video properties dialog (lp: #1433984)
  * d/p/gallery-don-t-use-command-line-options-that-got-removed-f.patch,
    d/p/screenshot-fix-invalid-free-created-by-the-previous-chang.patch:
    - backport fixes to make the gallery plugin work again (lp: #1798399)

 -- Sebastien Bacher <email address hidden> Tue, 13 Nov 2018 16:17:08 +0100

Changed in totem (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions