totem video play back laggy when opened through GUI, running it from terminal is OK

Bug #1792437 reported by Daniel on 2018-09-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

I'm on fresh install of Ubuntu 18.10 daily build!
totem video playback is laggy when opened through GUI (double click on video file or open video app from applications menu). However, when I open totem from terminal everything is OK and playback is totally smooth.

I have already tried:

1) installing gstreamer-libav_1.15.1 from cosmic repo.
2) compile and install gstreamer-libav_1.14.2 from source.
3) compile and install libde265 from source.
4) compile and install totem from source.

Other players including vlc and mpv don't seem to be affected.
Even totem started from terminal is not affected.

I didn't have this problem on ubuntu 18.04LTS.

If there is a need to provide more information, I will be happy to help solving this problem.

Regards,
Danial Khazaei

Daniel (khazaei.danial) on 2018-09-13
description: updated
description: updated
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1792437

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

tags: added: cosmic
Changed in totem (Ubuntu):
status: New → Incomplete
Daniel (khazaei.danial) wrote :

apport-collect 1792437 executed and information has been sent.

Daniel (khazaei.danial) wrote :

further info:
Well it seems that its not only terminal, for example:

if I open system monitor first and then double click on the movie file, video playback is perfectly smooth! The moment I close system monitor during the playback it becomes laggy again.

However not all applications have this effect, for instance opening calculator before playing the movie doesn't have any effect and the playback would still be laggy.

Daniel van Vugt (vanvugt) wrote :

That command did not seem to work. It should have added some attachments to this bug.

Please try again:

  apport-collect 1792437

Daniel (khazaei.danial) wrote :

well when I execute this command a window pops up saying information is being collected that may help developers to fix this problem! Then it shows a summary and request my permission to send the collected data which I press send...

The first time I executed the command, it asked for permission to connect with my launchpad account which I granted.

Daniel (khazaei.danial) wrote :

Today I have received an update for xserver-xorg and xserver-xorg-video-amdgpu and the problem is now gone! no more laggy playback with totem...

Changed in totem (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers