bad colours playing movies in totem-gstreamer with xv output driver

Bug #174782 reported by infodroid on 2007-12-07
2
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: totem-gstreamer

SUMMARY
Playing movies in Totem under Ubuntu Gutsy does not render them in their correct colours. If anything they look blue.

STEPS TO REPRODUCE
Play any movie in Totem. I have tested different formats such as ogg mov avi mpg.

WORKAROUND
Force gstreamer not to use xv driver: gstreamer-properties > Video > Plugin: Change "Autodetect" to "X Window System (no xv)". It is worth pointing out that mplayer renders all videos correctly. Also VLC will play them correctly for x11 and opengl output drivers.

HARDWARE
* Mobile Intel PM965 chipset
* ATI Mobility Radeon X1350 graphics

infodroid (infodroid) wrote :

Example attached featuring Eben Moglen.

description: updated
Pedro Villavicencio (pedro) wrote :

Thanks for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

Changed in totem:
status: New → Invalid
snakingmax (snakingmax) wrote :

To solve this problem temporarily you need to change the gstreamer configuration:

Type in your console: gstreamer-properties

Now go to Video -> Default Output
and select plugin: X Window System (without Xv)

Finally restart the windows manager for the changes to take effect.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments