totem media player in the Ubuntu dock right click menu does not work, rewind does not work, nor full screen works

Bug #1726688 reported by David Gil on 2017-10-24
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Low
Unassigned
Bionic
Low
Unassigned
Cosmic
Low
Unassigned

Bug Description

Impact
------
None of the extra Desktop Actions for the Videos app (Totem) work

Test Case
---------
1. Install the update.
2. You might need to log out and log back in.
3. Open the Videos app
4. Click the + button.
5. Navigate to /usr/share/example-content/ and both media files
6. After adding the files, click the Check button at the top of the app.
   Select both videos and click Play. (This adds both videos to the current
   playlist.)
7. Play a video
8. Right-click on the videos icon in the Ubuntu Dock. Make sure that the 5 actions starting at Play/Pause and ending at Fullscreen work.

Regression Potential
-------------------
Since none of the actions worked before and the changes are minimal, there isn't really any regression risk here.

Original Bug Report
-------------------
totem media player in the Ubuntu dock right click menu does not work, rewind does not work, nor full screen works.

I'm completely aware that there is a similar bug report of Ubuntu DBUS PlayPause() Function. However it is no longer just Play and Pause anymore.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: totem 3.26.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Oct 24 12:22:01 2017
ExecutablePath: /usr/bin/totem
InstallationDate: Installed on 2017-10-19 (4 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
ProcEnviron:
 LANGUAGE=en_PH:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_PH.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
UpgradeStatus: No upgrade log present (probably fresh install)
XorgLog: Error: [Errno 2] No such file or directory: '/var/log/Xorg.0.log'

David Gil (davidjosephgil) wrote :
David Gil (davidjosephgil) wrote :

This is the video of what actually happened.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed

Same problem on Ubuntu 18.04
corrado@corrado-p6-bb-1114:~$ apt policy totem
totem:
  Installed: 3.26.0-0ubuntu2
  Candidate: 3.26.0-0ubuntu2
  Version table:
 *** 3.26.0-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p6-bb-1114:~$ inxi -Fx
System: Host: corrado-p6-bb-1114 Kernel: 4.13.0-16-generic x86_64 bits: 64 gcc: 7.2.0
           Desktop: Gnome 3.26.2 (Gtk 2.24.31) Distro: Ubuntu Bionic Beaver (development branch)
Machine: Device: desktop Mobo: ASRock model: H110M-G/M.2 serial: N/A UEFI: American Megatrends v: P1.10 date: 05/11/2017
CPU: Dual core Intel Core i3-7100 (-HT-MCP-) arch: Skylake rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15648
           clock speeds: max: 3900 MHz 1: 3900 MHz 2: 3900 MHz 3: 3900 MHz 4: 3900 MHz
Graphics: Card: Intel HD Graphics 630 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.5 ) driver: i915 Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 17.2.4 Direct Render: Yes
Audio: Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-16-generic
Network: Card: Intel Ethernet Connection (2) I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:44:7b:86
Drives: HDD Total Size: 1000.2GB (13.4% used)
           ID-1: /dev/sda model: TOSHIBA_DT01ACA1 size: 1000.2GB
Partition: ID-1: / size: 32G used: 6.9G (24%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 37.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 239 Uptime: 4:39 Memory: 1333.6/7684.1MB Init: systemd runlevel: 5 Gcc sys: 7.2.0
           Client: Shell (bash 4.4.121) inxi: 2.3.40
corrado@corrado-p6-bb-1114:~$

still on Ubuntu 18.10 Cosmic:
corrado@corrado-p6-cc-0509:~$ apt policy totem
totem:
  Installed: 3.26.0-0ubuntu6
  Candidate: 3.26.0-0ubuntu6
  Version table:
 *** 3.26.0-0ubuntu6 500
        500 http://archive.ubuntu.com/ubuntu cosmic/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p6-cc-0509:~$

tags: added: bionic cosmic
Changed in totem (Ubuntu):
importance: Undecided → Low
Simone Piccardi (simo.pk) wrote :

I made some debugging about this issue. It is due to the action names in the .desktop file not corresponding to the DBus actions of totem, plus the mute action isn't among the one implemented in totem.

I made a patch to fix the names and add the mute action to totem. This is my first contribution to Ubuntu so please tell me if there's something wrong.

Tested under Ubuntu 18.04 and 18.10

The attachment "1-3.26.0-0ubuntu6.2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Jeremy Bicha (jbicha) on 2019-01-15
Changed in totem (Ubuntu):
status: Confirmed → Fix Committed
Changed in totem (Ubuntu Bionic):
importance: Undecided → Low
status: New → In Progress
Changed in totem (Ubuntu Cosmic):
importance: Undecided → Low
status: New → In Progress
Jeremy Bicha (jbicha) on 2019-01-15
description: updated
Jeremy Bicha (jbicha) wrote :

Simone, thank you very much for submitting your patch and helping to make Ubuntu better.

I adjusted your patch a bit (modified the existing patch without renaming it and adding a separate patch for the mute action). I uploaded your work to Ubuntu 19.04, the current development release and I uploaded it as Stable Release Update (SRU) candidates for Ubuntu 18.10 18.04 LTS.

The SRUs will need to be manually approved a member of the SRU team before they will be built and made available so that testers can verify that the proposed updates fix this bug.

You can read more about this process at https://wiki.ubuntu.com/StableReleaseUpdates

I am unsubscribing ubuntu-sponsors now. Feel free to resubscribe if you have anything else that needs sponsoring.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.30.0-1ubuntu3

---------------
totem (3.30.0-1ubuntu3) disco; urgency=medium

  * Modify 91_quicklist_entries.patch:
    - Update Desktop Action names to match D-Bus names (LP: #1726688)
  * Add Add-Mute-action.patch:
    - Add Mute action so that we can use it as a Desktop Action

 -- Simone Piccardi <email address hidden> Tue, 15 Jan 2019 19:09:08 +0100

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Robie Basak (racb) wrote :

Accepting, but "there isn't really any regression risk here" isn't OK as documented at https://wiki.ubuntu.com/StableReleaseUpdates - see "It's just a one-line change!" and the documentation of this entry in the Procedure section. Please could you fix this?

For example, what if this SRU inadvertently breaks data/org.gnome.Totem.desktop.in.in somehow (eg. a syntax error that we've missed)? Or if we trigger some latent bug by expanding src/totem-menu.c:app_entries? During SRU verification, can we make sure that the existing functionality being modified here still works?

Changed in totem (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic

Hello David, or anyone else affected,

Accepted totem into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/totem/3.26.0-0ubuntu6.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in totem (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed-cosmic
Robie Basak (racb) wrote :

Hello David, or anyone else affected,

Accepted totem into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/totem/3.26.2-1ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Jeremy Bicha (jbicha) wrote :

Yes, verifying the SRU requires verifying that the .desktop works and that the Actions work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers