fullscreen controls flicker on and off

Bug #172247 reported by Gaspard Leon on 2007-11-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Undecided
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

using totem (w/ xine)

when in full-screen mode, the controls appear to "Flicker" when moving the mouse quickly to get them to appear.

So when you first open full screen, the controls are shown fine, no flickering.

Then you leave the mouse for a few seconds, the controls fade out (the screen flicks to black a couple times, but it's not bad).

Then (this is the important bit) you move the mouse to bring up the controls, if you keep moving the mouse, the controls will continue to partially fade in, then flick back to black, very irritating, the close fullscreen button comes on before the navigation bar at the bottom. If you move the mouse very slightly (just the right amount), so the controls fade in all the way before flicking off, they will stay solid, but only if you move the mouse very gently.

I'm using compiz (w/ emerald and nvidia proprietary drivers) on a Geforce 5900XT

please advise, is there a way to turn off the "fading" effect?...

Pedro Villavicencio (pedro) wrote :

Thanks for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

Changed in totem:
status: New → Invalid
Gaspard Leon (gaspard.leon) wrote :

sorry, I couldn't find a bug that was the same, so I logged a new one... I've noticed since that very occasionally (maybe once in 15 loads) it will not update the fullscreen correctly, the background (black bars) above and below the video will be whatever was below when maximizing, so will look incorrect, however when the display is corrupted thusly, the flickering does not occur...

anyway, it's probably an issue with compiz or emerald since it doesn't occur when you have desktop-effects turned off.

Gaspard Leon (gaspard.leon) wrote :

I'm now using kernel 2.6.23.12 and the driver installer from nvidia... (neither included with gutsy I know) but it works fine now.. with compiz! (although i had to run compiz --replace because desktop-effects thinks i'm not running a restricted driver)

but yeah I think this will be fixed with later kernels/driver combinations.

Also note that 2.6.23.12 is much faster overall.

Richard Hansen (rhansen) wrote :

If this bug is a duplicate, what bug is it a duplicate of? I'm having this same problem but couldn't find any other bug reports.

Gaspard Leon (gaspard.leon) wrote :

This appears to effect compiz and totem combination only. (Although I've seen compiz turned on and no flickering a couple times...)

In the end, I turned compiz off, it wasn't worth it for what I do, watching movies, browsing the web etc.

Gaspard Leon (gaspard.leon) wrote :

so for anyone with the same issue (a7x etc)

workaround 1 to fix flickering: use metacity instead of compiz (turn desktop effects off)
workaround 2 to fix fullscreen black-bars on widescreen video: use the keyboard shortcut (F11) to enable fullscreen

Richard Hansen (rhansen) wrote :

Reopening since this does not appear to be a duplicate.

Changed in totem:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

still an issue with latest updates on hardy?

Changed in totem:
assignee: nobody → desktop-bugs
status: New → Incomplete
Gaspard Leon (gaspard.leon) wrote :

it seems to work fine now, also you can fix horizontal "tearing" using advanced settings dialog in compiz and go to general section and enable vsync.

Gaspard Leon (gaspard.leon) wrote :

appears to work in hardy

Changed in totem:
status: Incomplete → Fix Released

still an issue in 9.04.
flicker only occurs using compiz.
Even using kb shortcuts to advance or rewind, flicker occurs and eventualy looses focus forcing a mouse click to regain use of kb shortcuts.
My bet is that it happens because of the rendering of the controls over the video makes the video loose focus, causing it to flicker.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers