Totem gets aspect ratio wrong when the monitor is rotated

Bug #152279 reported by Erdal Ronahi
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Confirmed
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

I use a pivot monitor. When I rotate the screen with xrandr -o left or Grandr, totem gets the aspect ratio wrong. For instance a 4:3 film is shown as 3:4, that means higher than wide. It is also not possible to correct the aspect ratio from the GUI menu. New video thumbnails are also distorted, however in the other direction: They become much wider than hig.

Kaffeine shows the same buggy behaviour as Totem, while VLC doesn't. VLC gets the aspect ratio right. This bug was also not there in Feisty.

Tags: bionic xenial
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Does it happen if you play the video using "gst-launch-0.10 playbin uri=file:///path/to/video"? What videocard and driver do you use?

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Erdal Ronahi (erdalronahi) wrote :

I am using the Nvidia driver on a GeForce FX 5200.

At the moment I cannot rotate the screen at all, neither with xrandr nor with Grandr, although xorg.conf has not changed. So I cannot test the effect of gst-launch-0.10 on the rotated screen.

Revision history for this message
Erdal Ronahi (erdalronahi) wrote :

I tried gst-launch, and it worked fine. After that, now Totem also seems to work fine. However, some video thumbnails still get distorted when being produced, namely they are much wider than high.

Revision history for this message
Erdal Ronahi (erdalronahi) wrote :

The problem is not resolved. While gst-launch gets the aspect ratio correct all the time, totem doesn't. When set to "automatic", it distorts most but not all films from 4:3 to something super-wide like 8:3 (estimated, but wider than 16:9).

Manual setting of the aspect ratio to 4:3 sometimes helps, sometimes doesn't.

This has nothing to do with rotation, so we can change the title of the bug.

Revision history for this message
Erdal Ronahi (erdalronahi) wrote : Re: [Gutsy] Totem gets aspect ratio wrong

I just realized that I have totem-xine installed instead of totem-gstreamer, replacing it with totem-gstreamer solved all my issues.

Revision history for this message
Lasy (lasy) wrote :

I have the same problem. It occurs when using a secondary display. Xine-based players think the second display's aspect ratio is the same as the default display's.

I'm using twinview and have xorg configured so that the resolution 1280x720 is displayed on the secondary monitor and resolution 1680x1050 is displayed on the primary monitor. The monitor that isn't used is set to null. I achieve this using specific metamodes.

This problem was already fixed in feisty, but has now reappeared in gutsy.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thank you for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. https://answers.launchpad.net/ubuntu

Changed in totem:
status: Incomplete → Invalid
Revision history for this message
Nuno Santos (zoryn1) wrote :

I have a similar problem. Ever since I started using compiz, totem gets the apect ratio wrong. Totem-gstreamer, totem-xine, all get the aspect ratio inverted (3:4 instead of 4:3).
Using up-to-date gutsy, nvidia drivers, and compiz.

Revision history for this message
James Harmison (jharmison) wrote :

This problem isn't gone, and it's not a support issue. It is a bug. I have pinpointed the problem, and figured out how to "fix" it, at least temporarily. I'm running UNR Jaunty, with all current updates (Totem 2.26.1). gst-launch displayed the video properly before the fix, VLC displayed it properly before the fix, Totem did not before the fix. I do not have Xine or totem-xine installed. This is with totem-gstreamer, like it's supposed to be out of the box.

The problem exists when a computer HAS BEEN connected to a second monitor. I sometimes dual-head my netbook with my TV (which has a D-SUB input) to watch streaming video on my TV. Even after disconnecting the TV, the second screen is still configured with a different aspect ratio and is therefore interfering with Totem's ability to get the aspect ratio correct.

In Jaunty, head to System -> Preferences -> Display (In previous version, I believe Display is labeled Screen Resolution or Screens, though I don't know if this bug was patched in earlier distributions and has regressed in Jaunty, possibly due to the new X server?) and set the Mirror Screens option to correct this behavior.

This is obviously not great for LEAVING your system dual-headed, but if you HAVE HAD it connected to a second screen this problem will persist afterwards, and changing this option will fix it. This is, in my opinion, a bug. Totem should be able to adjust the aspect ratio based on that of the screen that it's displaying on.

James

Revision history for this message
Lee Willis (junk-talpa) wrote :

This issues affects me. I'm on latest of all packages, and playing videos on a rotated screen and the aspect ratio is screwed. Playing videos on my normal laptop LCD is fine. I'll go through the history now and provide any info that's been asked for. If there's anything else anyone needs to identify the cause of this bug - happy to provide further diagnostics.

Changed in totem (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Lee Willis (junk-talpa) wrote :

"Does it happen if you play the video using "gst-launch-0.10 playbin uri=file:///path/to/video"?"

- No - the video plays fine when played like this:

"What videocard and driver do you use?"

- AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]
- i915 driver

Current xrandr status:
 $ xrandr -q
Screen 0: minimum 320 x 200, current 2566 x 1920, maximum 32767 x 32767
LVDS1 connected 1366x768+0+432 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768 60.0*+ 40.1
   1360x768 59.8 60.0
   1024x768 60.0
   800x600 60.3 56.2
   640x480 59.9
VGA1 connected primary 1200x1920+1366+0 left (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200 60.0*+
   1920x1080 60.0 +
   1600x1200 60.0
   1680x1050 60.0
   1280x1024 60.0
   1280x960 60.0
   1024x768 60.0
   800x600 60.3
   640x480 60.0
   720x400 70.1
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Revision history for this message
Lee Willis (junk-talpa) wrote : Re: Totem gets aspect ratio wrong

This bug is present in Ubuntu 14.04, updated description to match. I'm seeing this bug with totam 3.10.1

summary: - [Gutsy] Totem gets aspect ratio wrong
+ Totem gets aspect ratio wrong
Revision history for this message
Václav Šmilauer (eudoxos) wrote :

For me, the bug is definitely present also with gst-launch-0.10 playbin, using 3 pivoted monitors, with 14.04LTS. Smplayer gets the aspect ratio right (make your life better and ditch totem). This bug is 8 years old.

Revision history for this message
Benjamin Sperisen (lasindi) wrote :

This bug is also present in Ubuntu 14.10, for me. I have dual monitors with an NVIDIA GeForce 9800 GT, the binary NVIDIA driver version 331.113. Pretty unbelievable that this bug has lasted 8 years....

Revision history for this message
Furkan (falaca) wrote :

This bug was also present on my system up to and including Ubuntu 14.10. With 15.04, totem simply freezes when launched on a portrait display.

Revision history for this message
Furkan (falaca) wrote :

I installed Ubuntu 16.04 Alpha - the crash is gone, but the aspect ratio is still wrong when Totem is launched on a rotated screen (it's fine if launched on another screen with default orientation and then dragged over to the rotated screen).

Revision history for this message
Václav Šmilauer (eudoxos) wrote :

This bug is 11 years old by now. Totem is the default movie player for Ubuntu and this deserves proper attention.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

It appears nobody has confirmed this bug since January 2016. Can you confirm which release you see the problem in?

summary: - Totem gets aspect ratio wrong
+ Totem gets aspect ratio wrong when the monitor is rotated
Revision history for this message
Krzysztof Dryja (cih997) wrote :

Ubuntu 18.04.3 LTS
Kernel 4.15.0-58-generic
Totem 3.26.0

Wrong ratio when video opened on rotated (pivot) monitor - issue still exists.

PS. If I move Totem window from rotated monitor to another, not rotated one and open video, ratio is correct. I can then move app window to the rotated monitor and it's still with correct ratio. Workaround but only if you have another not rotated monitor attached.

Side note: checked recent VLC and the issue is not present with it.

Cheers.

tags: added: bionic xenial
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers