Totem menu bar is displayed in fullscreen mode (during gnome-flashback session or when Top Bar > Application Menu is disabled)

Bug #1502476 reported by Mystic-Mirage on 2015-10-03
266
This bug affects 57 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Medium
Daniel van Vugt

Bug Description

The menubar of Totem video player doesn't hide in fullscreen mode when I use gnome-flashback session.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed
sde (sde) wrote :

I was looking for how to fullscreen Totem in Lubuntu. The menu bar is still there after pressing f11 and after the other controls disappear. I confirmed it affects a Gnome session, it also affects LXDE sessions, and it does not affect the Ubuntu default session.

sde (sde) wrote :

Workaround: Instead of using Totem, use GNOME MPlayer which can display videos fullscreen.

Wolfgang Schnerring (wosc) wrote :

I'm seeing the same issue with totem under cinnamon (I'm on Ubuntu 15.04), the menubar is still visible in fullscreen mode, have not found a way to hide it.

description: updated
Toshio Ito (debug-ito) wrote :

I have the same issue in Xubuntu 16.04 beta with the default GTK theme (Greybird)

- totem 3.18.1-1ubuntu4
- xfwm4 4.12.3-1ubuntu1

Dmitry Shachnev (mitya57) wrote :

Lars, you are the author of 0001-Add-a-traditional-menubar.patch in totem, can you please look at this bug?

suletom (suletom) wrote :

Same problem on 16.04 beta (mate desktop).

Ville Ranki (ville-ranki) wrote :

Same problem on 16.04 (cinnamon desktop). Happened also on 15.10.

Dragor (gregory-brancq) wrote :

Same problem on 16.04 with cairo-dock session.

houstonbofh (leesharp) wrote :

16.04 release with Flashback. Nice annoying non-removable menu bar.

Same problem on 16.04 with both xfce4 and cinnamon-session.

JP (vectorpoem) wrote :

This happens for me too in 16.04 with GNOME3.

Igi (igilama) wrote :

Affects also Kubuntu 15.10

Robert Bruce Park (robru) wrote :

AUGH, as a workaround I installed Totem from the GNOME3 staging PPA, that worked for a time but then this patch managed to work it's way through debian and then to that PPA, too! Apparently nobody on the desktop team or even in debian watches fullscreen movies!

Robert Bruce Park (robru) wrote :

I've created a PPA and uploaded a build without this patch. Should work for anybody using GNOME3 staging PPA on xenial.

https://launchpad.net/~robru/+archive/ubuntu/unbork-totem/

no longer affects: ubuntu-gnome-flashback
f-r-e-e-s-k-y (f-r-e-e-s-k-y) wrote :

this also affects budgie-remix 16.04, no gnome-flashback involved

Ramon Orru (ramon-orru) wrote :

same problem on yakkety - cinnamon desktop

Mike Chelen (mchelen) wrote :

Confirmed on Ubuntu Gnome 16.10

Roman Zabaluev (haarolean) wrote :

Wow, two years old bug and still stretches from version to version. Still not fixed even in 17.04. Great.

houstonbofh (leesharp) wrote :

Here is to hoping that dumping Unity freed up some resources to fix stuff like this. But it is shameful that things like this go on. I have a bunch of ancient bugs that just sit there...

CenterTest (idrissi27) wrote :

same problem on Ubuntu Studio 16.10

Boyd (boyd-dyob) wrote :

Confirmed in Ubuntu 17.04 with XFCE

Rocko (rockorequin) wrote :

Confirmed in Ubuntu 17.10.

Jeevan.U (jeevanthanal) wrote :

Confirmed in Ubuntu 17.10.

Roman Zabaluev (haarolean) wrote :

I don't think they even care about this 2yo bug. I guess switching to VLC is the best option, guys.

houstonbofh (leesharp) wrote :

I am hoping all of the suddenly freed up Unity devs are looking for something to do! :) In all seriousness, I am hoping that this gets fixed in the switch to pure gnome.

Daniel van Vugt (vanvugt) wrote :

Yeah I think I know the simple solution for this and now (some time before 18.04) is the time to fix it.

Lion1969 (lion-box) wrote :

Most probably the very same problem is present in Eog
https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1545872

summary: - Totem menubar is displayed in fullscreen mode during gnome-flaskback
- session
+ Totem menu bar is displayed in fullscreen mode (during gnome-flashback
+ session or when Top Bar > Application Menu is disabled)
Changed in totem (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: totem → ubuntu
Changed in ubuntu:
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

When done we might also want to close this:
https://bugzilla.gnome.org/show_bug.cgi?id=749695

no longer affects: ubuntu
Changed in totem (Ubuntu):
importance: Undecided → Medium
status: Confirmed → In Progress
Kai Mast (kai-mast) wrote :

Any progress on this? The issue also exists on bionic.

tags: added: bionic zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.26.0-0ubuntu3

---------------
totem (3.26.0-0ubuntu3) bionic; urgency=medium

  * Drop patches that provided old-style decorations and menus for Unity7.
    This conveniently also fixes LP: #1502476. LP: #1719322

 -- Daniel van Vugt <email address hidden> Thu, 25 Jan 2018 05:42:51 +0800

Changed in totem (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.