totem plugin going fullscreen does not work (was: freezes computer)

Bug #148073 reported by Kai Schroeder on 2007-10-02
12
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned
f-spot (Ubuntu)
Undecided
Unassigned
totem (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

When compiz is enabled, switching to fullscreen in the totem firefox plugin freezes the computer. The plugin actually does not switch to fullscreen - firefox is still shown. the video window is not updated anymore, sound is still playing though. I can still move the mouse cursor but I cannot use the computer anymore. All keyboard input is disabled (like ctrl-alt-f1 or alt-tab). I can only press the hardware reset button to continue work. I have verified that this does not happen when metacity is used as the window manager.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

What video driver do you use? Can you give a example website where this bug can be tested against? Does it only happen with firefox or does it happen with the regular totem in fullscreen mode as well?

Thanks,
 Michael

Changed in compiz:
importance: Undecided → High
status: New → Incomplete
Michael Vogt (mvo) wrote :

I just tried to reproduce it and it does not crash for me but it also does not go to fullscreen video.

Changed in compiz:
importance: High → Medium
status: Incomplete → Confirmed
Michael Vogt (mvo) wrote :

I used http://stage6.divx.com as a example video source.

Kai Schroeder (kai-schroeder) wrote :

Hm, although it was perfectly reproducible after several reboots yesterday, I can't reproduce the freezing now either. Today the plugin shows the video in a small window including decorations when I want to go fullscreen. Once, directly after switching to compiz from metacity, it even worked as expected. I use the nvidia-glx-new driver on a Geforce 8600 gts. The video player itself works fine.

Markus Kienast (elias1884) wrote :

Same as mentioned above happens to me. The fullscreen video is showed in a small window instead. Yet, when I maximize the window, still the exit fullscreen button is shown in the top-right corner and working as expected.

The reason for this seems to be the compiz workarounds plugin. The legacy fullscreen option is on by default. When I turn it off, everything works as expected apart from some flickering when the fullscreen player controls are shown and then faded out.

I am also using nvidia-glx-new on a nVidia Corporation NV43 [GeForce Go 6200/6400] in visual effects "Extra" mode.

unggnu (unggnu) wrote :

I can confirm this. Totem fullscreen doesn't work fine with the mozilla plugin an compiz. I see a little window which could be maximized but have still a title bar and I can see the panels. If I disable compiz it works fine. The weird thing is that Totem app fullscreen works fine for me even with compiz.
VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
Btw. it wasn't possible to file a bug against totem-mozilla.

@elias
How to disable legacy fullscreen option? I haven found any option in Totem gconf.

Kai Schroeder (kai-schroeder) wrote :

The F-Spot fullscreen mode also suffers from a similar problem

Neil Martin (neil-martin28) wrote :

I confirm both totem-mozilla and F-Spot suffer this problem on my Dell Inspiron 6400 with the Intel 945GM graphics chip using the default intel xorg driver in Gutsy. Disabling compiz stops this happening.

Regards,

Neil.

leo335 (leonardo-borghi) wrote :

The F-spot suffers in normal mode too .
After few minutes, like screensaver time, it freeeze in bw screen with colour dialogue interfaces.
I can only press CTRL+ALT+BACKSPACE to reset Xserver.
Thanks

Leonardo.

Kai Schroeder (kai-schroeder) wrote :

fullscreen mode in f-spot and totem plugin works in hardy

Changed in compiz:
status: Confirmed → Fix Released
Changed in f-spot:
status: New → Fix Released
Changed in totem:
status: New → Fix Released

I still sometimes see this issue on Hardy. It is not always reproducible but I saw that freeze recently when having Firefox in fullscreen mode on one screen, and double clicking Totem on another screen to go fullscreen (I've got a dual head setup, nvidia driver). If I connect to the system with ssh, compiz.real is running at 100% cpu.

won (mrwon) wrote :

This was happening for me most often in Miro. Seemingly randomly, it would cause a movie played back in fullscreen to present me with a blank screen and no keyboard / mouse response. The same thing would also happen in Totem on DVD insertion. (Speaking of which, how does one prevent Totem or anything from opening automatically on DVD insertion anyway?)

Anyhow, if you've got the CompizConfig Settings Manager installed (it appears in the menu on this Hardy Heron install as "Advanced Desktop Effects Settings"), you can try going to the Workarounds plug-in of the Utilities section and un-checking the "Legacy Fullscreen Support" entry. That restored order for me, although some movies do stutter slightly more (I think) than they would have before that was disabled. Still, far more preferable than having to do hard restarts throughout the day.

I don't remember how I got the Advanced Desktop Effects Settings thing enabled. It didn't come preinstalled with Hardy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers