Totem disables screensaver even when playing streaming audio

Bug #145771 reported by Stephen Monteith on 2007-09-27
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Low
totem (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

I'm playing an audio stream from http://www.radioparadise.com 128K AAC stream. The screen saver/screen locking is disabled by Totem. Since there is no video content being played, disabling the screen saver is not needed. If there is an option in the preferences to bypass this, I could not find it.

ProblemType: Bug
Architecture: i386
Date: Thu Sep 27 15:37:21 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/totem
NonfreeKernelModules: nvidia
Package: totem-gstreamer 2.20.0-0ubuntu1
PackageArchitecture: i386
ProcCmdline: totem file:///home/stephen/Desktop/rp_128aac.m3u
ProcCwd: /home/stephen
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux stephen-desktop 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

Pedro Villavicencio (pedro) wrote :

Thanks for your report, confirmed, note that the screensaver is not activated even if you don't use the "Visual Effects" option, will forward upstream, thanks.

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in totem:
status: Unknown → New
Changed in totem:
status: New → Confirmed
Changed in totem:
status: Confirmed → Fix Released

in hardy alpha 6 it now has an option:
"Allow the screensaver to activate even when audio-only is playing"
but this sentence doesnt make any sense. It should instead read:
"Allow the screensaver to activate when audio-only is playing"
The "even" isnt necessary and creates confusion due to the word only appearing later in the sentence, which suggest the screensaver will also now activate when audio+video is playing which is not what it is trying to tell you it will do.

Pedro Villavicencio (pedro) wrote :

fixed on hardy, thanks for reporting.

Changed in totem:
status: Triaged → Fix Released
Changed in totem:
importance: Unknown → Low
John Bruno (jbalaska) wrote :

I understand this is a old bug, but I'm running Ubuntu 10.10 and Totem 2.32.0. When I play audio only and have the option set to "disable screen-saver while playing video only" my screen-saver/monitor sleep mode is still disabled.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.