Regression: Unable to select audio or subtitle tracks

Bug #1447224 reported by Peter Würtz on 2015-04-22
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
indicator-appmenu (Ubuntu)
High
Unassigned
Vivid
Undecided
Unassigned
totem (Ubuntu)
High
Lars Karlitski
Vivid
Undecided
Iain Lane
vlc (Ubuntu)
High
Unassigned
Vivid
Undecided
Unassigned

Bug Description

[ Description ]

Under Unity, the menu items "Language" and "Subtitles" do not show available languages and subtitles that can be selected.

[ Fix ]

Port to GMenu, which can correctly show the menu items.

NOTE that this removes the menu from full screen under Unity.

[ QA ]

Test under both Unity and GNOME shell (and optionally other DEs) that you can load a video (e.g. http://trailers.divx.com/divx_prod/divx_plus_hd_showcase/Sintel_DivXPlus_6500kbps.mkv [large - 819M]) with subtitles and languages and select between them.

[ Development fix ]

Identical & already uploaded.

[ Regression potential ]

Due to the nature of this change, you won't get the app menu when full screened under Unity any more - langs and subtitles can only be selected from the regular menu which is visible when not in full screen.

No other regressions are expected, so if you find any please report in this bug.

Peter Würtz (pwuertz) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed
Changed in vlc (Ubuntu):
status: New → Confirmed
Aaron O'Neil (alienoar) wrote :

I am experiencing exactly the same issue as described by the original report. Additionally, the hotkey to toggle subtitles on/off in vlc "S" causes file playback to terminate, defaulting to the playlist.

Aaron O'Neil (alienoar) wrote :

totem defaults to subs on and does not detect the subtitle track in the menu to to toggle on/off. vlc defaults to subs off and also does not detect the subtitle track in the menu. Both programs have the menu option to select an external subs file, but the embedded track is not able to be switched on/off.

Changed in totem (Ubuntu):
importance: Undecided → High
Changed in vlc (Ubuntu):
importance: Undecided → High
no longer affects: vlc
no longer affects: totem
Thibaut Robert (thibaut-robert) wrote :

This is bug is probably related with #1448234

Peter Würtz (pwuertz) wrote :

Ok, I read about restoring subtitle functionality by switching to fullscreen in #1448234, which gave me an idea. There is nothing wrong with totem or vlc. Yet again its Ubuntu's appmenu that botches up applications. After uninstalling appmenu everything works as expected.

Changed in vlc (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → High
Guillaume MM (gadmm) wrote :

Maybe because indicator-appmenu fails to update the menus in the new unity mode? see <https://bugs.launchpad.net/ubuntu/+source/lyx/+bug/1430059>

Fabian Franzen (flammi88-3) wrote :

I am also affected by this bug. First I thought it was a configuration mistake of mine, so I created a question at askubuntu.com where i describe the problem: http://askubuntu.com/questions/617296/unable-to-switch-subtitle-and-audio-language-in-vlc-totem-via-menu

Fabian Franzen (flammi88-3) wrote :

The patch proposed in <https://bugs.launchpad.net/ubuntu/+source/lyx/+bug/1430059> solved the problem with VLC (and also for LyX, see link before).

Unfortunately the problem with totem still persists...

Iain Lane (laney) wrote :

Lars said he would take a look at this soon - looks to me (but I don't know the most about this stuff) like totem's code is failing to populate the traditional menubar but does for the gear menu - so there's a bug in totem too in addition to any indicator-appmenu bug.

Changed in totem (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
Changed in vlc (Ubuntu Vivid):
status: New → Invalid
Iain Lane (laney) wrote :

rhythmbox has a function rb_application_link_shared_menus that might be similar to what we want here

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-appmenu (Ubuntu Vivid):
status: New → Confirmed
Changed in totem (Ubuntu Vivid):
status: New → Confirmed
Lars Karlitski (larsu) wrote :

Totem's menu xml has placeholders for subtitles and languages, which are populated dynamically based on the video that is loaded.

The traditional menubar, the gear menu, and the fullscreen gear menu all share the same placeholder ids and Totem inserts the dynamic submenu in only one of them. I've worked around this issue in [1] by not populating the gear menu and fullscreen gear menu at all. I think we can take this for now.

We're thinking about how to fix this properly in gtk as well.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=749695

Iain Lane (laney) wrote :

Recording what we said on IRC

   - No way to change languages/subtitles in fullscreen
   - There's an empty menu when the file doesn't have selectable audio languages. Can submenus be made insensitive? Or maybe add a "No languages" item.
  - Doesn't backport cleanly to 3.14 for SRU to vivid & my version didn't work properly. :)

Lars Karlitski (larsu) wrote :

This patch is a backport of the upstream patch to 3.14

The attachment "0001-Add-a-traditional-menubar.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Iain Lane (laney) wrote :

That patch uses gtk_popover_set_transitions_enabled, which is ≥ 3.16 :(

Iain Lane (laney) on 2015-06-11
Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Invalid
Changed in indicator-appmenu (Ubuntu Vivid):
status: Confirmed → Invalid
Iain Lane (laney) wrote :

Uploaded with a note about the behaviour changes. We think that on balance being able to select languages outweighs these, but it is up to you dear SRU team to decide.

description: updated
Changed in totem (Ubuntu Vivid):
status: Confirmed → In Progress
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.14.3-0ubuntu2

---------------
totem (3.14.3-0ubuntu2) wily; urgency=medium

  * debian/patches/traditional_menus.patch: Replace with
    debian/patches/0001-Add-a-traditional-menubar.patch which was submitted
    upstream and fixes dynamic menus in the traditional bar (e.g. the language
    and subtitle menus). (LP: #1447224)

 -- Iain Lane <email address hidden> Thu, 11 Jun 2015 11:39:21 +0100

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
Peter Würtz (pwuertz) wrote :

Sorry, but why did you remove the my reported regression concerning the menu in VLC?

What is the solution now? Totem gets some workaround, but the bug in Unity/Appmenu remains, leaving VLC and who knows how many other applications in a broken state?

Rich Daley (riih) wrote :

+1 to pwuertz's comment. This is a wider issue than totem so marking it as resolved when there's a workaround only for totem doesn't help those of us with issues in VLC.

On Thu, Jun 11, 2015 at 11:57:31AM -0000, Rich Daley wrote:
> +1 to pwuertz's comment. This is a wider issue than totem so marking it
> as resolved when there's a workaround only for totem doesn't help those
> of us with issues in VLC.

Please be slightly patient.

They are two different bugs. I was checking on another report.

The vlc issue is bug #1340059.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Rich Daley (riih) wrote :

Thanks! I think where it got confusing is that those of us who reported this against VLC got added to this defect when someone decided they were the same thing. I will follow that other case.

Iain Lane (laney) wrote :

On Thu, Jun 11, 2015 at 01:13:14PM +0100, Iain Lane wrote:
> On Thu, Jun 11, 2015 at 11:57:31AM -0000, Rich Daley wrote:
> > +1 to pwuertz's comment. This is a wider issue than totem so marking it
> > as resolved when there's a workaround only for totem doesn't help those
> > of us with issues in VLC.
>
> Please be slightly patient.
>
> They are two different bugs. I was checking on another report.
>
> The vlc issue is bug #1340059.

oops, bug #1430059. :)

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Hello Peter, or anyone else affected,

Accepted totem into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/totem/3.14.3-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in totem (Ubuntu Vivid):
status: In Progress → Fix Committed
tags: added: verification-needed
Alexander Usyskin (sanniu) wrote :

With totem 3.14.3-0ubuntu0.1 from proposed menus for audio ans subtitle are filled again. Thanks:)

tags: added: verification-done
removed: verification-needed
Peter Würtz (pwuertz) wrote :

Totem from proposed allows switching languages again. Thanks!

The verification of the Stable Release Update for totem has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.14.3-0ubuntu0.1

---------------
totem (3.14.3-0ubuntu0.1) vivid; urgency=medium

  * New upstream bugfix release.
  * debian/patches/ubuntu-grilo-filesystem.patch: Update our patch to use
    grl-filesystem to account for upstream changes in this release which
    caused spurious items in overview.
  * debian/patches/traditional_menus.patch: Replace with
    debian/patches/0001-Add-a-traditional-menubar.patch which was submitted
    upstream and fixes dynamic menus in the traditional bar (e.g. the language
    and subtitle menus). (LP: #1447224)

 -- Iain Lane <email address hidden> Thu, 11 Jun 2015 11:57:37 +0100

Changed in totem (Ubuntu Vivid):
status: Fix Committed → Fix Released
gfysty! (g7265899) wrote :

Come on ffs...
I had no problem whatsoever on 15.04 with the previously installed version, now the Context-Menu in Fullscreen completely disappeared in Totem and i have to minimize it it an use the Unity Taksbar to scale or deactivate/activate Subtitles, something that worked before this ... update no problem with subtitles whatsoever.

How can i revert back from this version, i can't stand the idea to have to minimize Totem to change everything that isn't volume or fast forward...

Please tell me which version was the previously released and how to revert back :( :(
I was hesitating when i saw the Totem-Update because everything was working 100% even better than VLC and now there is this mayor-fuck-up with the complettly removed context-menu within Fullscreen....

Fuck this... -.- (Yes i'am pissed.)

gfysty! (g7265899) wrote :

Temporary way to rollback (fix removed Fullscreen-Context Menu)

1:

sudo apt-get purge totem-common totem libtotem0 totem-plugins gir1.2-totem-1.0

2:

sudo apt-get install totem-common=3.14.2-0ubuntu2 totem=3.14.2-0ubuntu2 libtotem0=3.14.2-0ubuntu2 totem-plugins=3.14.2-0ubuntu2 gir1.2-totem-1.0=3.14.2-0ubuntu2

3:

Block Package using Synaptic or just don't upgrade Totem-related packages....

Cheers.

gfysty! (g7265899) wrote :

CORRECTION:

######

2:

sudo apt-get install totem-common=3.14.2-0ubuntu1 totem=3.14.2-0ubuntu1 libtotem0=3.14.2-0ubuntu1 totem-plugins=3.14.2-0ubuntu1 gir1.2-totem-1.0=3.14.2-0ubuntu1

On Sun, Jul 19, 2015 at 10:57:28PM -0000, gfysty! wrote:
> Come on ffs...
> I had no problem whatsoever on 15.04 with the previously installed version, now the Context-Menu in Fullscreen completely disappeared in Totem and i have to minimize it it an use the Unity Taksbar to scale or deactivate/activate Subtitles, something that worked before this ... update no problem with subtitles whatsoever.

Please keep your language calm.

It wasn't technically possible for us to provide for both use cases I'm
afraid. We were stuck between having no way to change languages or
subtitles (which lots of people were unhappy about) or having no menu in
fullscreen and we chose what we consider to be the lesser of two evils.

Ubuntu's team for managing updates to stable releases had the chance to
review this update and passed it too. It has gone through our correct
process.

Cheers,

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

trond hansen (thanse5) wrote :

in my opinion this fix is only a half fix,before i had to go to full
screen to cange subtitles and language, and the rotation did also work
but now there is no rotation.this is not critic i jus wish it was fixed.

trond hansen

Den 20. juli 2015 10:33, skrev Iain Lane:
> On Sun, Jul 19, 2015 at 10:57:28PM -0000, gfysty! wrote:
>> Come on ffs...
>> I had no problem whatsoever on 15.04 with the previously installed version, now the Context-Menu in Fullscreen completely disappeared in Totem and i have to minimize it it an use the Unity Taksbar to scale or deactivate/activate Subtitles, something that worked before this ... update no problem with subtitles whatsoever.
> Please keep your language calm.
>
> It wasn't technically possible for us to provide for both use cases I'm
> afraid. We were stuck between having no way to change languages or
> subtitles (which lots of people were unhappy about) or having no menu in
> fullscreen and we chose what we consider to be the lesser of two evils.
>
> Ubuntu's team for managing updates to stable releases had the chance to
> review this update and passed it too. It has gone through our correct
> process.
>
> Cheers,
>

gfysty! (g7265899) wrote :

Excuse my language, it was late and i was quite upset on the "broken" Fullscreen-Easteregg -so to speak- that this update meant for me and all others that updated and were used to have a context-menu in Fullscreen.
I actually didn't even noticed there was such a bug, cause i usally use Totem in Fullscreen, until i checked it today.

Nevertheless this isn't a fix, you take a bug fix it and in reverse create another one, this is messy bugfixing if you ask me, and i guess there will be more 'upset' people coming once this update has come around 100%.
The Problem beeing that you lose the every kind of interaction within fullscreen except for the very basic stuff, i could totally live with having to go into windowed-mode if it was just for the subs's but Maximize/Scale/ etc..

For me Totem used to be a tool i didn't even think about touching, but after the mayor-UI Changes it became a really straight-forward player, minimalistic yet intuitively easy to use, this update basically destroyed exactly that intuitiveness that i really started to love for me, so much so that i rarely use VLC anymore, hope this explains a bit why i reacted the way i reacted :)

Have a nice day folks!

Sebastien Bacher (seb128) wrote :

> but now there is no rotation

what do you mean? rotation should be/listed work if the corresponding plugin is enabled

trond hansen (thanse5) wrote :

rotation does not work in the menu but it works when i use ctrl-r,and
yes it is enabeled in plugins.see bug#1451762.it is greyed out in the
dropdown menue now. i dont think its a big deal it is only a wish to
have this
corected in the future.

trond hansen

Den 20. juli 2015 15:44, skrev Sebastien Bacher:
>> but now there is no rotation
> what do you mean? rotation should be/listed work if the corresponding
> plugin is enabled
>

Sebastien Bacher (seb128) wrote :

is that menu not working a regression of the update? can you open a new bug about it?

Mondane (mondane-woodworker) wrote :

What's the shorcut for downloading the subtitles? That menu-entry is greyed
out too on my system.

2015-07-20 17:34 GMT+02:00 trond hansen <email address hidden>:

> rotation does not work in the menu but it works when i use ctrl-r,and
> yes it is enabeled in plugins.see bug#1451762.it is greyed out in the
> dropdown menue now. i dont think its a big deal it is only a wish to
> have this
> corected in the future.
>
> trond hansen
>
> Den 20. juli 2015 15:44, skrev Sebastien Bacher:
> >> but now there is no rotation
> > what do you mean? rotation should be/listed work if the corresponding
> > plugin is enabled
> >
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1448234).
> https://bugs.launchpad.net/bugs/1447224
>
> Title:
> Regression: Unable to select audio or subtitle tracks
>
> Status in indicator-appmenu package in Ubuntu:
> Invalid
> Status in totem package in Ubuntu:
> Fix Released
> Status in vlc package in Ubuntu:
> Invalid
> Status in indicator-appmenu source package in Vivid:
> Invalid
> Status in totem source package in Vivid:
> Fix Released
> Status in vlc source package in Vivid:
> Invalid
>
> Bug description:
> [ Description ]
>
> Under Unity, the menu items "Language" and "Subtitles" do not show
> available languages and subtitles that can be selected.
>
> [ Fix ]
>
> Port to GMenu, which can correctly show the menu items.
>
> NOTE that this removes the menu from full screen under Unity.
>
> [ QA ]
>
> Test under both Unity and GNOME shell (and optionally other DEs) that
> you can load a video (e.g.
>
> http://trailers.divx.com/divx_prod/divx_plus_hd_showcase/Sintel_DivXPlus_6500kbps.mkv
> [large - 819M]) with subtitles and languages and select between them.
>
> [ Development fix ]
>
> Identical & already uploaded.
>
> [ Regression potential ]
>
> Due to the nature of this change, you won't get the app menu when full
> screened under Unity any more - langs and subtitles can only be
> selected from the regular menu which is visible when not in full
> screen.
>
> No other regressions are expected, so if you find any please report in
> this bug.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-appmenu/+bug/1447224/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.