nautilus crashed with SIGSEGV in discovered_cb()

Bug #1433984 reported by emk2203 on 2015-03-19
98
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Totem
Expired
Medium
nautilus (Ubuntu)
Undecided
Unassigned
totem (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact
nautilus segfaults sometime when closing the property dialog on a video

* Test case

- open nautilus
- open the file properties of a mp3
- close the dialog

nautilus should not segfault (close directly by hitting esc to increase the chances to hit the bug)

the errors should also stop with the new version
https://errors.ubuntu.com/problem/d154b3cfc3985b5a6c5c8f1b1e2dfc670aa1e5d7

* Regression potential

The changes are in the nautilus properties page, check that this one still works correctly
---

Tried to open a file

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: totem 3.14.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
ApportVersion: 2.16.2-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Mar 19 10:23:11 2015
ExecutablePath: /usr/bin/nautilus
InstallationDate: Installed on 2011-10-03 (1263 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcCmdline: nautilus -n
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 LANGUAGE=de_DE
 XDG_RUNTIME_DIR=<set>
SegvAnalysis:
 Segfault happened at: 0x7f04073a4c2b: mov (%rcx),%rdi
 PC (0x7f04073a4c2b) ok
 source "(%rcx)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: totem
StacktraceTop:
 ?? () from /usr/lib/nautilus/extensions-3.0/libtotem-properties-page.so
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 g_cclosure_marshal_generic () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
SystemImageInfo:
 current build number: 0
 device name: ?
 channel: daily
 last update: Unknown
Title: nautilus crashed with SIGSEGV in ffi_call_unix64()
UpgradeStatus: Upgraded to vivid on 2014-12-24 (84 days ago)
UserGroups: adm admin bumblebee cdrom dialout lpadmin plugdev sambashare scanner

emk2203 (emk2203) wrote :

StacktraceTop:
 discovered_cb (discoverer=<optimized out>, info=0x41bf4e0, error=<optimized out>, props=0x7f0410012740) at totem-properties-view.c:287
 ffi_call_unix64 () at ../src/x86/unix64.S:76
 ffi_call (cif=cif@entry=0x7fffe42205d0, fn=<optimized out>, rvalue=0x7fffe4220530, avalue=avalue@entry=0x7fffe42204d0) at ../src/x86/ffi64.c:525
 g_cclosure_marshal_generic (closure=0x36e8fd0, return_gvalue=0x0, n_param_values=<optimized out>, param_values=<optimized out>, invocation_hint=<optimized out>, marshal_data=0x0) at /build/buildd/glib2.0-2.43.91/./gobject/gclosure.c:1448
 g_closure_invoke (closure=0x36e8fd0, return_value=0x0, n_param_values=3, param_values=0x7fffe4220800, invocation_hint=0x7fffe42207a0) at /build/buildd/glib2.0-2.43.91/./gobject/gclosure.c:768

Changed in totem (Ubuntu):
importance: Undecided → Medium
summary: - nautilus crashed with SIGSEGV in ffi_call_unix64()
+ nautilus crashed with SIGSEGV in discovered_cb()
tags: removed: need-amd64-retrace
Sebastien Bacher (seb128) wrote :
information type: Private → Public
Changed in totem (Ubuntu):
importance: Medium → High
status: New → Triaged
Changed in totem:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in totem:
status: Confirmed → Incomplete
tags: added: wily
tags: added: xenial
tags: added: artful
tags: added: bionic
Changed in nautilus (Ubuntu):
status: New → Confirmed
description: updated
Changed in totem:
status: Incomplete → Expired
Sebastien Bacher (seb128) wrote :

The bug was fixed in 3.26.2 in cosmic, the errors summary confirms there is no report on this serie, I've uploaded a SRU to bionic now

description: updated
Changed in totem (Ubuntu):
status: Triaged → Fix Released

Hello emk2203, or anyone else affected,

Accepted totem into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/totem/3.26.0-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in totem (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

the 3.26.0-0ubuntu6.1 update seems to behave correctly, no segfault issue when closing the properties dialog

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.26.0-0ubuntu6.1

---------------
totem (3.26.0-0ubuntu6.1) bionic; urgency=medium

  * debian/patches/git_properties_segfault.patch:
    - backport fix for nautilus sometime crashing when closing the
      video properties dialog (lp: #1433984)
  * d/p/gallery-don-t-use-command-line-options-that-got-removed-f.patch,
    d/p/screenshot-fix-invalid-free-created-by-the-previous-chang.patch:
    - backport fixes to make the gallery plugin work again (lp: #1798399)

 -- Sebastien Bacher <email address hidden> Tue, 13 Nov 2018 16:17:08 +0100

Changed in totem (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for totem has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.