[gutsy] totem browser-plugin makes firefox-granparadiso crash

Bug #131658 reported by Fabien Tassin on 2007-08-10
14
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

Firefox Granparadiso (currently 3.0 alpha 7) crashes with missing symbols in totem plugin.

Most of those could be fixed by adding "-L/usr/lib/firefox -lxpcom" (ie linking with Firefox 2 as usual) so at runtime, Firefox 3 also knows it has to load -lxpcom (but from its own /usr/lib/firefox-granparadiso following its own LD_LIBRARY_PATH).

I have a working patch that does just that.

After this patch, there's still one remaining missing symbol: nsMemory::Clone
Problem is this symbol was in -lxpcom before, it is now only in libxpcomglue.a (which is in Firefox SDK that's now in firefox-granparadiso-dev in gutsy, but unfortunately not in firefox-dev).

Instead of messing with compilation options, I thought it was better to not use that symbol, which is used only 3 times in the whole totem source tree.

I'm made a second (working) patch.

I hope you'll consider those patches so that firefox 3 users can also use totem plugin, like I do now.

In the long term, it would be better to stop compiling against firefox-dev but use xulrunner sdk (that will be packaged hopefully soon by the MozillaTeam).

patches follow.

Fabien Tassin (fta) wrote :
Fabien Tassin (fta) wrote :
Fabien Tassin (fta) wrote :

those patches were made against SVN sources. Should apply cleanly on stock 2.19.6.

Not posted upstream as they already have the libxpcomglue detection code so it's ubuntu's fault for not doing the proper thing. Well, I guess ;)

Sebastien Bacher (seb128) wrote :

Thank you for your bug and the patches, could you explain what is the libxpcomglue detection code and why you think it doesn't work in Ubuntu?

Sebastien Bacher (seb128) wrote :

Confirming the bug, the -lxpcom is a know issue and we already used a similar workaround previous cycle

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the issue is fixed in the current version

Changed in totem:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers