OSD (skip, pause) take full window (and fullscreen) height

Bug #1309605 reported by Robin Roth on 2014-04-18
246
This bug affects 51 people
Affects Status Importance Assigned to Milestone
Totem
Expired
Medium
totem (Ubuntu)
High
Unassigned

Bug Description

The OSD icons for forward/backward skip and pause have the wrong heigt. They take the full (sometimes even more) height on the player window and also full height in fullscreen mode.

This appeared after the upgrade to trusty (totem 3.10.1)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed
Anders Glent Buch (andersgb1) wrote :

Same here, but only after I've had the player in fullscreen. Until that point, no OSD is shown at all!

Robin Roth (robinro) wrote :

Let me be a bit more precise (no pun intended).
In Window mode, it I resize the window while the OSD is shown, it is rescaled to the window size. When switching to full screen while an OSD is there, it is also resized.
So a temporary workaround is to resize the window to a minimal size while forcing an OSD and then never again resize when an OSD is shown.

Changed in totem (Ubuntu):
importance: Undecided → High
kek (ubuntu2016) wrote :

This happens with me too. It either never appears or when it appears it is as big as my screen. 14.04 fresh install.

beccatoria (beccatoria) wrote :

Same problem here, fresh 14.04 install, tried to reinstall, did no good.

Goalie Fight (goaliefight) wrote :

Same here. Happens when fast forwarding in a video on 14.10.

Goalie Fight (goaliefight) wrote :

Correction: Still an issue is 14.04.

Avi Marcus (avi-amarcus) wrote :

I'm on a fresh install of 14.04 and I have this problem, only in full screen. Reinstall didn't help.

Avi Marcus (avi-amarcus) wrote :

I tried:

sudo apt-get remove totem
sudo apt-get install --reinstall totem

And reinstalling but it didn't change anything.

However this worked:
sudo apt-get autoremove totem
sudo apt-get install totem

Avi Marcus (avi-amarcus) wrote :

Ah. scratch that, no, it didn't work either.
Ah, I had it full-window but not full screen... it's only a problem full screen.

Goalie Fight (goaliefight) wrote :

Tried removing and reinstalling. Still an issue for me on 14.04 with all updates as of May 31 2014. Does it in window or full screen. Screenshot attached.

Stego (stegomon) wrote :

still an issue on 14.04

Tom Oehser (tom-toms) wrote :

PLEASE FIX THIS ONE!!!

Changed in totem:
importance: Unknown → Medium
status: Unknown → Expired
fabio (fabio1977) wrote :

I tested Xubuntu 14.04 for a couple of days, and there the background of the icons is transparent. So it doesn't covers this much of the screen.

In Xubuntu I installed totem from the original repositories:

sudo apt-get install totem

I'm not sure, but I guess, that this is the same package as in Ubuntu 14.04. If so, then this should have to do with the unity theme, or not?

Maybe, this is a clue!? I hope so.

Forest (foresto) wrote :

I'm running Xubuntu 14.04, and the problem definitely exists here. Yes, the icon backgrounds are technically transparent, in that the underlying video is visible outside the icons' rounded corners, but the icons themselves are opaque and cover almost the entire video frame.

Shahverdy (shahverdy) wrote :

I noticed that when I play a video, as far as I am in maximized mode (not full screen) no icons are shown for a while. As soon as I enter the full screen mode then icons are shown as big as the screen size (size=size of full screen).

Shahverdy (shahverdy) wrote :

related to my previous comment.

D3Hunter (jujj603) on 2014-10-08
Changed in totem (Ubuntu):
assignee: nobody → D3Hunter (jujj603)
assignee: D3Hunter (jujj603) → nobody
status: Confirmed → New
assignee: nobody → D3Hunter (jujj603)
status: New → Confirmed
assignee: D3Hunter (jujj603) → nobody
D3Hunter (jujj603) wrote :

Patch code below to totem3.10.1, will fix this annoying problem.

**It may cause other display problems as i haven't run a full test**

    --- totem-3.10.1/src/totem-object.c 2013-09-29 20:18:43.000000000 +0800
    +++ totem-3.10.1-myversion/src/totem-object.c 2014-10-08 21:59:52.266918845 +0800
    @@ -3356,6 +3356,7 @@
        icon_name = totem_get_rtl_icon_name ("media-playback-start");
       else
        icon_name = "media-playback-pause-symbolic";
    + icon_name = NULL;
       totem_fullscreen_show_popups_or_osd (totem->fs, icon_name, FALSE);
       totem_action_play_pause (totem);
       return TRUE;
    @@ -3692,6 +3693,7 @@
       retval = FALSE;
      }

    + icon_name = NULL;
      if (icon_name != NULL)
       totem_fullscreen_show_popups_or_osd (totem->fs,
                icon_name,

Mn1945_786 (mohsin-hassan2009) wrote :

Can you please tell me in which file should I paste the above code?

Anyway, sudo apt-get install --reinstall totem fixed the icons issue. But I have to make sure not the enable fullscreen on totem because doing that brings the huge icons back.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.