Ubuntu

totem crashed with signal 5

Reported by Shirish Agarwal on 2007-07-28
42
This bug affects 1 person
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

I tried to play a .mkv (matroska video file format) http://en.wikipedia.org/wiki/.mkv & totem crashed. It didn't give any details or ask for any codec installation or anything. it just crashed.

ProblemType: Crash
Architecture: i386
Date: Sat Jul 28 18:15:58 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/totem
NonfreeKernelModules: cdrom
Package: totem-gstreamer 2.19.4-0ubuntu4
PackageArchitecture: i386
ProcCmdline: totem file:///home/shirish/mvgroup/Discovery.HD.%20Return.to.Flight.The.Inside.Story.x264.AC3.5.1.1080.www.mvgroup.org.mkv
ProcCwd: /home/shirish/mvgroup
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_IN.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: totem
StacktraceTop:
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? ()
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? ()
Title: totem crashed with signal 5
Uname: Linux Mugglewille 2.6.22-8-generic #1 SMP Thu Jul 12 15:59:45 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Shirish Agarwal (shirishag75) wrote :

StacktraceTop:gdk_x_error (display=0x83301d0, error=0xb1faa7e8) at /build/buildd/gtk+2.0-2.11.6/gdk/x11/gdkmain-x11.c:641
bonobo_x_error_handler (display=0x83301d0, error=0x80ab898) at bonobo-ui-main.c:58
_XError (dpy=0x83301d0, rep=0xb1faa8b0) at ../../src/XlibInt.c:2907
_XReply (dpy=0x83301d0, rep=0xb1faa8b0, extra=0, discard=1) at ../../src/XlibInt.c:1833
XSync (dpy=0x83301d0, discard=0) at ../../src/Sync.c:48

Changed in totem:
importance: Undecided → Medium
Shirish Agarwal (shirishag75) wrote :

libmatroska is installed.

shirish@Mugglewille:~$ aptitude search matroska
p libmatroska-dev - extensible open standard audio/video container format
i A libmatroska0 - extensible open standard audio/video container format
p libmatroska0-dbgsym - debug symbols for package libmatroska0

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Does it happen every time you try to open this video? What videocard and driver do you use?

Changed in totem:
assignee: nobody → desktop-bugs
status: New → Incomplete
Shirish Agarwal (shirishag75) wrote :

It happens every time. Here's the output from PCI devices in hardinfo

Host bridge Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface
VGA compatible controller Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device
USB Controller Intel Corporation 82801DB/DBL/DBM
USB Controller Intel Corporation 82801DB/DBL/DBM
USB Controller Intel Corporation 82801DB/DBL/DBM
USB Controller Intel Corporation 82801DB/DBM
PCI bridge Intel Corporation 82801 PCI Bridge
ISA bridge Intel Corporation 82801DB/DBL
IDE interface Intel Corporation 82801DB
Multimedia audio controller Intel Corporation 82801DB/DBL/DBM
Multimedia controller Philips Semiconductors SAA7130 Video Broadcast Decoder
Ethernet controller Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
Ethernet controller Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet

As one can see its an Intel 845G/GL/GE/PE integrated chipset.

The driver I use is the old 'i810' driver. The newer driver has problems with the i845 chipset series I believe.

Sebastien Bacher (seb128) wrote :

does it happen if you play the video using xine for example?

Shirish Agarwal (shirishag75) wrote :

I don't have that video anymore but it played fine in one of the other players that much I remember as I don't have the .mkv file anymore hence marking it as invalid.

Changed in totem:
status: Incomplete → Invalid
Matthew Garrett (mjg59) wrote :

Setting back to previous status.

Changed in totem:
status: Invalid → Incomplete
Sebastien Bacher (seb128) wrote :

Does it happen with an another video?

Shirish Agarwal (shirishag75) wrote :

my issue is I don't know any specific site which uses .mkv, if somebody knows I'll then download stuff from there, test out & let you guys know.

Totem crashes playing a video (not .mkv), sometimes crashes randomly, in
gnome, updating from feisty changing repositories feisty to gutsy, and
installing codecs with automatix.

--
Existen 100 tipos de personas: las que saben binarios, las que no saben
binarios, las que creen que saben pero no saben, y las que dicen que no
saben pero saben.

Sebastien Bacher (seb128) wrote :

automatix is not supported and known to create issues, does it happen on a system where it has not been used?

Pedro Villavicencio (pedro) wrote :

Still an issue with latest Gutsy?

Pedro Villavicencio (pedro) wrote :

Closing this report for now, feel free to reopen it if you can reproduce it with Gutsy, thanks you!.

Changed in totem:
status: Incomplete → Invalid
Vladislav Muravyev (rex-lux) wrote :

The same bug at Intrepid Ibex (Linux vm-desktop 2.6.26-5-generic #1 SMP Fri Aug 15 13:54:22 UTC 2008 x86_64 GNU/Linux) whether to open any file (DV, avi, MPEG-2, audio files...), whether to use gstreamer-based totem or Xine...

Vladislav Muravyev (rex-lux) wrote :

the same situaltion with totem-gstreamer 2.23.4-0ubuntu2 version.

Changed in totem:
status: Invalid → Incomplete
Vladislav Muravyev (rex-lux) wrote :

It seems not to be bug of totem, because VLC and Mplayer also crashed on opening.

Changed in totem:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers