streaming icecast server and ogg vorbis - only 1 first entry in the playlist played

Bug #127374 reported by Alexandre Dulaunoy on 2007-07-21
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Low
Unassigned
rhythmbox (Ubuntu)
Low
Unassigned
totem (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: totem

When listening to an OGG Vorbis stream from an Icecast server, totem is just playing the first current entry and
is not following the stream to play the complete stream. (e.g. http://a.6f2.net:8000/ClassicHouse.ogg.m3u )

This is only an issue when an Icecast server is playing various files...

ProblemType: Bug
Architecture: i386
Date: Sat Jul 21 13:56:54 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/totem
Package: totem-gstreamer 2.18.1-0ubuntu3
PackageArchitecture: i386
ProcCmdline: totem file:///tmp/ClassicHouse.ogg.m3u
ProcCwd: /home/adulau
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/adulau/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
SourcePackage: totem
Uname: Linux feedit 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

Related branches

Alexandre Dulaunoy (adulau) wrote :
Changed in totem:
importance: Undecided → Low

I can confirm that this bug is present in both totem-gstreamer and rhytmbox in Feisty. For any web radio stream in OGG Vorbis format, they will only play the current song. When the stream switches to a new song, the client will appear to continue downloading - but there is not any sound output.

As both totem and rhythmbox has this problem, I suspect that this a bug in the gstreamer OGG support, so i marked this bug as "affects gstreamer0.10". VLC is NOT affected.

Some of the streams i tried to play are:
http://bombastix.soundbomb.net:8000/nectarine.ogg
http://anka.org:8080/fresh.ogg

Pedro Villavicencio (pedro) wrote :

Confirmed with Hardy, but it's more like a gstreamer task, leaving that one, thanks!.

Changed in rhythmbox:
status: New → Invalid
Changed in totem:
status: New → Invalid
Changed in gstreamer0.10:
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

could somebody having the issue send the bug to bugzilla.gnome.org?

Sebastien Bacher (seb128) wrote :

the issue should be fixed with decodebin2 in jaunty

Changed in rhythmbox (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Invalid → Triaged
Changed in gstreamer0.10 (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.0-0ubuntu2

---------------
rhythmbox (0.12.0-0ubuntu2) jaunty; urgency=low

  * debian/patches/90_svn_change_fix_crasher.patch:
    - svn change to fix a crasher (lp: #346877, #346514)
  * debian/patches/91_svn_change_decodebin2_fix_chained_ogg.patch:
    - svn change to use decodebin2 that should fix the playing of chained ogg
      (lp: #127374)
  * debian/patches/92_svn_change_fix_psp_nokia770_crasher.patch:
    - svn change to fix a crash with psp and nokia770 devices (lp: #183797)
  * debian/patches/93_svn_change_fix_device_change_crasher.patch:
    - svn change to fix a crash on device change (lp: #73059)

 -- Sebastien Bacher <email address hidden> Wed, 01 Apr 2009 21:50:31 +0200

Changed in rhythmbox:
status: Triaged → Fix Released
vitja (vitja-makarov) wrote :

Bug still exists in both rhythmbox and totem on jaunty, updated 04/02

produnis (schlarmann-uni-wh) wrote :

same with me using Ubuntu 9.10 64bit. Effects: Totem, Rhythmbox and VLC

Changed in gstreamer0.10 (Ubuntu):
status: Fix Released → New
Changed in rhythmbox (Ubuntu):
status: Fix Released → New
Nigel Babu (nigelbabu) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. If you could test the current Ubuntu development version, this would help us a lot. If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect 127374, and any other logs that are relevant for this particular issue.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Akoi Meexx (akoimeexx) on 2010-02-25
Changed in totem (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Invalid
Akoi Meexx (akoimeexx) wrote :

Tracked it back initially to totem, sorry about the premature status changes there. Tested and confirmed on my machine running icecast/ices2. Stream works in applications that do not utilize gstreamer.

Akoi Meexx (akoimeexx) wrote :

USERNAME@SERVER:/etc/ices2/music$ totem
/var/lib/python-support/python2.6/gdata/tlslite/utils/cryptomath.py:9: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
** Message: Error: Internal data flow error.
gstbasesrc.c(2330): gst_base_src_loop (): /GstPlayBin:play/GstSoupHTTPSrc:source:
streaming task paused, reason not-linked (-1)

Victor Vargas (kamus) wrote :

Since that stream url is not valid and you are using a very old release I will close this report for now but if you encounter that this issue reappears in latest release included in Ubuntu Maverick please reopened again. Thanks in advance

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
Omer Akram (om26er) wrote :

thanks for the bug report. I just played this stream http://anka.org:8080/fresh.ogg in rhythmbox and after a while the music was changed and nothing stopped, so I believe this issue has been fixed at some point. So I am closing this bug as invalid

PS: I am using Ubuntu Natty Narwal.

Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Omer Akram (om26er) on 2011-02-03
Changed in gstreamer0.10 (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers