symbol lookup error in libtotem-properties-page.so"

Bug #118302 reported by Fabien Tassin on 2007-06-01
54
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Critical
totem (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Nautilus restarts when I right click "Properties" on a sound or video file. It's not a crash, nautilus simply exits and gnome restarts it.

This is fresh Gutsy. Nautilus 1:2.19.2-0ubuntu2. It's been there for at least two weeks, maybe more.

I've tried to see what's causing that and found out it's a symbol lookup error inside libtotem-properties-page.so.

Here is the relevent part of a strace of nautilus:

===
read(11, " \257\203\277\0\0\0\0\1\0\0\0\1\0\0\0\f\0\0\0\1\1\1\1\1\0\1\5\t\1\1\0\0\0\0\0\3\0\0\0\0\0\0@-\0\0\0/schemas/apps/totem/network-buffer-threshold\0\1\1", 95) = 95
writev(2, [{"nautilus", 8}, {": ", 2}, {"symbol lookup error", 19}, {": ", 2}, {"/usr/lib/nautilus/extensions-1.0/libtotem-properties-page.so", 60}, {": ", 2}, {"undefined symbol: totem_interface_load_with_root", 48}, {"",
0}, {"", 0}, {"\n", 1}], 10) = 142
exit_group(127) = ?
Process 8621 detached
===

This is with totem-gstreamer 2.19.3-0ubuntu1
That's 100% reproducible.

Related branches

Fabien Tassin (fta) wrote :

I've rebuilt the package using ubuntu's sources and checked for this particular symbol. It is indeed compiled in a ".a" lib (libtotem_player.a from libtotem_player_la-totem-interface.o) but not in any shared ".so". This libtotem_player.a is bundled into two binaries (totem itself and a test app called test-properties-page).

libtotem-properties-page.so calls totem_interface_load_with_root() but is not compiled with the corresponding ".a". It can't work.

That symbol has to be put in libtotem-properties-page.so either through libtotem_player_la-totem-interface.o or libtotem_player.a, or not called at all in there.

Fabien Tassin (fta) wrote :

even if it impacts nautilus, this is a totem issue

Trueno22 (diazfam04) wrote :

I am experiencing the same isue tried switching to gstreamer-xine and still caused the same issue

Nico Crama (rossocrama) wrote :

I've the same package versions and the same issue

Fabien Tassin (fta) wrote :

I've fixed the issue and submited a patch upstream. See bug #444564 in Gnome's bugzilla.
The patch is also attached. You need to restart autogen of course.

Changed in totem:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

Thank you for the bug and the patch

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Fix Committed

Sebastien Bacher wrote:
> Thank you for the bug and the patch
>
> ** Changed in: totem (Ubuntu)
> Importance: Undecided => Medium
> Assignee: (unassigned) => Ubuntu Desktop Bugs
> Status: Unconfirmed => Fix Committed
>
>
Your welcome :).

Fabien Tassin (fta) wrote :

> Your welcome :).

that's my line.

Jonathan Vasquez (fearedbliss) wrote :

Ubulette wrote:
>> Your welcome :).
>>
>
> that's my line.
>
>
lol it's mine now :)

Changed in totem:
status: Unconfirmed → Fix Released
Changed in totem:
importance: Medium → High

BUG #120452 ISN'T A DUPLICATE OF THIS ONE!

Sebastien Bacher (seb128) wrote :

using caps will not make people read your comments, rather ignore what you are writing

I used caps only because i have already said that three-four times, but that bug is signed as a duplicate of this one yet.

Sebastien Bacher (seb128) wrote :

You sent no comment to the bug before using caps, that's not a way to behave, bug triager are trying to give an hand fixing bugs and there is no reason to use this tone even if you already wrote something on an another bug

Sebastien Bacher (seb128) wrote :

bug #120447 is a duplicate, you commented on the wrong place, you added a comment on bug #120452 and you should have unmarked it duplicate, still not a reason to act the way you did on the bug

Ok, sorry. Anyway, how do I unmark a bug duplicate?

Sebastien Bacher (seb128) wrote :

click on "Mark as duplicate" and delete the number

Sebastien Bacher (seb128) wrote :

totem (2.19.4-0ubuntu3) gutsy; urgency=low

  * debian/patches/90_from_svn_no_nautilus_lookup_error.dpatch:
    - patch from SVN, fix nautilus crashing on lookup error (LP: #118302)

 -- Sebastien Bacher <email address hidden> Mon, 25 Jun 2007 10:14:56 +0200

Changed in totem:
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.