totem crashed with SIGSEGV in g_data_set_internal()

Bug #1100937 reported by Doug McMahon on 2013-01-17
132
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem (Ubuntu)
Medium
Unassigned

Bug Description

Happens with the latest libglib2.0-0 packages (2.35.4-0ubuntu3), doesn't with previous 2.34.3
Test case:
open totem, add an audio track
add a 2nd track, totem crashes

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: totem 3.6.3-0ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-0.4-generic 3.8.0-rc3
Uname: Linux 3.8.0-0-generic x86_64
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
Date: Thu Jan 17 15:06:56 2013
ExecutablePath: /usr/bin/totem
InstallationDate: Installed on 2013-01-17 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130116)
MarkForUpload: True
ProcCmdline: totem
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fed4dcefac3 <g_datalist_id_set_data_full+483>: mov (%rcx),%edi
 PC (0x7fed4dcefac3) ok
 source "(%rcx)" (0xaaaaaaaaaaaaaaa8) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: totem
StacktraceTop:
 g_datalist_id_set_data_full () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/totem/plugins/chapters/libchapters.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: totem crashed with SIGSEGV in g_datalist_id_set_data_full()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Doug McMahon (mc3man) wrote :

StacktraceTop:
 g_data_set_internal (dataset=0x0, new_destroy_func=0x0, new_data=0x0, key_id=56, datalist=0x7fed4fc75680) at /build/buildd/glib2.0-2.35.4/./glib/gdataset.c:367
 g_datalist_id_set_data_full (datalist=datalist@entry=0x7fed4fc75680, key_id=56, data=data@entry=0x0, destroy_func=destroy_func@entry=0x0) at /build/buildd/glib2.0-2.35.4/./glib/gdataset.c:674
 g_object_real_dispose (object=0x7fed4fc75670) at /build/buildd/glib2.0-2.35.4/./gobject/gobject.c:1012
 g_object_unref (_object=0x7fed4fc75670) at /build/buildd/glib2.0-2.35.4/./gobject/gobject.c:2987
 load_chapters_from_file (uri=0x7fed50df5a90 "file:///home/doug/Music/01%20-%20The%20Thrill%20Is%20Gone.cmml", from_dialog=0, plugin=0x7fed50170dd0) at totem-chapters.c:616

Changed in totem (Ubuntu):
importance: Undecided → Medium
summary: - totem crashed with SIGSEGV in g_datalist_id_set_data_full()
+ totem crashed with SIGSEGV in g_data_set_internal()
tags: removed: need-amd64-retrace
Doug McMahon (mc3man) on 2013-01-17
description: updated
information type: Private → Public
tags: added: running-unity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Also affects a gnome-shell session & also is seen in Videos (totem) 3.7-git

Fabio Marconi (fabiomarconi) wrote :

reproduced ffwd a flac file
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=693983

Changed in totem:
importance: Unknown → High
status: Unknown → New
Changed in totem:
importance: High → Unknown
status: New → Unknown
Changed in totem:
importance: Unknown → Medium
status: Unknown → New
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1100937

tags: added: package-qa-testing
tags: added: bugpattern-needed
Doug McMahon (mc3man) wrote :

Tested upstream commit on current source, (totem-3.6.3) & a 3.7.x git source (pre new totem-pl-parser req.) & it fixes this issue
https://git.gnome.org/browse/totem/commit/?id=da0961f0f5d6221a13e9201436d84c423c811c87

Without this totem is almost worthless so should be attended to

Doug McMahon wrote:
> Without this totem is almost worthless so should be attended to

I fully agree. I stopped using totem because of this bug and switched to Audacious. Feature-wise, I liked totem better, but I just couldn't trust it.

Doug McMahon (mc3man) wrote :

In hopes of catching some attention attached debdiff

The attachment "totem_3.6.3-0ubuntu4.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Dimitri John Ledkov (xnox) wrote :

What is the test file / files that I can use to reproduce this bug?
I have been hit by something described in https://bugzilla.gnome.org/show_bug.cgi?id=693983
but running:

   rm -rf ~/.cache/gstreamer-1.0/

fixed everything for me.

Doug McMahon (mc3man) wrote :

This particular bug does not have/need any test file(s).
It's simply about adding multiple files to totem's playlist, then switching between files in the playlist (if one gets that far

The only thing I see that deleting, in my case registry.x86_64.bin, does is makes it more likely one can add a number of individual files without totem crashing just from adding files
Switching between added files almost always results in crash, more likely if all audio files but happens with mixed audio, video files or video only.

Doug McMahon (mc3man) wrote :

Will attach a quick vid showing immediate crash switching from 1st. to 2nd track in playlist
(and I assure you have tested fully on 'unadulterated' fresh 13.04 installs unlike one vid was made on.

Doug McMahon (mc3man) wrote :

For comp. a patched Videos, took liberty of adding 3 files, switching is fine. Put in a mp4 so can be viewed in browser if desired

Changed in totem:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.6.3-0ubuntu4

---------------
totem (3.6.3-0ubuntu4) raring; urgency=low

  * Apply git_refactor_async_chapters_loading patch
    - upstream fix for totem crashed with SIGSEGV in g_data_set_internal()
      (lp: #1100937)
 -- Doug McMahon <email address hidden> Tue, 12 Mar 2013 16:34:31 +0000

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.