Firefox doesn't work with AT&T Natural Voices® Text-to-Speech Demo

Bug #1075039 reported by Ma Hsiao-chun on 2012-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. http://www2.research.att.com/~ttsweb/tts/demo.php
2. Click "SPEAK"
3. Then it goes to window like the attachment firefox.png but the play controls stuck.

If I download the wav file manually, if plays in Totem.
The same website also works well in Epiphany and Google Chrome.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 16.0.2+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-32.51-generic 3.2.30
Uname: Linux 3.2.0-32-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu14
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: Cirrus Analog [Cirrus Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: maxiaojun 1958 F.... pulseaudio
BuildID: 20121025210744
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xa0900000 irq 49'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10134206,106b1c00,00100302 HDA:80862805,80860101,00100000'
   Controls : 40
   Simple ctrls : 14
Channel: Unavailable
Date: Sun Nov 4 23:21:50 2012
ForcedLayersAccel: False
IpRoute:
 default via 130.126.60.1 dev eth0 proto static
 130.126.60.0/23 dev eth0 proto kernel scope link src 130.126.61.2 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
Plugins:
 iTunes Application Detector - /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so (rhythmbox-mozilla)
 QuickTime Plug-in 7.6.6 - /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so (totem-mozilla)
 VLC Multimedia Plugin (compatible Totem 3.0.1) - /usr/lib/mozilla/plugins/libtotem-cone-plugin.so (totem-mozilla)
 Windows Media Player Plug-in 10 (compatible; Totem) - /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so (totem-mozilla)
 DivX® Web Player - /usr/lib/mozilla/plugins/libtotem-mully-plugin.so (totem-mozilla)
PrefSources: prefs.js
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=16.0.2/20121025210744
RelatedPackageVersions:
 rhythmbox-mozilla 2.96-0ubuntu4.2
 totem-mozilla 3.0.1-0ubuntu21.1
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/24/12
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP81.88Z.0047.B27.1201241646
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-94245B3640C91C81
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro8,1
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-94245B3640C91C81
dmi.modalias: dmi:bvnAppleInc.:bvrMBP81.88Z.0047.B27.1201241646:bd01/24/12:svnAppleInc.:pnMacBookPro8,1:pvr1.0:rvnAppleInc.:rnMac-94245B3640C91C81:rvrMacBookPro8,1:cvnAppleInc.:ct10:cvrMac-94245B3640C91C81:
dmi.product.name: MacBookPro8,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Ma Hsiao-chun (mahsiaochun) wrote :
Chris Coulson (chrisccoulson) wrote :

That is the totem plugin in your screenshot

affects: firefox (Ubuntu) → totem (Ubuntu)
Ma Hsiao-chun (mahsiaochun) wrote :

What about Epiphany, is it using same/similar plugin?
See epiphany.png

Ma Hsiao-chun (mahsiaochun) wrote :

As I said, offline playback in Totem works fine.
See totem.png

no longer affects: firefox (Ubuntu)
no longer affects: firefox (Ubuntu)
Chris Coulson (chrisccoulson) wrote :

Working in Chrome / Chromium / Epiphany is irrelevant as those don't use the Totem plugin to handle this.

Looking in xsession-errors shows that the separate totem-plugin-viewer process receives the correct URL from the part of totem which runs inside the browser. This isn't a Firefox bug...

JNH (jordannh) on 2013-02-14
Changed in totem (Ubuntu):
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

fixed in totem 3.6.3-0ubuntu2
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Raring Ringtail.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers