"Play Disc" available for removable media, displays error on use

Bug #428998 reported by Louis Simard on 2009-09-13
0
Affects Status Importance Assigned to Milestone
Totem
Invalid
Undecided
Unassigned
totem-pl-parser (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

Totem's Movie menu has the options Open and Open Location, under which options of the type "Play Disc 'LEGALLYBLONDE' (DVD)" appear when discs are inserted into users' CD-ROM drives. Now, that's all fine and dandy.

However, in Karmic alpha 5, inserting other sorts of removable media, like USB flash drives, also gives a Play Disc option.

The option, when used, gives the following error dialog:

> The folder contents could not be displayed
> Operation not supported

and presents the user with a "Select Movies or Playlists" window containing no files. This will heavily confuse a new user.

Steps to reproduce:

1. Open Totem.
2. Verify that the Movie menu has no Play Disc options.
3. Insert a USB flash drive, memory card or other removable media which does not have a DVD-Video or VideoCD directory structure into the computer.
4. Open the Movie menu after the flash drive appears as an icon on the Desktop. (which requires the automounter to be enabled)
5. Select the "Play Disc '2.0 GB Filesystem'" option or similar from the Movie menu.

Software versions:

Ubuntu 9.10 (Karmic) alpha 5 amd64, up-to-date as of 2009-09-13 17:30 GMT
Totem Movie Player 2.27.92
GStreamer 0.10.24
Nautilus 2.27.92

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in totem (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Changed in totem:
importance: Undecided → Unknown
status: New → Unknown
Changed in totem:
status: Unknown → New
affects: totem (Ubuntu) → totem-pl-parser (Ubuntu)
Changed in totem-pl-parser (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem-pl-parser - 2.27.92-0ubuntu1

---------------
totem-pl-parser (2.27.92-0ubuntu1) karmic; urgency=low

  * New upstream version:
    - Speed up PLS parsing
    - Fix error when trying to activate a data mount in Totem's Movie menu
      (lp: #428998)
    - Try harder to ignore text files
    - Fix test parser

 -- Sebastien Bacher <email address hidden> Tue, 15 Sep 2009 15:53:48 +0200

Changed in totem-pl-parser (Ubuntu):
status: Fix Committed → Fix Released

invalidating the bug in Totem, as it has been fixed in totem-pl-parser

Changed in totem:
importance: Unknown → Undecided
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.