rhythmbox not downloading podcast - the feed contains no downloadable items

Bug #424859 reported by James Lewis on 2009-09-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
totem-pl-parser (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Running some tests with Karmic, and I noticed that Rhythmbox now says that a number of my podcasts are failing, but it appears this is wrong. This is 0.12.4 from Karmic updated to 5 Sep 2009.

Several podcasts appear to be erroring, but it seems they are also up to date... I can only assume that it's reporting that the feed is failing when it has no new episodes... please see screenshot attached.

rhythmbox:
  Installed: 0.12.4-1ubuntu1
  Candidate: 0.12.4-1ubuntu1
  Version table:
 *** 0.12.4-1ubuntu1 0
        500 http://gb.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

James Lewis (james-fsck) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your report, may you please run rhythmbox from the command line as: rhythmbox --debug &> rhythmbox-debug.txt ; Perform the operation to reproduce the bug and attach the resulting file to the report?. Thanks in advance

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
James Lewis (james-fsck) wrote :
Download full text (3.2 KiB)

The section of the file generated while refreshing a podcast is, obviously a number of podcasts do this, but I picked a mainstream one.

(14:47:21) [0x2508040] [window_focus_cb] rb-mmkeys-plugin.c:142: window got focus, re-grabbing media keys
(14:47:25) [0x2508040] [rb_property_view_selection_changed_cb] rb-property-view.c:838: selection changed
(14:47:25) [0x2508040] [rhythmdb_read_enter] rhythmdb.c:1223: counter: 1
(14:47:25) [0x3a307f0] [query_thread_main] rhythmdb.c:4098: entering query thread
(14:47:25) [0x3a307f0] [rhythmdb_query_internal] rhythmdb.c:4075: doing query
(14:47:25) [0x3a307f0] [do_query_recurse] rhythmdb-tree.c:2243: doing recursive query, 1 conjunctions
(14:47:25) [0x3a307f0] [rhythmdb_query_model_add_results] rhythmdb-query-model.c:2023: adding 91 entries
(14:47:25) [0x3a307f0] [rhythmdb_query_internal] rhythmdb.c:4081: completed
(14:47:25) [0x2508040] [rhythmdb_read_enter] rhythmdb.c:1223: counter: 2
(14:47:25) [0x3a307f0] [query_thread_main] rhythmdb.c:4098: entering query thread
(14:47:25) [0x3a307f0] [rhythmdb_query_internal] rhythmdb.c:4075: doing query
(14:47:25) [0x3a307f0] [do_query_recurse] rhythmdb-tree.c:2243: doing recursive query, 1 conjunctions
(14:47:25) [0x3a307f0] [rhythmdb_query_model_add_results] rhythmdb-query-model.c:2023: adding 113 entries
(14:47:25) [0x3a307f0] [rhythmdb_query_internal] rhythmdb.c:4081: completed
(14:47:25) [0x2508040] [idle_process_update] rhythmdb-query-model.c:1065: inserting 91 rows
(14:47:25) [0x2508040] [idle_process_update] rhythmdb-query-model.c:1065: inserting 113 rows
(14:47:25) [0x2508040] [rhythmdb_process_one_event] rhythmdb.c:2637: processing RHYTHMDB_EVENT_QUERY_COMPLETE
(14:47:25) [0x2508040] [rhythmdb_read_leave] rhythmdb.c:1237: counter: 1
(14:47:25) [0x2508040] [rhythmdb_process_one_event] rhythmdb.c:2630: processing RHYTHMDB_EVENT_THREAD_EXITED
(14:47:25) [0x2508040] [rhythmdb_process_one_event] rhythmdb.c:2637: processing RHYTHMDB_EVENT_QUERY_COMPLETE
(14:47:25) [0x2508040] [rhythmdb_read_leave] rhythmdb.c:1237: counter: 0
(14:47:25) [0x2508040] [rhythmdb_process_one_event] rhythmdb.c:2630: processing RHYTHMDB_EVENT_THREAD_EXITED
(14:47:28) [0x2508040] [rb_podcast_source_cmd_update_feed] rb-podcast-source.c:1447: Update action
(14:47:28) [0x3455ba0] [rb_podcast_manager_thread_parse_feed] rb-podcast-manager.c:1050: attempting to parse feed http://downloads.bbc.co.uk/rmhttp/downloadtrial/worldservice/digitalplanet/rss.xml
(14:47:28) [0x3455ba0] [rb_uri_could_be_podcast] rb-file-helpers.c:507: 'http://downloads.bbc.co.uk/rmhttp/downloadtrial/worldservice/digitalplanet/rss.xml' should be Podcast file, HACK
(14:47:28) [0x3455ba0] [rb_podcast_parse_load_feed] rb-podcast-parse.c:170: not checking mime type for http://downloads.bbc.co.uk/rmhttp/downloadtrial/worldservice/digitalplanet/rss.xml (should be Podcast file)
(14:47:28) [0x2508040] [window_focus_cb] rb-mmkeys-plugin.c:142: window got focus, re-grabbing media keys
(14:47:28) [0x3455ba0] [rb_podcast_parse_load_feed] rb-podcast-parse.c:235: Parsing http://downloads.bbc.co.uk/rmhttp/downloadtrial/worldservice/digitalplanet/rss.xml as a podcast succeeded, but the feed contains no downloadable items
(14:47:31) [0x25...

Read more...

James Lewis (james-fsck) wrote :

It looks like I was wrong, it's definitely not downloading these podcasts.. you can see from this screenshot that it claims that the BBC "Digital planet" podcast rss has no downloadable items, but Firefox shows that there is a new episode not downloaded.

Pedro Villavicencio (pedro) wrote :

confirming, the podcast works fine with banshee, will send upstream thanks James.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
summary: - Podcasts in Rhythmbox report bogus errors in Karmic Alpha 5
+ rhythmbox not downloading podcast - the feed contains no downloadable
+ items
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: https://bugzilla.gnome.org/show_bug.cgi?id=594894

Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Changed in rhythmbox:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

This was fixed on totem-pl-parser reassigning, thanks for reporting.

affects: rhythmbox (Ubuntu) → totem-pl-parser (Ubuntu)
Changed in totem-pl-parser (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem-pl-parser - 2.29.92-0ubuntu1

---------------
totem-pl-parser (2.29.92-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Fix parsing of Guardian Podcasts (lp: #424859)
    - Fix parsing of pukas.wax playlist
    - Fix directory file descriptor leak
    - Fix versioning of the introspection support
  * debian/control.in:
    - don't build-depends on libdbus-1-dev, updated depends
  * debian/patches/01_fix_gir_file.patch,
    debian/patches/90autoreconf.patch:
    - the change is in the new version
 -- Sebastien Bacher <email address hidden> Thu, 18 Mar 2010 00:13:25 +0100

Changed in totem-pl-parser (Ubuntu):
status: Fix Committed → Fix Released
Austriaco (lanieves) wrote :

it would be nice if this update were to be backported to karmic. Trying to install the lucid package fails due to dependency errors:

$ sudo dpkg -i /tmp/libtotem-plparser17_2.30.0-2ubuntu1_i386.deb
Selecting previously deselected package libtotem-plparser17.
(Reading database ... 152548 files and directories currently installed.)
Unpacking libtotem-plparser17 (from .../libtotem-plparser17_2.30.0-2ubuntu1_i386.deb) ...
dpkg: dependency problems prevent configuration of libtotem-plparser17:
 libtotem-plparser17 depends on libgmime-2.4-2 (>= 2.4.11); however:
  Version of libgmime-2.4-2 on system is 2.4.6-5.
dpkg: error processing libtotem-plparser17 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libtotem-plparser17

Changed in rhythmbox:
importance: Unknown → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.