problem with DVB due to bad playlist?

Bug #275253 reported by Patrice DUROUX on 2008-09-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem-pl-parser (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

Hello,

Totem seems to be no more able to watch TV using DVB with both gstreamer and xine backend. It is opening a lot of windows , one for each channel saying this kind of message:

The playlist 'dvb://...' could not be parsed, it might be damaged.

May be a problem with totem-pl?

Regards,
Patrice.

nekko (hacker-nekko) wrote :

I have the same issue:
e.g. RTL:506000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_1_2:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE:337:338:16405
is not parsed correctly, while
Südwest BW/RP(ARD):177500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_3_4:FEC_1_2:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE:257:258:16

in the same dvb-channels.conf is read correctly.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, could anybody having the hardware to trigger this bug send it to bugzilla.gnome.org directly where the people writting the software will read it? the bugs triager who don't get the issue are not likely to reply to their comments in an useful way

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
mcjhn (mcjhn1) wrote :

I have the same problem

All channels except one are not parsed correct:

Not parsed correctly:
e.g.
BBC ONE:546000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_3_4:FEC_3_4:QAM_16:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:600:601:4175

Parsed correctly:
 e.g.
TVX / REDHOT:850000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_1_2:QAM_64:TRANSMISSION_MODE_2K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:0:0:15232

As much at TVX REDHOT is a quality channel it would be good if the others works

Hardware: Hauppauge DVB Nova-t TDA10045 (Hotplugged firmware)

I'm new to this, I'm not sure what you mean...'send it to bugzilla.gnome.org directly' sorry

mcjhn (mcjhn1) wrote :

Just a quick thought

Both correctly parsed channels contain a '/' in their names

TVX / REDHOT and Südwest BW/RP(ARD)

Sebastien Bacher (seb128) wrote :

the issue is similar to http://bugzilla.gnome.org/show_bug.cgi?id=554875 which has been fixed in the svn now

Changed in totem:
status: New → Fix Committed
Changed in totem-pl-parser:
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem-pl-parser - 2.24.1-0ubuntu1

---------------
totem-pl-parser (2.24.1-0ubuntu1) intrepid; urgency=low

  * New bug-fix only upstream release (LP: #280102):
    - fix DVB channels parsing in Totem (LP: #275253)
    - fix parsing of DOS M3U files not ending with a line feed (LP: #272761)
    - always write '#EXTM3U" at the start of M3U playlists
    - updated Danish, Romanian and Russian translations

 -- Cesare Tirabassi <email address hidden> Wed, 08 Oct 2008 12:13:49 +0200

Changed in totem-pl-parser:
status: Fix Committed → Fix Released
Changed in totem:
status: Unknown → Fix Released
Changed in totem:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.