totem won't play last file of m3u list if there's no windows endline CR/LF

Bug #272761 reported by Pablo Castellano on 2008-09-21
2
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem-pl-parser (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

I have an album ripped using windows so the m3u file has Windows newline CR/LF on every line (those ^M seen in vi).
The problem is when you are playing the album using the m3u file and the last song arrives.
If there's no newline character at the end, totem doesn't parse well the line and shows a popup saying:
"An error occurred. Location not found"

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: wl
Package: totem 2.23.91-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=es_ES.UTF-8
SourcePackage: totem
Uname: Linux 2.6.27-3-generic i686

Sebastien Bacher (seb128) wrote :

thank you for your bug report, that's not an ubuntu specific issue though, could you open it on bugzilla.gnome.org too where the people writting the software will read it too?

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Changed in totem:
status: New → Triaged
Changed in totem:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

the issue is somewhat similar to bug #251669

Changed in totem:
status: New → Fix Released

 Comment #2 from Bastien Nocera (totem developer, points: 26)
2008-09-27 03:30 UTC [reply]

Fixed in gnome-2-24 and trunk

2008-09-27 Bastien Nocera <email address hidden>

        * plparse/totem-pl-parser-lines.c (totem_pl_parser_add_m3u):
        Fix parsing of DOS M3U files where the last line finishes with
        a carriage return but no line feed (Closes: #553130)

Changed in totem:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem-pl-parser - 2.24.1-0ubuntu1

---------------
totem-pl-parser (2.24.1-0ubuntu1) intrepid; urgency=low

  * New bug-fix only upstream release (LP: #280102):
    - fix DVB channels parsing in Totem (LP: #275253)
    - fix parsing of DOS M3U files not ending with a line feed (LP: #272761)
    - always write '#EXTM3U" at the start of M3U playlists
    - updated Danish, Romanian and Russian translations

 -- Cesare Tirabassi <email address hidden> Wed, 08 Oct 2008 12:13:49 +0200

Changed in totem-pl-parser:
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.