Rhythmbox cannot handle a certain podcast URL

Bug #269471 reported by hovercraft on 2008-09-12
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
totem-pl-parser (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

When I attempt to add a new podcast feed for URL: http://www.abc.net.au/rn/podcast/feeds/spirit.xml, the feed is not added. If I run with --debug I get is this:
(00:17:01) [0x80dc408] [actually_hide_controls] rb-visualizer-plugin.c:798: hiding controls
(00:17:02) [0x80dc408] [window_focus_cb] rb-mmkeys-plugin.c:118: window got focus, re-grabbing media keys
(00:17:04) [0x80dc408] [rb_podcast_source_cmd_new_podcast] rb-podcast-source.c:1981: Got new podcast command
(00:17:10) [0x8b63100] [rb_uri_could_be_podcast] rb-file-helpers.c:809: 'http://www.abc.net.au/rn/podcast/feeds/spirit.xml' should be Podcast file, HACK
(00:17:10) [0x8b63100] [rb_podcast_parse_load_feed] rb-podcast-parse.c:134: not checking mime type for http://www.abc.net.au/rn/podcast/feeds/spirit.xml (should be Podcast file)
(00:17:10) [0x80dc408] [window_focus_cb] rb-mmkeys-plugin.c:118: window got focus, re-grabbing media keys
** Message: can't parse the file
(00:17:10) [0x8b63100] [rb_podcast_parse_load_feed] rb-podcast-parse.c:202: Parsing http://www.abc.net.au/rn/podcast/feeds/spirit.xml as a Podcast failed

I know this is a valid URL because it works with gpodder and it used to work with rhythmbox before I went to Hardy Heron.

lsb_release -rb:
Description: Ubuntu 8.04.1
Release: 8.04

apt-cache policy rhythmbox:
rhythmbox:
  Installed: 0.11.5-0ubuntu8
  Candidate: 0.11.5-0ubuntu8
  Version table:
 *** 0.11.5-0ubuntu8 0
        500 http://ftp.iinet.net.au hardy-updates/main Packages
        100 /var/lib/dpkg/status
     0.11.5-0ubuntu6 0
        500 http://ftp.iinet.net.au hardy/main Packages

ProblemType: Bug
Architecture: i386
Date: Sat Sep 13 00:07:13 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.11.5-0ubuntu8
PackageArchitecture: i386
ProcEnviron:
 PATH=/home/User Name/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.24-19-generic i686

hovercraft (roberthart) wrote :
Pedro Villavicencio (pedro) wrote :

confirming, will forward upstream, thanks for reporting.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

I've sent this upstream at: http://bugzilla.gnome.org/show_bug.cgi?id=552025 ; thanks for reporting.

Changed in rhythmbox:
status: Unknown → New
hovercraft (roberthart) wrote :

There has been no activity on this since it was reported - either here or upstream. Is there any way to prompt some action?

Sebastien Bacher (seb128) wrote :

not really, the people working on this software do that during their after work hours and there is just lot of bugs compared to the people working on it, you can add a comment on the bug to ask if somebody looked at it but that's about it there

Dan Kortschak (dan-kortschak) wrote :

I can confirm that this happens for these two URLs too:

http://www.abc.net.au/rn/podcast/feeds/bbing.xml
http://www.abc.net.au/rn/podcast/feeds/correspond.xml

But not for a number of others from the same site including:

http://www.abc.net.au/rn/podcast/feeds/mind.xml

The second of the two above appears to be HTML rather than XML, so that explains that one.

Perhaps it's just a problem with the ABC?

Ross Patterson (rossp) wrote :

I'm also getting this problem for all my feeds.

$ sudo apt-cache policy rhythmbox
rhythmbox:
  Installed: 0.11.6svn20081008-0ubuntu4.3
  Candidate: 0.11.6svn20081008-0ubuntu4.3
  Version table:
 *** 0.11.6svn20081008-0ubuntu4.3 0
        500 http://us.archive.ubuntu.com intrepid-updates/main Packages
        100 /var/lib/dpkg/status
     0.11.6svn20081008-0ubuntu4 0
          1 http://us.archive.ubuntu.com intrepid/main Packages

Dan Kortschak (dan-kortschak) wrote :

Ross, what feeds are you attempting to use. The reported URLs above were all from the abc.net.au podcasts feeds - I've looked through their feeds and they are, to varying degrees, non conforming to the standards for feeds. I think this may be the problem.

I've reported the problem to the ABC and they don't seem very much to care. If you are trying ABC feeds, you might want to add a complaint, if it's not the ABC, put the feed through http://feedvalidator.org/check.cgi and check whether it's the feed or rhythmbox.

(I'm using the same version as you and most feeds work).

Dan Kortschak <email address hidden> writes:

> Ross, what feeds are you attempting to use. The reported URLs above
> were all from the abc.net.au podcasts feeds - I've looked through
> their feeds and they are, to varying degrees, non conforming to the
> standards for feeds. I think this may be the problem.
>
> I've reported the problem to the ABC and they don't seem very much to
> care. If you are trying ABC feeds, you might want to add a complaint,
> if it's not the ABC, put the feed through
> http://feedvalidator.org/check.cgi and check whether it's the feed or
> rhythmbox.
>
> (I'm using the same version as you and most feeds work).

My feeds are all NPR feeds and they all work under banshee:

  http://www.npr.org/rss/podcast.php?id=13
  http://www.npr.org/rss/podcast.php?id=35
  http://feeds.thisamericanlife.org/talpodcast
  http://feeds.wnyc.org/radiolab

Thanks,
Ross

Pedro Villavicencio (pedro) wrote :

fixed on upstream svn now, thanks for reporting.

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
affects: rhythmbox (Ubuntu) → totem-pl-parser (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem-pl-parser - 2.26.1-0ubuntu1

---------------
totem-pl-parser (2.26.1-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #353412)
    - Fix playback of radio streams when the URL has a trailing slash
      (LP: #269471)
    - Fix detection of ISOs as VCDs or DVDs
    - Fix parsing of some podcasts with huge amounts of CDATA in the XML

 -- Andreas Moog <email address hidden> Wed, 01 Apr 2009 22:03:09 +0200

Changed in totem-pl-parser (Ubuntu):
status: Fix Committed → Fix Released
Changed in rhythmbox:
status: New → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.