Podcast feed is not added.

Bug #236800 reported by Keith on 2008-06-02
2
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem-pl-parser (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Ubuntu 8.04
rhythmbox Installed: 0.11.5-0ubuntu6
libtotem-plparser10: Installed: 2.22.3-0ubuntu2

This seems to be exactly like Bug# 202982, but that claims to be resolved.

I tried to add the following podcast feed: http://www.podshow.com/feeds/noagenda.xml
I expected a new feed to be added or an error telling me it was not added for some reason. Neither happened, no new feed, no error, no crash report.

Running Rhythmbox in debug mode produced the same output as described in Bug# 202982.

Thanks!

ProblemType: Bug
Architecture: i386
Date: Mon Jun 2 09:39:27 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.11.5-0ubuntu6
PackageArchitecture: i386
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.24-17-generic i686

Keith (keith-ray-miller) wrote :
Pedro Villavicencio (pedro) wrote :

thanks for your report, please run rhythmbox as: rhythmbox --debug &> rhythmbox-debug.txt and attach that file to the report. thanks.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Keith (keith-ray-miller) wrote :

I suffer the exact same bug running the very same setup.

Here's the feed that doesn't work for me: http://www.chyz.qc.ca/podcast.php?id=000302

I've opened a bug upstream (as recommended by fellows on #rhythmbox on irc.gnome.org) : http://bugzilla.gnome.org/show_bug.cgi?id=541405

rhythmbox -d output:
[...]
(10:35:31) [0x80dc408] [rb_podcast_source_cmd_new_podcast] rb-podcast-source.c:1981: Got new podcast command
(10:35:31) [0x80dc408] [window_focus_cb] rb-mmkeys-plugin.c:118: window got focus, re-grabbing media keys
(10:35:32) [0x80dc408] [rb_audioscrobbler_should_handshake] rb-audioscrobbler.c:876: No username set
(10:35:33) [0x8d9cee0] [rb_podcast_parse_load_feed] rb-podcast-parse.c:138: checking mime type for http://www.chyz.qc.ca/podcast.php?id=000302
(10:35:33) [0x80dc408] [window_focus_cb] rb-mmkeys-plugin.c:118: window got focus, re-grabbing media keys
** Message: can't parse the file
(10:35:33) [0x8d9cee0] [rb_podcast_parse_load_feed] rb-podcast-parse.c:202: Parsing http://www.chyz.qc.ca/podcast.php?id=000302 as a Podcast failed
[...]

Changed in rhythmbox:
status: Incomplete → Triaged
Changed in totem:
status: Unknown → New

Problem(s) have been solved upstream. I have however only been able to backport the fix for my particular problem (html comments in xml) to the current Ubuntu version... I haven't been able to locate what makes the other podcast (Keith's) fail. Upstream developper (hadess) confirmed that Keith's podcast works with the latest version though.

Changed in totem:
status: New → Fix Released
Changed in totem-pl-parser:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem-pl-parser - 2.23.91-0ubuntu1

---------------
totem-pl-parser (2.23.91-0ubuntu1) intrepid; urgency=low

  * New upstream release (LP: #262855)
    - Add support for parsing Zune and ZENCast URLs
    - Fix parsing broken podcasts with HTML comments in them
    - Better detection of Podcasts (LP: #236800)
    - Fix parsing of QuickTime metalinks masquerading as MPEG-4 files
    - Fix a few memleaks from GIO porting
    - Fixes for the Python bindings
    - Use a nice title for the developer documentation

 -- Pedro Fragoso <email address hidden> Sat, 30 Aug 2008 01:49:30 +0100

Changed in totem-pl-parser:
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.