libtotem-plparser10 Will not install.

Bug #231236 reported by W. Scott Lockwood III on 2008-05-16
40
Affects Status Importance Assigned to Milestone
totem-pl-parser (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: libtotem-plparser10

scott@scott-d630:~$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

scott@scott-d630:~$ apt-cache policy libtotem-plparser10
libtotem-plparser10:
  Installed: 2.22.2-0ubuntu1
  Candidate: 2.22.3-0ubuntu1
  Version table:
     2.22.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com hardy-updates/main Packages
 *** 2.22.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Expected result: Upgrade of package.

What happened instead:

scott@scott-d630:~$ sudo apt-get -f -u -m install libtotem-plparser10 -y --force-yes
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libtotem-plparser10: Depends: libcamel1.2-11 (>= 2.22.1.1) but 2.22.1-0ubuntu2.1 is to be installed
                       Depends: libedataserver1.2-9 (>= 2.22.1.1) but 2.22.1-0ubuntu2.1 is to be installed

Square Bottle (squarebottle) wrote :

I'm having the same issue. The updater tries to update it, and often it thinks that it succeeds, but it immediately says there's 1 new update to be done, and sure enough, it's this package. It's a loop, and it reminds me of when Beryl's packages did the same thing (like a year ago, back before it became Compiz Fusion).

I'm seeing the same thing (and I'm not the only one - Bug #231237 looks like a duplicate of this bug).

Update Manager's response to the dependency problem on my system was to make the update unselectable, although it still shows up in the list. I imagine this would be rather confusing to someone who's trying to keep their system updated but isn't familiar with the command-line tools or synaptic. Using synaptic or apt-get on the command line at least gives me enough information to discover *why* this update isn't working.

Gustavo Veloso (gjmveloso) wrote :

Confirmed!
Maybe Ubuntu pack-mans didn't synchronize repositories well...

Changed in totem-pl-parser:
status: New → Confirmed
David Pearce (halzia) wrote :

Installed version of libcamel1.2-11 is 2.22.1-0ubuntu2.1, nothing newer available.
Looks like libtotem-plparser10 was built against a backport?

Arthur (moz-liebesgedichte) wrote :

Is there a bug or blueprint for an automatic test which would check the repositories against these kind of dependency issues and warn the maintainers? They're a mere annoyance for me but I've had other users run to me because they felt that they've somehow wrecked their system.

NetworkerDeluxe (wolter-andre) wrote :

I'm having the same issue, too.

Hope a lot people will post, so the issue will be handled fast...

huiii (a00ps) wrote :

me too since yesterday at least!!

libtotem-plparser10:
  Depends: libcamel1.2-11 (>=2.22.1.1) but 2.22.1-0ubuntu2.1 is to be installed

cant install rhythmbox, brasero, and a lot of other stuff...

jojo4u (bugzilla-freedom-x) wrote :

The packages in question are in hardy-proposed. I guess you can solve the problem by adding hardy-proposed and install libcamel/libedataserver from there.

libcamel1.2-11:
  Installed: 2.22.1-0ubuntu2.1
  Candidate: 2.22.1-0ubuntu2.1
  Version table:
     2.22.1.1-0ubuntu2 0
        598 http://ftp-stud.hs-esslingen.de hardy-proposed/main Packages
 *** 2.22.1-0ubuntu2.1 0
        700 http://ftp-stud.hs-esslingen.de hardy-updates/main Packages
        100 /var/lib/dpkg/status
     2.22.1-0ubuntu2 0
        600 http://ftp-stud.hs-esslingen.de hardy/main Packages

libedataserver1.2-9:
  Installed: 2.22.1-0ubuntu2.1
  Candidate: 2.22.1-0ubuntu2.1
  Version table:
     2.22.1.1-0ubuntu2 0
        598 http://ftp-stud.hs-esslingen.de hardy-proposed/main Packages
 *** 2.22.1-0ubuntu2.1 0
        700 http://ftp-stud.hs-esslingen.de hardy-updates/main Packages
        100 /var/lib/dpkg/status
     2.22.1-0ubuntu2 0
        600 http://ftp-stud.hs-esslingen.de hardy/main Packages

Ricardo L. Febrero (rlfebrero) wrote :

I'm having the same problem. I don't think adding proposed updates is a good solution, it should have been checked that the package would upgrade before sending it to updates. I'm using a mirror from Germany.
Is someone able to upgrade the package?? Everyone should have the same problem.

jojo4u (bugzilla-freedom-x) wrote :

Of course, this is an error and adding hardy-proposed should be a temporary solution. But people like huiii should be able to install dependend software again.

Eymen A (eal) wrote :

Having the same issue with an automatic install deployments.
Its really annoying to have dependency problems.
Here is which other packages are affected:
The following packages have unmet dependencies:
  libtotem-plparser10: Depends: libcamel1.2-11 (>= 2.22.1.1) but 2.22.1-0ubuntu2.1 is installed.
                       Depends: libedataserver1.2-9 (>= 2.22.1.1) but 2.22.1-0ubuntu2.1 is installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:
brasero
deskbar-applet
gnome-applets
gnome-games
gnome-volume-manager
libdeskbar-tracker
libtotem-plparser10
python-gnome2-desktop
rhythmbox
totem
totem-gstreamer
totem-mozilla
totem-plugins

Downgrade the following packages:
gnome-panel [1:2.22.1.3-0ubuntu1 (hardy-updates, now) -> 1:2.22.1.2-0ubuntu3
(hardy)]

Leave the following dependencies unresolved:
gnome-games-data recommends gnome-games
gnome-panel recommends gnome-applets (>= 2.12.1-1)
Score is -503

Not so cool for an LTS release. But a fix is already in hardy-proposed :)
The hardy-proposed packages (libcamel, libdataserver) should go to hardy-updates soon.

darkhack (mysticdarkhack) wrote :

Same problem here and the upgrade is being halted at the time being.

dudo (thedudoworld-gmail) wrote :

same here....

both error in x86 and ppc

letubenaiah (benjhenry88) wrote :

Same problem here.

libcamel1.2-11 | 2.22.1-0ubuntu2.1 | hardy-updates | amd64, i386
libcamel1.2-11 | 2.22.1.1-0ubuntu2 | hardy-proposed | amd64, i386

libedataserver1.2-9 | 2.22.1-0ubuntu2.1 | hardy-updates | amd64, i386
libedataserver1.2-9 | 2.22.1.1-0ubuntu2 | hardy-proposed | amd64, i386

SRU'ers, please accept all rdepends of packages from -proposed into -updates at the same time, else you're breaking users systems. (this has happened before, too)

Changed in totem-pl-parser:
importance: Undecided → Critical
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem-pl-parser - 2.22.3-0ubuntu2

---------------
totem-pl-parser (2.22.3-0ubuntu2) hardy-updates; urgency=low

  * Upload to hardy-updates to not depend on other upgrades
    which didn't migrate to hardy-updates yet (lp: #231236)

 -- Sebastien Bacher <email address hidden> Sat, 17 May 2008 14:55:48 +0200

Changed in totem-pl-parser:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Accepted Seb's rebuild into hardy-updates. Sorry for the inconvenience!

mr.goose (editor-garfnet) wrote :

Problem reported, discussed analysed and fixed in less than 24 hours! That is very impressive. Well done & thanks to everyone concerned! Shame a certain Redmond-based corporation can't do that. Ah well! :-)

Anyway, I just did "sudo apt-get update" & "sudo apt-get upgrade" on all 4 of our local Ubuntu-based machines and they all are fixed. Lovely! Thanks again.

Best wishes, G.

NetworkerDeluxe (wolter-andre) wrote :

Wow, thats lovely.

I like it to say whats wrong and someone hear me. Cool, that will harden my decision for Ubuntu...

tgillett (tgillett) wrote :

I hit the problem when I upgraded two machines from Gutsy to Hardy here last night.

I noticed that Brasero, Rythmbox and Movie Player weren't loaded as part of the upgrade and wouldn't load, amongst other apps. So it has made a bit of a mess of the upgrade.

After an hour or so trying to work out what was wrong I found this thread. Thought I would wait till the repository was updated. Tried again this morning to update/upgrade but no luck.

I realised that I was pointing to a local mirror repository (Australia) so I changed to the main repository and then it picked up the changed files and allowed me to install the apps.

So I suspect the impact of the problem will be ongoing until all the mirrors are updated.

Just updating the repositories won't fix the parts of the system upgrade that weren't done. Is the any way to tell what would have been affected during the upgrade, beyond the couple of apps above?

  • unnamed Edit (1.8 KiB, text/html; charset=ISO-8859-1)

Well done, Cutty Shark! :-P

I have already upgraded, fine. Everything's Ok now.

2008/5/17 tgillett <email address hidden>:

> I hit the problem when I upgraded two machines from Gutsy to Hardy here
> last night.
>
> I noticed that Brasero, Rythmbox and Movie Player weren't loaded as part
> of the upgrade and wouldn't load, amongst other apps. So it has made a
> bit of a mess of the upgrade.
>
> After an hour or so trying to work out what was wrong I found this
> thread. Thought I would wait till the repository was updated. Tried
> again this morning to update/upgrade but no luck.
>
> I realised that I was pointing to a local mirror repository (Australia)
> so I changed to the main repository and then it picked up the changed
> files and allowed me to install the apps.
>
> So I suspect the impact of the problem will be ongoing until all the
> mirrors are updated.
>
> Just updating the repositories won't fix the parts of the system upgrade
> that weren't done. Is the any way to tell what would have been affected
> during the upgrade, beyond the couple of apps above?
>
> --
> libtotem-plparser10 Will not install.
> https://bugs.launchpad.net/bugs/231236
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Néstor Amigo Cairo
+34 687 96 74 81
<email address hidden>

W. Scott Lockwood III (wsl3) wrote :

Fixed for me as well. Thanks all!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments