Ubuntu

required kernel toshiba support not enabled

Reported by Mike.lifeguard on 2010-09-22
240
This bug affects 43 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
toshset (Debian)
New
Unknown
toshset (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: toshset

The kernel support required to use these utilities isn't installed - I can't use extra buttons, hotkeys, or change screen brightness.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: toshset 1.75-2
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
Architecture: i386
CheckboxSubmission: 8b15f4fca5292e90a3327d5e528e925e
CheckboxSystem: 988b7c9be54a1e2525cae7d97805a134
Date: Wed Sep 22 01:13:08 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: toshset

Mike.lifeguard (mikelifeguard) wrote :
John Cooper (choffee) wrote :

I am having this problem in Mavrick as the kernel has dropped the patch. Using a Toshiba Portage R500

Mark Crompton (cromptonm) wrote :

Same problem, "required kernel toshiba support not enabled", using Maverick with kernel 2.6.35-22 on a Toshiba Portege R600.

Module toshiba_acpi loaded successfully.

Changed in toshset (Debian):
status: Unknown → New
Scott Hosking (scotthosking) wrote :

Same as #3

Daniel Smith (connect404) wrote :

Same as #3

This compounded with random hard lockups.

pascal (pascal-pascallen) wrote :

Ubuntu 10.10, kernel 2.6.35-22 same problem.

How is the option.c driver for Tosh 3g modem? Likely gone, the support.

Thomas Orgis (thomas-forum) wrote :

I see that the toshiba_acpi -dev patch has been intentionally dropped, see https://lists.ubuntu.com/archives/kernel-team/2010-June/011112.html . Andy wrote:

Quote: I therefore suggest we drop this patch and see if anyone notices.

Well, I do notice. There is no way anymore to disable the backlight on this nice transflective screen -- or is there an alternative to toshset yet? Please re-integrate that patch.

Mark Crompton (cromptonm) wrote :

Thomas,

Thanks for the info on the patch - very interesting.

The main problem for me is that it is impossible to use the on-board 3g mobile broadband modem without toshset.

However, on my system if I enter the following command in a terminal, the response is:

mark@mark-PORTEGE-R600:~$ lsmod | grep toshiba
toshiba_bluetooth 2223 0
toshiba_acpi 10178 0

Now I'm no expert, but to me this means that the kernel module toshiba_acpi is in fact loaded - or am I wrong?

If toshiba_acpi is loaded, then does this mean that some other module is required in order to run toshset?

I'm happy to try and compile a kernel myself, but I'm not sure what patch is required to enable toshset?

John Cass (john-miltonroad) wrote :

I'm having the same problems on my Portege R500, used to be able to use trasflective screen now cant get toshset to work
"required kernel toshiba support not enabled."

Mark Crompton (cromptonm) wrote :

I'm open to correction on this, but it looks like the problem is that a modified version of the kernel module toshiba_acpi is required for toshset to run. Although toshiba_acpi is present in Ubuntu 10.10 (with kernel 2.6.35), it seems it is the unmodified version, and it needs to be patched. Unfortunately I don't know how to do this - if anyone does please let us know!

The older kernels, eg 2.6.32 (as used in Ubuntu 10.04 Lucid) used the patched driver, and this allowed toshset to run.

A work-around solution is simply to use the older kernel. Not an ideal situation, of course, but until such time as the patched toshiba_acpi is included in the latest kernel, using the older kernel will enable the use of toshset.

Easiest way to do it is just install kernel 2.6.32-25-generic through Synaptic. Everything still works as normal (at least on my system it does), but most importantly, toshset works with this kernel.

I have been able to set the fan speed and transreflective mode using toshset after patching and building the toshiba_acpi module for the current maverick kernel (2.6.35-22-generic). The acpitool program is also able to set the fan and lcd brightness levels. So the patch seems to enable toshset without affecting the other acpi functionality.

toshiba_acpi patch used: http://schwieters.org/toshset/toshiba_acpi-current.patch

After building the tosbiba_acpi.ko module I just copied it over to the current kernel module lib directory. I'll have to see if there is an official method for substituting a single modified module to a existing kernel build.

Reference System: Toshiba R600, 64bit Maverick Meerkat with patched toshiba_acpi, no 3g modem.

Mark Crompton (cromptonm) wrote :

Mark,
Thanks very much for this - very useful information!

I'm new to this kind of thing, so I'd appreciate it if you could go into a little more detail on what the process is to apply the patch, and to build the toshiba_acpi.ko module?

I'm looking into using Dynamic Kernel Module Support (DKMS) and a launchpad PPA package to enable the patched toshiba_acpi modules are updated along with kernel updates. Otherwise the procedure might need to be repeated for each ubuntu kernel update.

The quick and dirty instructions are below, most of the instructions come from the Ubuntu KernelCustomBuild webpage. I might have missed something, please post any corrections.
1) Get ubuntu kernel source package and kernel building tools packages (I had all these installed, so I don't know what is required)
2) #> cd /usr/src
3) #> sudo wget http://schwieters.org/toshset/toshiba_acpi-current.patch
4) #> sudo tar -jxf linux-source-2.6.35.tar.bz2
5) #> cd linux-source-2.6.35
6) #> sudo patch -p1 < ../toshiba_acpi-current.patch
7) #> cd drivers/platform/x86/
8) I only wanted to build the toshiba_acpi module. So I commented out all the other modules from the Makefile. Using sudo make a backup copy of the Makefile, then edit the Makefile to only build the toshiba_acpi module. Just put # in front
of the other modules.
9) sudo make -C /usr/src/linux-headers-`uname -r` M=`pwd` modules
10) sudo make -C /usr/src/linux-headers-`uname -r` M=`pwd` modules_install
11) sudo depmod -a
12) Driver should be into /lib/modules/*/extra/toshiba_acpi. rmmod and modprobe
to load the new module. Rebooting should work as well.

Primary Reference: https://wiki.ubuntu.com/KernelCustomBuild
Helpful References:
https://help.ubuntu.com/community/Kernel/Compile (lists kernel building packages)
http://wiki.centos.org/HowTos/BuildingKernelModules
http://www.cyberciti.biz/tips/compiling-linux-kernel-module.html
http://www.linuxheadquarters.com/howto/tuning/kernelpatch.shtml

Mark Crompton (cromptonm) wrote :

Fantastic!! Your instructions worked perfectly! :)

Thank you very much for taking the time and effort to put this together.

Just a few suggestions that may help other newbies like me:

For step 1)
get the kernel source package:
 #> sudo apt-get install linux-source-2.6.35
get the kernel building source packages:
 #> sudo apt-get install kernel-package libncurses5-dev fakeroot wget bzip2
(maybe not all these packages are necessary, but I don't think it will harm to install them)

For step 8), to edit the Makefile as root:
 #> sudo gedit Makefile

For step 12)
Copy the file toshiba_acpi.ko to /lib/modules/*/extra (replace * with your current kernel version).
remove the old module:
 #> sudo rmmod toshiba_acpi
and load the new module:
 #> sudo modprobe toshiba_acpi
(or simply reboot)

At last toshset works again :)

Daniel Smith (connect404) wrote :

I've been trying to compile this patch into the 2.6.37rc2 mainline kernel but have run into a few issues. The reason for trying to get it up and running with .37 to resolve the well documented lag/speed issues on Maverick with the .35 kernel.

So I patched the .37 toshiba.acpi with the link above and tried to compile:

dsmith@pez:/usr/src/linux-2.6.37-rc2/drivers/platform/x86$ sudo make -C /usr/src/linux-headers-`uname -r` M=`pwd` modules
make: Entering directory `/usr/src/linux-headers-2.6.37-020637rc2-generic'
  CC [M] /usr/src/linux-2.6.37-rc2/drivers/platform/x86/toshiba_acpi.o
/usr/src/linux-2.6.37-rc2/drivers/platform/x86/toshiba_acpi.c:819: error: unknown field ‘ioctl’ specified in initializer
/usr/src/linux-2.6.37-rc2/drivers/platform/x86/toshiba_acpi.c:820: warning: initialization from incompatible pointer type
make[1]: *** [/usr/src/linux-2.6.37-rc2/drivers/platform/x86/toshiba_acpi.o] Error 1
make: *** [_module_/usr/src/linux-2.6.37-rc2/drivers/platform/x86] Error 2
make: Leaving directory `/usr/src/linux-headers-2.6.37-020637rc2-generic'

Seems that ioctl variable has been removed from 2.6.37rc1. Ioctl was removed by the merging of the BKL (big kernel lock) tree.

So I hacked toshiba_acpi.c a little to get it compiling from:
(line 859)
static int
tosh_ioctl(struct inode* ip, struct file* fp, unsigned int cmd,
 unsigned long arg)

to:
static long
    tosh_ioctl(struct file* fp, unsigned int cmd,
 unsigned long arg)

and also from:
(line 921)
.ioctl = tosh_ioctl
to:
.compat_ioctl = tosh_ioctl

Compiles clean, inserts and loads up but I cant get access to toshet. What is interesting is I can cat /proc/toshiba
dsmith@pez:/usr/src/linux-2.6.37-rc2/drivers/platform/x86$ cat /proc/toshiba
1.1 0xfcff 0.0 0.45 0x418e 0x00

Well I'm no kernel hacker and am not really sure what Im doing past here... any ideas?

Daniel Smith (connect404) wrote :

I can however confirm that merging the patch back into the 2.6.35-22 version works fine.

Daniel Smith (connect404) wrote :
wpoet (wp-sensotech) wrote :

Here is my version for kernel 2.6.35-23-generic
/usr/src/linux-source-2.6.35/drivers/platform/x86/toshiba_acpi.ko

Thomas Orgis (thomas-forum) wrote :

This problem has been diagnosed to death: People dropped the experimental toshiba patch from the kernel, intending to see if this breaks something for anyone. People noticed that toshset is broken on their machines. People notice that it is trivial to apply the patch (excep the needed change for .37 kernels).

Would people please just consider putting the patch back in for 10.04 / 10.10?

wpoet (wp-sensotech) wrote :

Yes, Thomas, I fully agree. Does anyone have an idea where else to complain. This has been going on for half a year. It is painful enough if something does not work. But is a working solution is dropped, I really lack any understanding. No wonder, my wife thinks I am stupid to use Linux. In Windows everything's so easy, at least as far as hardware support is concerned.

Mark Crompton (cromptonm) wrote :

In response to the decision to drop the patch, mentioned in the following post:

https://lists.ubuntu.com/archives/kernel-team/2010-June/011112.html

I sent a message to kernel-team, pointing out that the resulting bug has definitely been noticed, and requested that the patch be put back in. This is the reply I received:

(Quote)

On Fri, Nov 26, 2010 at 06:33:29PM +0800, Mark Crompton wrote:

> > Please re-instate this patch.
Please don't. This functionality needs to be merged into the driver, not
punted out in a way that lets userspace trigger arbitrary SMIs.

-- Matthew Garrett | (e-mail address removed)

(End quote)

So the kernel team have passed responsibility for this bug to the driver.

Where to now?

Mike Doherty (doherty) wrote :

Upstream kernel, I imagine.

Nikita Tsukanov (keks9n) wrote :

>>
The ioctl ops in struct file_operations is deprecated on 2.6.36.
You need to convert it to unlocked_ioctl ops.

If you are lucky, just changing the second argument (struct file*) and
the return type of the old ioctl function from int to long might make
things working (supposing no BKL is needed).

(http://web.archiveorange.com/archive/v/u1yF7zbcV1zFXbC3gf6U)

Will try to patch it.

Nikita Tsukanov (keks9n) wrote :

Used kind of black magic and got it working.

tags: added: patch
Mark Crompton (cromptonm) wrote :

Thank you keks-n for the patch for kernel 2.6.37

I can confirm it works

Solnyshok (solnyshok) wrote :

is that good for 2.6.37rc2-maverick or 2.6.37-natty?

Mark Crompton (cromptonm) wrote :

I used 2.6.37rc2-maverick.

Nikita Tsukanov (keks9n) wrote :

I've patched the kernel from natty repo and got it working. Anyway all kernels since 2.6.33 randomly freeze my system, so I still use 2.6.32.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Mike.lifeguard,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 644898

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marc 1837 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xffd3c000 irq 45'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,11790463,00102201 HDA:11c13026,11790001,00100700'
   Controls : 8
   Simple ctrls : 6
DistroRelease: Ubuntu 11.04
HibernationDevice: RESUME=UUID=aac17870-eb6f-4cc8-843c-c7fafa0a736d
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: TOSHIBA PORTEGE M400
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=ca1a2fef-9e27-4105-8003-2b3146127193 ro splash vga=795 crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Regression: No
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-7-generic N/A
 linux-backports-modules-2.6.38-7-generic N/A
 linux-firmware 1.49
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: natty kernel-uncat needs-upstream-testing
Uname: Linux 2.6.38-7-generic x86_64
UpgradeStatus: Upgraded to natty on 2011-03-26 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/22/2008
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 3.80
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion3.80:bd05/22/2008:svnTOSHIBA:pnPORTEGEM400:pvrPPM40C-TD30TE:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: PORTEGE M400
dmi.product.version: PPM40C-TD30TE
dmi.sys.vendor: TOSHIBA

tags: added: apport-collected kernel-uncat natty

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: maverick
removed: needs-kernel-logs
Gary M (garym) on 2011-05-01
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: regression-release
43 comments hidden view all 123 comments
Nikita Tsukanov (keks9n) wrote :

Now you can find toshiba-acpi-fix in ppa:keks9n/main

pascal (pascal-pascallen) wrote :

@keks-n

Thank you very much. Used it and works like a charm. Including the 3-g modem on portege R-500.

Alex (agemmell) wrote :

@keks-n

Thank you! Your autobuilder works! I've added your ppa and I can see there is an update (from 0.0.2, which I have, to 0.0.3) however I can't seem to install the update. The update manager gives me this error:

Requires installation of untrusted packages
The action would require the installation of packages from unauthenticated sources.
Details: toshiba-acpi-fix

How do I get the update?!

Thanks!

Nikita Tsukanov (keks9n) wrote :

Alex, you've added ppa in a wrong way (at least no key file was imported).

Try:

$ sudo apt-add-repository ppa:keks9n/main
$ sudo apt-get update

Alex (agemmell) wrote :

Sweeeeeeeeet! It all works again now. Thank you SO much keks-n. You've been very patient and I truly appreciate it!

That didnt work with kernel 2.6.38-10-generic-pae

after apt-get upgrade .. I get this:

.....
Building toshiba_acpi for 2.6.38-10-generic-pae
make -C /lib/modules/2.6.38-10-generic-pae/build M=/tmp/tmp.tLYjGDVRR1 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.38-10-generic-pae'
  CC [M] /tmp/tmp.tLYjGDVRR1/toshiba_acpi.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC /tmp/tmp.tLYjGDVRR1/toshiba_acpi.mod.o
  LD [M] /tmp/tmp.tLYjGDVRR1/toshiba_acpi.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-10-generic-pae'
cp toshiba_acpi.ko /lib/modules/2.6.38-10-generic-pae/kernel/drivers/platform/x86/toshiba_acpi.ko
update-initramfs -c -k 2.6.38-10-generic-pae
update-initramfs: Generating /boot/initrd.img-2.6.38-10-generic-pae
...
Reloading the module
ERROR: Module toshiba_acpi does not exist in /proc/modules
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.38-10-generic-pae/kernel/drivers/platform/x86/toshiba_acpi.ko): No such device
dpkg: error processing toshiba-acpi-fix (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 toshiba-acpi-fix
E: Sub-process /usr/bin/dpkg returned an error code (1)

Nikita Tsukanov (keks9n) wrote :

Does it work with other kernels? Does toshset work with 2.6.32?

Cannot boot to X with 2.6.32-26-generic-pae .. get stuck on terminal during booting.

I using Ubuntu 11.04 distribution.

With 2.6.38-10-generic-pae I can using fn+Esc combination, which is stand for mute/unmute, and fn+F6, fn+F7 brightens, but cannot fn+F3, fn+F4, fn+F5 ..

Nikita Tsukanov (keks9n) wrote :

Are you sure, that you need _this_ fix? It fixes only the problem with toshset. I think it's better to create a new bug report and describe your problem in it, because it looks like that your laptop uses another acpi model which isn't handled by toshiba_acpi kernel module.

Kamarada (kamarada) wrote :
Download full text (4.0 KiB)

Error on Toshiba L300D and Ubuntu 11.04 32b
any solution?

Selecting previously deselected package toshiba-acpi-fix.
(Reading database ... 214463 files and directories currently installed.)
Unpacking toshiba-acpi-fix (from .../toshiba-acpi-fix_0.0.3_all.deb) ...
Setting up toshiba-acpi-fix (0.0.3) ...
Building toshiba_acpi for installed kernels
Building toshiba_acpi for 2.6.38-8-generic
make -C /lib/modules/2.6.38-8-generic/build M=/tmp/tmp.BjYlRViA6Y modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.38-8-generic'
  CC [M] /tmp/tmp.BjYlRViA6Y/toshiba_acpi.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC /tmp/tmp.BjYlRViA6Y/toshiba_acpi.mod.o
  LD [M] /tmp/tmp.BjYlRViA6Y/toshiba_acpi.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
cp toshiba_acpi.ko /lib/modules/2.6.38-8-generic/kernel/drivers/platform/x86/toshiba_acpi.ko
update-initramfs -c -k 2.6.38-8-generic
update-initramfs: Generating /boot/initrd.img-2.6.38-8-generic
Building toshiba_acpi for 2.6.39-0-generic
make -C /lib/modules/2.6.39-0-generic/build M=/tmp/tmp.CjN1kDW4A8 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.39-0-generic'
  CC [M] /tmp/tmp.CjN1kDW4A8/toshiba_acpi.o
/tmp/tmp.CjN1kDW4A8/toshiba_acpi.c:72:28: fatal error: linux/smp_lock.h: No such file or directory
compilation terminated.
make[2]: *** [/tmp/tmp.CjN1kDW4A8/toshiba_acpi.o] Error 1
make[1]: *** [_module_/tmp/tmp.CjN1kDW4A8] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.39-0-generic'
make: *** [all] Error 2
cp toshiba_acpi.ko /lib/modules/2.6.39-0-generic/kernel/drivers/platform/x86/toshiba_acpi.ko
cp: cannot stat `toshiba_acpi.ko': No such file or directory
make: *** [install] Error 1
Reloading the module
ERROR: Module toshiba_acpi does not exist in /proc/modules
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.39-0-generic/kernel/drivers/platform/x86/toshiba_acpi.ko): No such device
dpkg: error processing toshiba-acpi-fix (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 toshiba-acpi-fix
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up toshiba-acpi-fix (0.0.3) ...
Building toshiba_acpi for installed kernels
Building toshiba_acpi for 2.6.38-8-generic
make -C /lib/modules/2.6.38-8-generic/build M=/tmp/tmp.bygDKyRovd modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.38-8-generic'
  CC [M] /tmp/tmp.bygDKyRovd/toshiba_acpi.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC /tmp/tmp.bygDKyRovd/toshiba_acpi.mod.o
  LD [M] /tmp/tmp.bygDKyRovd/toshiba_acpi.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
cp toshiba_acpi.ko /lib/modules/2.6.38-8-generic/kernel/drivers/platform/x86/toshiba_acpi.ko
update-initramfs -c -k 2.6.38-8-generic
update-initramfs: Generating /boot/initrd.img-2.6.38-8-generic
Building toshiba_acpi for 2.6.39-0-generic
make -C /lib/modules/2.6.39-0-generic/build M=/tmp/tmp.866fxtlPEC modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.39-0-generic'
  CC [M] /tmp/tmp.866fxtlPEC/toshiba_acpi.o
/tmp/tmp.866...

Read more...

Mark Crompton (cromptonm) wrote :

I am testing Ubuntu 11.10 "Oneiric" beta. (So far so good). I would like to test the patch for Toshset. We need an update to toshiba-acpi-fix kindly provided by keks-n in his ppa, for Oneiric. Is that possible please?

Nikita Tsukanov (keks9n) wrote :

They finally removed BKL in 2.6.39 version of the kernel. I've replaced calls to lock/unlock_kernel by a mutex and now it seems to compile and work fine with 2.6.39 and 3.0.0. I've uploaded it to ppa, so new version should be available soon for oneiric. I keep the old version for natty because it seems to be stable with this version of Ubuntu.

Mark Crompton (cromptonm) wrote :

@keks-n

Thanks very much for the updated package.

I can confirm it works with Ubuntu 11.10 Oneiric (beta) and kernel 3.0.0-11-generic

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in toshset (Ubuntu):
status: New → Confirmed
Logan Perkins (perkins-9) wrote :

I just tested the toshiba-acpi-fix package running under debian testing/linux mint with kernel 3.0.0, and it works great. Thanks for the fixed package.

zik (zikzik) wrote :

toshiba-acpi-fix crashes for me on Ubuntu 11.10 Oneiric and kernel 3.1:

BUG: unable to handle kernel paging request at ffff8800dfd89f94
Pid 3269, comm: grep Tainted: G D 3.1.0-030100-generic #201110241006 TOSHIBA PORTEGE M800/PORTEGE M800
Call trace: m_show, seq_read seq_lseek proc_reg_read vfs_read sys_read system_call_fastpath

happy to do some testing.

Nikita Tsukanov (keks9n) wrote :

I cann't reproduce it on my laptop since my system doesn't boot even to login promt with 3.1 kernel from Ubuntu repo. Both with and without the patch applied to the module.

Roberto Grassi (robegrassi) wrote :

It compiles and works in Arch Linux with kernel 3.1.4 and on a Toshiba Satellite R830. Thanks a lot!

Metin Akın (aknmetin) on 2012-02-07
Changed in toshset (Ubuntu):
status: Confirmed → Opinion
status: Opinion → Confirmed
Eduard Gotwig (gotwig) wrote :

still not fixed in ubuntu 12.04

Brad Figg (brad-figg) wrote :

I'm just coming into this discussion so please be kind. It seems from what I've seen that the upstream developers think that this issue should be fixed in the current kernel (possibly earlier but let's ignore that for now). It looks from comment #103 that the problem still exists in the current (Precise) kernel.

Has anyone from this thread / bug tried to engage with the upstream developer(s) to let them know this issue still exists?

Quinn (weazelon) wrote :

@keks9n

I've been banging my head over this thing for the past 3 years I've tried compiling from a few suggested step by step guides, and I'm a total noob on everything linux. So, finally came back to this thread to see #84 and omg it worked like a charm !!
I can finally use my 3g modem on my Toshiba Tecra R10-10W - Toshset now works perfectly

For all the noobs that has no linux skills like me, I did:

1. sudo apt-add-repository ppa:keks9n/main
2. sudo apt-get update
3. sudo apt-get install toshiba-acpi-fix
4. sudo toshset -3g on

I can confirm it works with Ubuntu 11.04 natty and kernel 2.6.38-13-generic ! hurray !

Agustin Lobo (aloboaleu) wrote :

Hi!
using a toshiba Portege M400 with ubuntu 11.10, after installing toshiba-acpi-fix and rebooting,
with a second monitor as extended desktop,
I can still not increase the brightness of the lcd display, which is very low.
Also:
alobo@alobo-laptop:~$ sudo toshset -lcd 2
SciFeature:action: error setting lcd brightness
 SciSet returned: FAILURE
lcd brightness: super-bright

lcd does not change
alobo@alobo-laptop:~$ sudo toshset -inten 7
lcd intensity: 7/7

lcd does not change

If I run (as I used with ubuntu 10.04)
sudo toshset -video both

the displays get crazy

Any fix?

Thanks

Agus

Agustin Lobo (aloboaleu) wrote :

Actually I get:
alobo@alobo-laptop:~$ sudo toshset -video both
[sudo] password for alobo:
HciFeature::query: received an unexpected response for feature Video out: 387

alobo@alobo-laptop:~$

Agus

Chris Glass (tribaal) wrote :

This is still a problem on Precise.

@keks9n - Would you provide a PPA for precise? That would be really appreciated, worked a treat on Oneiric.

Solnyshok (solnyshok) wrote :

@keks9n

I see here http://launchpad.net/~keks9n/+archive/main/+packages
toshiba-acpi-fix published on 4-24-2012, but description still says Oneiric. Is that true?

Daniel Barker (phuebu) wrote :
Download full text (5.0 KiB)

I just tried the steps in post #105 and got the following output

sudo apt-get install toshiba-acpi-fix
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  language-pack-kde-zh-hans-base
  firefox-locale-zh-hans language-pack-kde-en
  kde-l10n-engb language-pack-zh-hans-base
  kde-l10n-zhcn language-pack-zh-hans
  language-pack-kde-zh-hans language-pack-kde-en-base
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  build-essential dpkg-dev libalgorithm-diff-perl
  libalgorithm-diff-xs-perl libalgorithm-merge-perl
  libdpkg-perl
Suggested packages:
  debian-keyring
The following NEW packages will be installed
  build-essential dpkg-dev libalgorithm-diff-perl
  libalgorithm-diff-xs-perl libalgorithm-merge-perl
  libdpkg-perl toshiba-acpi-fix
0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Need to get 741 kB of archives.
After this operation, 2,955 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://gb.archive.ubuntu.com/ubuntu/ precise/main libdpkg-perl all 1.16.1.2ubuntu7 [181 kB]
Get:2 http://ppa.launchpad.net/keks9n/main/ubuntu/ precise/main toshiba-acpi-fix all 0.0.4 [10.5 kB]
Get:3 http://gb.archive.ubuntu.com/ubuntu/ precise/main dpkg-dev all 1.16.1.2ubuntu7 [468 kB]
Get:4 http://gb.archive.ubuntu.com/ubuntu/ precise/main build-essential amd64 11.5ubuntu2 [5,978 B]
Get:5 http://gb.archive.ubuntu.com/ubuntu/ precise/main libalgorithm-diff-perl all 1.19.02-2 [50.7 kB]
Get:6 http://gb.archive.ubuntu.com/ubuntu/ precise/main libalgorithm-diff-xs-perl amd64 0.04-2build2 [12.4 kB]
Get:7 http://gb.archive.ubuntu.com/ubuntu/ precise/main libalgorithm-merge-perl all 0.08-2 [12.7 kB]
Fetched 741 kB in 0s (869 kB/s)
Selecting previously unselected package libdpkg-perl.
(Reading database ... 219113 files and directories currently installed.)
Unpacking libdpkg-perl (from .../libdpkg-perl_1.16.1.2ubuntu7_all.deb) ...
Selecting previously unselected package dpkg-dev.
Unpacking dpkg-dev (from .../dpkg-dev_1.16.1.2ubuntu7_all.deb) ...
Selecting previously unselected package build-essential.
Unpacking build-essential (from .../build-essential_11.5ubuntu2_amd64.deb) ...
Selecting previously unselected package libalgorithm-diff-perl.
Unpacking libalgorithm-diff-perl (from .../libalgorithm-diff-perl_1.19.02-2_all.deb) ...
Selecting previously unselected package libalgorithm-diff-xs-perl.
Unpacking libalgorithm-diff-xs-perl (from .../libalgorithm-diff-xs-perl_0.04-2build2_amd64.deb) ...
Selecting previously unselected package libalgorithm-merge-perl.
Unpacking libalgorithm-merge-perl (from .../libalgorithm-merge-perl_0.08-2_all.deb) ...
Selecting previously unselected package toshiba-acpi-fix.
Unpacking toshiba-acpi-fix (from .../toshiba-acpi-fix_0.0.4_all.deb) ...
Processing triggers for man-db ...
Setting up libdpkg-perl (1.16.1.2ubuntu7) ...
Setting up dpkg-dev (1.16.1.2ubuntu7) ...
Setting up build-essential (11.5ubuntu2) ...
Setting up libalgorithm-diff-perl (1.19.02-2) ...
Setting up libalgorithm-diff-xs-perl (0.04-2build2) ....

Read more...

Nikita Tsukanov (keks9n) wrote :

Have you tried it with older kernel (from oneiric or natty)?

Kai Deponte (kai-deponte) wrote :

THANKS Nikita!
couldn't use my Sony Ericsson F3507g on a Toshiba Tecra A10 with 12.04-64 Kernel 3.2.0
now working perfectly!

This issue is still present on my Toshiba Qosmio F60 with Ubuntu 12.10. I need to enable wireless from within Windows 7. Fn+F8 just enables/disables the wireless using soft block under Ubuntu, while the LED light stays on. Wireless still needs to be enabled from within Windows for the soft block to work.

Out put of lsusb:
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 043: ID 0930:0508 Toshiba Corp. Integrated Bluetooth HCI
Bus 001 Device 006: ID 04f2:b130 Chicony Electronics Co., Ltd

Output of lspci -n:
00:00.0 0600: 8086:0044 (rev 12)
00:02.0 0300: 8086:0046 (rev 12)
00:16.0 0780: 8086:3b64 (rev 06)
00:1a.0 0c03: 8086:3b3c (rev 06)
00:1b.0 0403: 8086:3b56 (rev 06)
00:1c.0 0604: 8086:3b42 (rev 06)
00:1c.1 0604: 8086:3b44 (rev 06)
00:1c.2 0604: 8086:3b46 (rev 06)
00:1c.3 0604: 8086:3b48 (rev 06)
00:1c.5 0604: 8086:3b4c (rev 06)
00:1d.0 0c03: 8086:3b34 (rev 06)
00:1e.0 0604: 8086:2448 (rev a6)
00:1f.0 0601: 8086:3b09 (rev 06)
00:1f.2 0106: 8086:3b29 (rev 06)
00:1f.6 1180: 8086:3b32 (rev 06)
01:00.0 0805: 1180:e822 (rev 01)
01:00.1 0880: 1180:e230 (rev 01)
02:00.0 0280: 10ec:8172 (rev 10)
03:00.0 0480: 102f:01ba (rev 01)
05:00.0 0200: 10ec:8168 (rev 03)
ff:00.0 0600: 8086:2c62 (rev 02)
ff:00.1 0600: 8086:2d01 (rev 02)
ff:02.0 0600: 8086:2d10 (rev 02)
ff:02.1 0600: 8086:2d11 (rev 02)
ff:02.2 0600: 8086:2d12 (rev 02)
ff:02.3 0600: 8086:2d13 (rev 02)

It would be great if anybody could find a solution to this so that I will not need to dual boot.

tygern8r (tygern8r) wrote :

Mine fails regardless of which kernel I use. I've gone all the way back to 2.6.38.8 and up including the most current 3.8 and I think it doesn't have anything to do with the kernel or Nikitas patch as other users have posted their success with most of the kernels I tried. I think the problem is the machine. My Toshiba Satellite L355D-S7809 has InsydeH2O BIOS v1.9, the last update I can find for my model. This webpage http://memebeam.org/toys/ToshibaAcpiDriver specifies this failure error and says that it is due to non-Toshiba BIOS. I am also unable to get Omnibook patch to work either, which is supposed to work on Phoenix BIOS on the Toshibas.

Reloading the module
FATAL: Error inserting toshiba_acpi (/lib/modules/3.2.0-38-generic/kernel/drivers/platform/x86/toshiba_acpi.ko): No such device
dpkg: error processing toshiba-acpi-fix (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libstdc++6-4.6-dev (4.6.3-1ubuntu5) ...
Errors were encountered while processing:
 toshiba-acpi-fix
E: Sub-process /usr/bin/dpkg returned an error code (1)

If someone has gotten this to work with the InsydeH2O BIOS I'd like to hear from you. Otherwise I'm afraid I've done all the troubleshooting I can do, and will either have to live with my fan running at full speed once the initial threshold is crossed, or I'm going to have to put Windows back on.

Mark Crompton (cromptonm) wrote :

@keks9n

Could you please update your PPA for raring? I still need the patch for my Toshiba Portege.
Many thanks :-)

Mark Crompton (cromptonm) wrote :

@keks9n

Thanks very much for the update. Still works like a charm :-)

Jalil Karimov (jukarimov) wrote :

Nops, not working :(

I downloaded kernel (2.6.35) from https://www.kernel.org/pub/linux/kernel/v2.6/
and tried to apply patch, but it rejected :(
however succeeded on 3-rd kernel 3.3.7 but running toshset with new module give oopses, and say unsupported toshiba bios :'(

I've just attempted to use the 'raring' version of the toshiba-acpi-fix package from https://launchpad.net/~keks9n/+archive/main

I was impressed to find that against one of the kernels in my Ubuntu Gnome Saucy (13.10) the kernel 3.9.0-7 the patched toshiba_acpi does indeed build and function, and although the hardware button doesn't work, I can turn on transflective mode from the command line with...
sudo toshset -trmode on
and back off with...
sudo toshset -trmode off

Sadly, with either of the 3.11 kernels (also installed) the build fails, and below is a typical error from the build process...

Building toshiba_acpi for 3.11.0-2-generic
make -C /lib/modules/3.11.0-2-generic/build M=/tmp/tmp.jtXi5Oxy3w modules
make[1]: Entering directory `/usr/src/linux-headers-3.11.0-2-generic'
  CC [M] /tmp/tmp.jtXi5Oxy3w/toshiba_acpi.o
/tmp/tmp.jtXi5Oxy3w/toshiba_acpi.c: In function ‘version_proc_open’:
/tmp/tmp.jtXi5Oxy3w/toshiba_acpi.c:827:2: error: implicit declaration of function ‘PDE’ [-Werror=implicit-function-declaration]
  return single_open(file, version_proc_show, PDE(inode)->data);
  ^
/tmp/tmp.jtXi5Oxy3w/toshiba_acpi.c:827:56: error: invalid type argument of ‘->’ (have ‘int’)
  return single_open(file, version_proc_show, PDE(inode)->data);
                                                        ^
/tmp/tmp.jtXi5Oxy3w/toshiba_acpi.c:828:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
cc1: some warnings being treated as errors
make[2]: *** [/tmp/tmp.jtXi5Oxy3w/toshiba_acpi.o] Error 1
make[1]: *** [_module_/tmp/tmp.jtXi5Oxy3w] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.11.0-2-generic'
make: *** [all] Error 2
cp toshiba_acpi.ko /lib/modules/3.11.0-2-generic/kernel/drivers/platform/x86/toshiba_acpi.ko
cp: cannot stat ‘toshiba_acpi.ko’: No such file or directory
make: *** [install] Error 1

Roberto Grassi (robegrassi) wrote :

For kernel>=3.10: replace PDE()->data with PDE_DATA()

I can't seem to find a way to enable Wireless on my Toshiba Qosmio F60 from Ubuntu (even 13.04) once it is disabled from within Windows. The LED buttons to enable Wireless, Mute, Play/Pause, Eco Mode, Touchpad block/unblock don't work either. It does not even generate any X Event. :-(

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-keyboard-lts-raring/+bug/1179383

http://askubuntu.com/questions/291783/led-touch-buttons-touchpad-toggle-not-working-in-toshiba-qosmio-f60

Under Windows the LED is used to switch on both WiFi, Bluetooth after which Fn+F8 is used to toggle between All Off, All On, Only Wifi, Only Bluetooth.

Alejandro Salas (kriegerd) wrote :

@Roberto Grassi,

I'm sorry if this is a newbie question. I searched the file and what I found was: PDE(inode)->data, do you mean to just replace that with PDE_DATA(inode)->data??

That's what I did and I'm still getting error
/tmp/tmp.qvjlE83cZN/toshiba_acpi.c: In function ‘version_proc_open’:
/tmp/tmp.qvjlE83cZN/toshiba_acpi.c:827:61: warning: dereferencing ‘void *’ pointer [enabled by default]
/tmp/tmp.qvjlE83cZN/toshiba_acpi.c:827:61: error: request for member ‘data’ in something not a structure or union
/tmp/tmp.qvjlE83cZN/toshiba_acpi.c:828:1: warning: control reaches end of non-void function [-Wreturn-type]

Thank you in advance.

Roberto Grassi (robegrassi) wrote :

@Alejandro Salas

No, just replace with: PDE_DATA(inode)

Alejandro Salas (kriegerd) wrote :

Thanks @Roberto Grassi!, that did the trick.
I still haven't figured out how to enable the volume wheel that comes with my laptop, but that's another issue.
I got it to work in a 3.10-2-686-pae Debian.

Displaying first 40 and last 40 comments. View all 123 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.