toshset required kernel toshiba support not enabled.

Bug #181374 reported by Mattias Örtenblad on 2008-01-08
112
This bug affects 20 people
Affects Status Importance Assigned to Milestone
toshset (Debian)
New
Undecided
Unassigned
toshset (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Abdusamed Ahmed
Nominated for Maverick by Abdusamed Ahmed

Bug Description

Binary package hint: toshset

I run Hardy Heron alpha 3 on a Toshiba portege m100.

Toshset doesn't seem to work, I get the following error msg:
"required kernel toshiba support not enabled."
when trying to run toshset. The biggest problem here is that my screen
brightness is set to lower than normal and I can't change it without this program.

toshset has worked flawlessly since Dapper. I upgraded from Gutsy to Heron.

Torsten Spindler (tspindler) wrote :

Load the toshiba_acpi and toshiba kernel modules manually and toshset should work. Please note that not all functionality is working right now.

Feanor (angelo-pantano) wrote :

same issue here, i can't load modules manually.

feanor@eldar:~$ sudo modprobe toshiba_acpi
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.24-15-generic/kernel/drivers/acpi/toshiba_acpi.ko): No such device

feanor@eldar:~$ sudo modprobe toshiba
FATAL: Error inserting toshiba (/lib/modules/2.6.24-15-generic/kernel/drivers/char/toshiba.ko): No such device

any clues?

insmod fails as well

farkewie (tyrongower) on 2008-04-19
Changed in toshset:
status: New → Confirmed
JM Barbier (jm-barbier) wrote :

Same problem here on a Satellite A210-BH... no brightness modification.

jmbarbier@portjm:~$ sudo modprobe toshiba
FATAL: Error inserting toshiba (/lib/modules/2.6.24-16-generic/kernel/drivers/char/toshiba.ko): No such device

i remember (but not 100% sure) that it was working a month ago (was 2.6.24-12, i think...)

thank you

jyio (inportb) wrote :

indeed, i think hardy is confused and thinks that this machine is not a toshiba. this may be why the brightness controls don't work anymore -- the hotkeys work and the brightness scripts are called, but the effects are strange.

Justin Waters (justin-waters) wrote :

I was experiencing the same problem on a Toshiba A105-S4084 with Phoenix BIOS when running Ubuntu Hardy. I updated the BIOS from 1.70 to 6.00, and my FN keys work, as does the screen brightness.

http://www.csd.toshiba.com/cgi-bin/tais/su/su_sc_modItemList.jsp?moid=1373530&rpn=PSAA8U&ct=DL&BV_SessionID=@@@@0643615367.1209421677@@@@&BV_EngineID=cccjadedmelledicgfkceghdgngdgnj.0

Function Keys that Worked right off the bat:
Mute, Suspend, Hibernate, Brightness Down, Brightness Up, Function Key Lock, Numpad Lock, Scroll Lock, Web Browser, Play/Pause, Stop, Previous Track, Next Track

I'm still getting "No Such Device" errors when I try to install the modules, however. My screen brightness control works again, so I'm not really worried about that.

JM Barbier (jm-barbier) wrote :

On my Kubuntu Satellite A210-BH, the Fn+F6 or Fn+F7 keys for brightness shows the brightness level, and i can change the value, but nothing is really done on brightness (brightness stays at maximum level). But brightness setting is possible, using directly /proc/acpi/video/VGA/LCD/brightness ...

Rik.v.a. (rik) wrote :

I can't enable Bluetooth because of this on a Toshiba Satellite Pro U400 (U400-10D); see http://rik.rikva.nl/cms/index.php?itemid=5 .

Confirm this problem with Toshiba A200-1ZB. I bluetooth does not work and tries to load above mentioned modules result in the same errors.

Tim Richardson (tim-richardson) wrote :

I have bluetooth working on my Toshiba Satellite Pro U400.
Please see my post (Tim Richardson) at
http://iorek.rikva.nl/cms/index.php?itemid=5

or in case something happens to it, here is a copy:
(but you will learn things by following the link)

To follow up on getting bluetooth to work on Ubuntu Hardy, I did this:

1) visit this site, and add the Debian sid repository
http://packages.kirya.net/
it is not necessary to add the source repository.

1a) refresh synaptic, and add the package
omnibook-source

2) use module-assistant to build the kernel module (but first, exit synaptic)
sudo m-a a-i omnibook-source
(you have to work out how to get module-assistant working yourself. It is a package; you can find it in Synaptic. Make sure you install all recommended dependencies. Try installing build-essential as well)

3) we need to make sure the module loads at startup
so edit the file /etc/modules
sudo vi /etc/modules
and add the line
omnibook
at the end

4) and we need to get it working so make a file called omnibook in /etc/modprobe.d
and in this file put one line
omnibook ectype=14

5) you don't need to reboot. You can do this
sudo modprobe omnibook ectype=14

by doing this, the bluetooth icon appears.
I just synced my phone. It works very wel.

Andrew Ivanov (aa.ivanov) wrote :

I am running Hardy Toshiba Satellite A110-195 laptop (lshw details bellow) and I'm trying to get more aggressive fan settings in an effort to resolve some heat issues.

I have tried using toshset, toshutil, fnfxd - they all complained about missing kernel support / kernel modules.

I tried loading the toshiba_acpi and toshiba modules manualy (as stated by Torsten Spindler in comment 2) and the command failed with:
root@rev2:~# modprobe toshiba
FATAL: Error inserting toshiba (/lib/modules/2.6.24-19-generic/kernel/drivers/char/toshiba.ko): No such device

Along with that I've found the following line in /var/log/messages and /var/log/kernel.log:
Jul 26 13:51:47 rev2 kernel: [ 1901.798939] toshiba: not a supported Toshiba laptop

Here are my details (if needed):

andrew@rev2:~$ lsb_release -rdc
Description: Ubuntu 8.04.1
Release: 8.04
Codename: hardy

root@rev2:~# lshw | head
    description: Notebook
    product: Satellite A110
    vendor: TOSHIBA
    version: PSAB0E-00F00XG3
    serial: Y6189915K
    width: 32 bits
    capabilities: smbios-2.4 dmi-2.4 smp-1.4 smp
    configuration: boot=oem-specific chassis=notebook cpus=2 uuid=9BECC3E1-757A-11DB-807B-0016D48A4489

Many "toshiba" laptops are not supported by the "toshiba" features in
the Linux kernel. The omnibook module may help. For my Satellite, I
needed the omnibook module to get the built-in bluetooth working.
The Debian packages work with Ubuntu 8.04

This is the page I made about my Toshiba configuration:
http://docs.google.com/Doc?id=dgd53r6d_36hqmmh4hn&hl=en

I only use omnibook for the bluetooth module. The kernel correctly looks
after everything else on my notebook, except for some LCD backlight
niggles. So I don't know if you will find the omnibook module much use
in your case.

On Sat, 2008-07-26 at 11:32 +0000, Andrew Ivanov wrote:
> I am running Hardy Toshiba Satellite A110-195 laptop (lshw details
> bellow) and I'm trying to get more aggressive fan settings in an effort
> to resolve some heat issues.
>
> I have tried using toshset, toshutil, fnfxd - they all complained about
> missing kernel support / kernel modules.
>
> I tried loading the toshiba_acpi and toshiba modules manualy (as stated by Torsten Spindler in comment 2) and the command failed with:
> root@rev2:~# modprobe toshiba
> FATAL: Error inserting toshiba (/lib/modules/2.6.24-19-generic/kernel/drivers/char/toshiba.ko): No such device
>
> Along with that I've found the following line in /var/log/messages and /var/log/kernel.log:
> Jul 26 13:51:47 rev2 kernel: [ 1901.798939] toshiba: not a supported Toshiba laptop
>
> Here are my details (if needed):
>
> andrew@rev2:~$ lsb_release -rdc
> Description: Ubuntu 8.04.1
> Release: 8.04
> Codename: hardy
>
> root@rev2:~# lshw | head
> description: Notebook
> product: Satellite A110
> vendor: TOSHIBA
> version: PSAB0E-00F00XG3
> serial: Y6189915K
> width: 32 bits
> capabilities: smbios-2.4 dmi-2.4 smp-1.4 smp
> configuration: boot=oem-specific chassis=notebook cpus=2 uuid=9BECC3E1-757A-11DB-807B-0016D48A4489
>

gasparov (luca.gasperini) wrote :

Another important note: This driver does not work on all Toshiba laptops, particularly those models which seem to have a BIOS or other firmware which was not developed by Toshiba itself. New reverse engineering work will have to be done on these machines, or Toshiba will have to disclose the necessary details. (For support of machines with Phoenx BIOS, try the [Omnibook driver].) The error you will see in this case is:

    $ modprobe toshiba_acpi
    FATAL: Error inserting toshiba_acpi
    (.../kernel/drivers/acpi/toshiba_acpi.ko): No such device

Pasted from: http://memebeam.org/toys/ToshibaAcpiDriver

So press F2 or similar when you see the Toshiba logo on laptop boot, if the bios says Phoenix its not a bug , if the bios says Toshiba its a bug.

Kenny McHenry (kennymc0) wrote :

I have a Toshiba M45 that has the toshiba bios which i have updated to the newest version that toshiba offers for my model of laptop (1.20). Even with this I'm having the same problem as everyone has been having; screen brightness, Fn keys etc. and I even get the fatal error when trying to add the toshiba and toshiba_acpi modules to the kernel. Also I get the error saying that the required kernel support for toshset and other toshiba apps. I've tried out Omnibook and it kinda works so I might try that again.

António Lima (amrlima) wrote :

Same problem here running Hardy. Only bluetooth doesn't work.

 sudo modprobe toshiba_acpi
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.24-21-generic/kernel/drivers/acpi/toshiba_acpi.ko): No such device

Brightness works well.

This is a toshiba satellite A300.

Ulf Adams (ulf-ofahrt) wrote :

In 8.10, toshset (still?) does not work. Apparently (grep -i tosh /boot/config-2.6.27-7-generic), the kernel toshiba support is not enabled, so no toshiba or toshiba_acpi modules are there.

Running 8.10 on a Toshiba Portege R500 here.

Also, the package info for toshset is wrong. It says:

 Toshset ia a command-line tool to allow access to much of the
 Toshiba laptop hardware interface developed by Jonathan Buzzard. It can do
 things like set the hard drive spin-down time, turn off the display
 and set the fan speed without the help of the kernel.
 The difference to toshutils is, that it does not need X or kernel-support.

It says that toshset does not need kernel-support, but it gives an error message when run without kernel support. (Or maybe the package description is correct, and something else is broken. But something is broken in either case.)

I've managed to get toshiba_acpi and toshset running on 8.10 - see my post in the forum:
http://ubuntuforums.org/showthread.php?p=6203606#post6203606
Also discussion on bug 269831 - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/269831

bill.wang (wb1023) on 2009-10-27
Changed in toshset (Ubuntu):
status: Confirmed → Fix Committed
pixel_juice (benjarvis) wrote :

I see a fix has been committed, will this eventually show up in Karmic or do I have to wait until Lucid? I have a Toshiba m45-s2692 (with Toshiba ACPI BIOS 1.20) and REALLY need this to work. My fan never goes faster than low speed!

Angel Guzman Maeso (shakaran) wrote :

On Lucid yet it dont released:
$ toshset -b on
required kernel toshiba support not enabled.

skunk (tiobra666) wrote :

I have the same problem on a toshiba satellite pro l300d-217 : is there a way to fix it?? I don't have hotkeys,my fan is always low mode even if the laptop is hot I really need to activate at least the fan!

Mark W (jedimark64) wrote :

Same problem here, Toshiba A200-psaf6a. Toshiba kernel modules not built.

Karmic, 2.6.31-16-generic x86_64,
toshset 1.75-1

Bluetooth, hotkeys don't work.. rfid kill switch (fn-f8) doesn't work.
I haven't noticed any fan issues, but I haven't worked this spare notebook all that much under ubuntu..

Ceyx (david-cowan) on 2010-04-10
Changed in toshset (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed

I have the same problem in Fujitsu Mini Ui3520

My system is Ubuntu 9.10

Changed in toshset (Ubuntu):
status: Fix Committed → Fix Released
Ceyx (david-cowan) on 2010-04-30
Changed in toshset (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Changed in toshset (Ubuntu):
status: Fix Released → Invalid

omnibook module is included in Lucid

Changed in toshset (Ubuntu):
status: Invalid → Fix Released
Alexander Skiba (ghostlyrics) wrote :

Maybe I've made a mistake, but I really don't think it is included.

try:
sudo modprobe omnibook ectype= xx

where xx is an number between 10 and 15

Alexander Skiba (ghostlyrics) wrote :

I apologize. It *is* in the kernel now.

mauricebis (mauricebis) wrote :

Lucid: Yes omnibook.ko is there but when I try modprobe, I get: FATAL: Error inserting omnibook (/lib/modules/2.6.32-21-generic/kernel/ubuntu/omnibook/omnibook.ko): Invalid argument? Any ideas?

what are typing exactly in the terminal?

Tommy_CZ (t-kijas) wrote :

I have same problem, Toshiba A210, typing modprobe omnibook, same output as mauricebis.

mauricebis (mauricebis) wrote :

Well, for unknown reasons I tried it today again "sudo modprobe omnibook ectype=15" and it worked! Now, when I want to use toshset, I still get the message "required kernel toshiba support not enabled."

no need to use toshset. Most of the hardware recognized by ubuntu, except bluetooth and hotykeys. You have to try out ectype from 10 to 15.

Abdusamed Ahmed (sir508) wrote :

the ectype doesn't work on lucid in Toshiba Qosmio f50 126! What to do!

Abdusamed Ahmed (sir508) wrote :

I haven't tried any tweaks yet.. bascially.. the kernal doesn't have it right now. Everything works except bluetooth!

Abdusamed Ahmed (sir508) wrote :

Yes, I can confirm the the message one with the FATAL after running this command

 " sudo modprobe option omnibook ectype=15"

The error message
" FATAL: Error inserting option (/lib/modules/2.6.32-24-generic/kernel/drivers/usb/serial/option.ko): Unknown symbol in module, or unknown parameter (see dmesg)"

Abdusamed Ahmed (sir508) wrote :

omnibook-source isn't in the SYNAPTICS!

mctt (spam-corruptive) wrote :

Hi All,
I've been searching away today for a way to do this. Only way that worked was a setup by set guide/comment from Tim Richardson, The 8th comment (I think) on this link works a treat;
http://rik.rikva.nl/cms/index.php?itemid=5

ymmv

Abdusamed Ahmed (sir508) wrote :

The only reason why I was facing this issue was because I wanted to run my bluetooth. Thanks to this link http://andrewm.info/guides/27-bluetooth-support-for-toshiba-laptops-on-ubuntu my bluetooth runs

The catch is that for some reason it doesn't autostart. I have to do the codes manually everytime with wireless button 'ON'.

No more bugs for me but I still face the issue regarding this thread.

Solnyshok (solnyshok) wrote :

toshiba bios, no bluetooth in Ubuntu 10.10, my laptop is Toshiba Satellite (Portege in some markets) R630
same as reported a year ago by
=======================================
Angel Guzman Maeso wrote on 2009-11-16: #18
On Lucid yet it dont released:
$ toshset -b on
required kernel toshiba support not enabled.

Koji Ito (koji-ito) on 2010-12-03
Changed in toshset (Ubuntu):
assignee: nobody → Koji Ito (koji-ito)
assignee: Koji Ito (koji-ito) → nobody
torzsmokus (torzsmokus) wrote :

@Abdusamed, have you noticed the extra word 'option' in your command?
" sudo modprobe option omnibook ectype=15"
you should have typed
" sudo modprobe omnibook ectype=15"
instead.

i no longer use ubuntu.

On Fri, Apr 8, 2011 at 12:14 AM, torzsmokus <email address hidden>wrote:

> @Abdusamed, have you noticed the extra word 'option' in your command?
> " sudo modprobe option omnibook ectype=15"
> you should have typed
> " sudo modprobe omnibook ectype=15"
> instead.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/181374
>
> Title:
> toshset required kernel toshiba support not enabled.
>
> Status in “toshset” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: toshset
>
> I run Hardy Heron alpha 3 on a Toshiba portege m100.
>
> Toshset doesn't seem to work, I get the following error msg:
> "required kernel toshiba support not enabled."
> when trying to run toshset. The biggest problem here is that my screen
> brightness is set to lower than normal and I can't change it without this
> program.
>
> toshset has worked flawlessly since Dapper. I upgraded from Gutsy to
> Heron.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/toshset/+bug/181374/+subscribe
>

sivakumar (sivakumarpraju) wrote :

I have Bluetooth problem on a Fujitsu laptop.I jumped to ubuntu 11.04 last weak from windows 7. MY bluetooth has worked greatly before that. but now, the inbuilt Bluetooth adapter on my lap is not working. Now i thinks that it was my mistake to change windows....
I like ubuntu more than windows, so please help me........
send your help to <email address hidden>
waiting..........

Eduard Gotwig (gotwig) wrote :

still not fixed, for ubuntu 12.04!

Jezza (balingupjer) wrote :

Having problems with Brightness control using Fn + F6/F7 with dual screen, not brightness change although notify message comes up.
If i reeboot without external monitor, brightness via Fn keys work fine

Portege m700 tablet, using 12.04 64 bit (was the same with 8.10 up to 11.10)

also unable to hotswap ext. monitor, have to reboot...

Jezza (balingupjer) wrote :

ah - wondered if this patch is relavent? - http://memebeam.org/toys/ExperimentalToshibaAcpiDriver

if so, why isn't it added & included (if it hasnt been already)

Can it be done by anyone on this package/bug? Im not a programmer. :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers