Please sync torsocks from Debian

Bug #992068 reported by mejo on 2012-04-30
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
torsocks
Unknown
Unknown
torsocks (Ubuntu)
Wishlist
Unassigned

Bug Description

Hello,

since the dist-upgrade to Ubuntu Precise Pangolin (12.04), torsocks is fundamentally broken:

$ torify test
18:49:19 libtorsocks(3960): The symbol res_init() was not found in any shared library. The error reported was: not found!
18:49:19 libtorsocks(3960): The symbol res_query() was not found in any shared library. The error reported was: not found!
18:49:19 libtorsocks(3960): The symbol res_search() was not found in any shared library. The error reported was: not found!
18:49:19 libtorsocks(3960): The symbol __res_send() was not found in any shared library. The error reported was: not found!
18:49:19 libtorsocks(3960): The symbol res_querydomain() was not found in any shared library. The error reported was: not found!
[ all messages repeated three times for three process IDs ]

Unfortunately I don't have the time to further debug this issue right now.

Regards,
 jonas

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: torsocks 1.2-1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Mon Apr 30 18:48:41 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426)
SourcePackage: torsocks
UpgradeStatus: Upgraded to precise on 2012-04-29 (1 days ago)

mejo (jonas-freesources) wrote :
mejo (jonas-freesources) wrote :

It seems like the bug isn't as critical as I thought. The errors can be ignored. Still it would be great to fix it.
Gentoo already has a patch: https://bugs.gentoo.org/show_bug.cgi?id=395953#c7

For more information: http://code.google.com/p/torsocks/issues/detail?id=3

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in torsocks (Ubuntu):
status: New → Confirmed
ilf (ilf) wrote :

This is still present in torsocks 1.2-3 amd64 in Quantal release.

It's especially annoying, since this has been fixed in Debians 1.2-3, but Ubuntu 1.2-3 ships with a different /usr/lib/torsocks/libtorsocks.a and /usr/lib/torsocks/libtorsocks.so.1.0.0 than Debian.

summary: - broken in 12.04: libtorsocks: many symbols not found
+ broken in 12.04 and 12.10: libtorsocks: many symbols not found

And apt thinks the 1.2-3 from Ubuntu is more current than the 1.2-3 from Debian. So working around this needs apt-pinning :(

mejo (jonas-freesources) wrote :

I guess that a simple rebuild would fix this bug for ubuntu. This is a quite easy fix. How can I request a rebuild of torsocks for Ubuntu?

tags: added: quantal raring
tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - broken in 12.04 and 12.10: libtorsocks: many symbols not found
+ [needs-packaging] broken in 12.04 and 12.10: libtorsocks: many symbols
+ not found
Changed in torsocks (Ubuntu):
importance: Undecided → Wishlist

I've backported a 1.3-3 from saucy (!) in my PPA (https://launchpad.net/~danmbox/+archive/ppa). I still get a bunch of junk:

13:31:17 libtorsocks(28806): WARNING: The symbol res_query() was not found in any shared library with the reported error: Not Found!
  Also, we failed to find the symbol __res_query() with the reported error: Not Found
13:31:17 libtorsocks(28806): WARNING: The symbol res_search() was not found in any shared library with the reported error: Not Found!
  Also, we failed to find the symbol __res_search() with the reported error: Not Found
13:31:17 libtorsocks(28806): WARNING: The symbol res_send() was not found in any shared library with the reported error: Not Found!
  Also, we failed to find the symbol __res_send() with the reported error: Not Found
13:31:17 libtorsocks(28806): WARNING: The symbol res_querydomain() was not found in any shared library with the reported error: Not Found!
  Also, we failed to find the symbol __res_querydomain() with the reported error: Not Found

that makes stderr unreadable. This is kind of important, because the only way to get rid of the junk is to redirect stderr, but in that case you lose all errors. Is this the same bug?

Unit 193 (unit193) wrote :

Trusty had the same problem, so I went and "backported" the one from experimental, works fine. I understand these warnings aren't errors, but it's easier to rebuild than get annoyed by them. ;)

Unit 193 (unit193) wrote :

Upstream torsocks released 2.0.0 stable. I've merged it from Debian experimental. As it fixes this bug, I'm subscribing sponsors.

https://launchpad.net/~unit193/+archive/ubuntu/staging/+files/torsocks_2.0.0-0ubuntu1.dsc

Daniel Holbach (dholbach) wrote :

tor recommends torsocks and parcimonie depends on torsocks. Will they still work?

summary: - [needs-packaging] broken in 12.04 and 12.10: libtorsocks: many symbols
- not found
+ Please sync torsocks from Debian
Changed in torsocks (Ubuntu):
status: Confirmed → Incomplete
Unit 193 (unit193) wrote :

torsocks is essentially a wrapper for tor, and so I can confirm that it works with tor. parcimonie I can't say for sure, but looks like there's no Debian bugs on it, and upstream author for parcimonie is also a Debian maintainer for torsocks.

Daniel Holbach (dholbach) wrote :

This bug was fixed in the package torsocks - 2.0.0-1
Sponsored for Unit 193 (unit193)

---------------
torsocks (2.0.0-1) unstable; urgency=low

  * New upstream release. The 2.0 rewrite is considered stable.
    (Closes: #684580, #704861, #755458)
  * Put under the umbrella of the Anonymity Tools Debian Maintainers team.
  * Add watch file and upstream signing key.
  * Add debian/README.source.

 -- Jérémy Bobbio <email address hidden> Fri, 22 Aug 2014 23:37:53 +0000

torsocks (2.0.0~rc7-1) experimental; urgency=medium

  * New upstream release.
  * Refresh quilt patch.
  * Use canonical URL in Vcs-Git.

 -- intrigeri <email address hidden> Sat, 05 Apr 2014 14:23:12 +0200

torsocks (2.0.0~rc6-1) experimental; urgency=low

  * New upstream release.
  * Update debian/rules now that documentation has moved.
  * Bump Standards-Version to 3.9.5, no changes required.

 -- Jérémy Bobbio <email address hidden> Mon, 17 Mar 2014 21:39:12 +0100

torsocks (2.0.0~rc3-1) experimental; urgency=low

  * New upstream release.
  * Drop now obsolete patches.

 -- Jérémy Bobbio <email address hidden> Tue, 05 Nov 2013 10:05:13 +0100

torsocks (2.0.0~rc2-3) experimental; urgency=low

  * Add a patch to fix a deadlock in getpeername() error path.
  * Add a patch to add compatibility with GNU/kFreeBSD.
  * Add a patch to fix build on s390(x) architectures.

 -- Jérémy Bobbio <email address hidden> Thu, 24 Oct 2013 21:12:36 +0200

torsocks (2.0.0~rc2-2) experimental; urgency=low

  * Remove Pre-Depends on dpkg as its already satisfied in oldstable,
    as pointed by intrigeri.
  * Add a patch to prevent running tests that require network access.
  * Add a patch to fix undefined syscall values for x86.

 -- Jérémy Bobbio <email address hidden> Wed, 23 Oct 2013 12:43:14 +0200

torsocks (2.0.0~rc2-1) experimental; urgency=low

  * Upload new torsocks rewrite to experimental.
  * Update debian/copyright.
  * Adapt installation cleanup phase to the new upstream version.
  * Remove get-orig-source from debian/rules as we use pristine-tar.
  * Do not ship upstream changelog twice.
  * Gracefully handle the move of torsocks.conf from /etc to /etc/tor.
  * Bump Standards-Version to 3.9.4, no changes required.

 -- Jérémy Bobbio <email address hidden> Tue, 22 Oct 2013 22:24:57 +0200

Changed in torsocks (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.