Missing dependency to zip and tar packages

Bug #115396 reported by Jej on 2007-05-18
8
Affects Status Importance Assigned to Milestone
torrentflux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: torrentflux

The Torrentflux software requires the zip or tar packages to download an archive of achieved downloads. If zip/tar is not installed nothing happens when an archive is requested, and Torrentflux does not complain nor tests the presence of zip/tar on the system.

Zip and tar should be at least suggested packages, but better if they are a dependency.

Jej.

Maurizio Moriconi (bugman) wrote :

Attached debdiff should fix this issue. Thank you :).

Maurizio Moriconi (bugman) wrote :

Correct debdiff! :-)

Changed in torrentflux:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Luca Falavigna (dktrkranz) wrote :

tar package is present in almost all Ubuntu boxes since it depends on ubuntu-minimal.
*ubuntu-desktop metapackages depends on zip, so it is highly probable that such package is installed.
Is it still worth adding them to Recommends or Suggest?

Steve Kowalik (stevenk) wrote :

You can't depend on either of those packages being installed, so the explicit depends/suggests are required.

Steve Kowalik (stevenk) wrote :

This package doesn't install due to MySQL fun.

Changed in torrentflux:
status: Confirmed → Fix Committed
Emilio Pozuelo Monfort (pochu) wrote :

Steve,

Check bug 102970

Changed in torrentflux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers